View Issue Details

IDProjectCategoryLast Update
0025374AI War 2GUIAug 17, 2021 12:56 am
ReporterMetrekec Assigned Tox4000Bughunter  
Severitymajor 
Status resolvedResolutionfixed 
Product Version3.307 Art Overload And The Devourer Chrysalis 
Fixed in VersionBeta 3.510 Threads And Science 
Summary0025374: Direct Upgrade ctrl+click additional information does not show the upgrade info for upgraded centerpiece
DescriptionSome ships do not show their stats on the direct upgrade ctrl+click screen. This includes centerpieces, command stations and Asteroid Mining Powerplants. Might also affect other units.

TagsNo tags attached.

Relationships

has duplicate 0025484 resolvedx4000Bughunter Some ships don't appear in science summaries 
related to 0025420 assignedx4000Bughunter Tech Pane: "Number of Shiplines that use this tech" is incorrect 

Activities

Metrekec

Jul 6, 2021 7:29 pm

reporter  

missing_ship_info.png (1,426,325 bytes)

Daniexpert

Jul 10, 2021 11:09 am

developer   ~0062357

Yes, I wanted to check what would change on a Paralysis citadel, but it showed only the engineers and turrets, but not the centerpiece.

x4000Bughunter

Aug 12, 2021 10:58 pm

administrator   ~0062696

Is this fixed in 3.509? If anyone can confirm, that would be awesome. Thank you!

Daniexpert

Aug 13, 2021 2:35 pm

developer   ~0062709

No, still missing.
Check the screenshot as example, expert mode, orbital mining upgrade.
2021-08-13 20_32_34-AIWar2.png (162,360 bytes)   
2021-08-13 20_32_34-AIWar2.png (162,360 bytes)   

x4000Bughunter

Aug 16, 2021 4:58 pm

administrator   ~0062725

First bit:

* Fixed an issue where when you were looking at the effect of direct upgrades for a fleet, it would not show you anything that did not have an explicit ship cap. So for instance, the command station and the metal harvesters, which are a "what you have here is what is there" sort of count were being omitted from that view.

x4000Bughunter

Aug 17, 2021 12:56 am

administrator   ~0062730

Thanks!

* Added a new CalculateMarkLevelForShipLine() that does the comprehensive logic for calculating the mark level for a ship line at a fleet.
** Before some of this data was a bit embedded in other logic, making it harder to read as well as impossible to get at any way other than by actually having a ship line of the specific type in a fleet.

* The way that estimations of how many ships and how much strength you will gain from upgrades has been redone heavily.
** This takes into account the differing levels of units in your various fleets, for one thing.
** Additionally, if you have fleets with different levels and you C-click into a tech, it will show you the various levels with those total counts.
** This may fix the turret count thing? Not sure yet.

* Added a new CollapseFromFleetsForTypeDownToTypesByMarkLevel() to ship lister utils.
** Previously, we were only ever able to see the global player average mark level of things, and not the actual marks that differed based on fleet upgrades. Now it breaks it out when it needs to.

* The way that fleet ship caps are calculated is now very slightly different when there are units that use MultiplierToAllFleetCaps, such as for turrets.
** This multiplier is now used at the very end of all other multipliers, rather than at the start, which means we can now calculate differentiate caps properly without having to know the starting ship cap.
** The overall impact to gameplay probably will be slight, but will affect the number of turrets that are in each cap somewhat.
** Unless the math was done wrong somehow or there was an implication we missed, in which case let us know how many extra or fewer turrets you have...

* When you have completed a tech line, its tooltip is now more correct in that it is clear that no more upgrades will happen.

* When you're on the refund screen for techs, C-clicking and tooltips no longer say things about upgrading, they only say things about the refund. Minor confusing text details, essentially.

* A variety of windows talking about techs of ships now show the tech roman numeral after the ship name. This is a help for new players in particular, and makes it so no-one has to perfectly memorize those colors.

* The tech tooltip actually breaks out ships and defenses seprately for the line items, same as it does for the tallies and total strength counting.
** In general, there is better seperation and formatting now so you can see what the heck is going on.

* C-clicking in the science retrieval window finally shows the proper fleets and totals.

* The totals for the ship lines were indeed fixed by Badger recently, but the number of defensive lines increased was still a bit off, showing the defensive TYPES, not lines.
** The strength totals for both were accurate, though. And honestly, because of the funky way that turrets and such work, it makes more sense to show the types. So the tooltips have been updated to say that those are by type. Since they are and that makes sense.
** TLDR: ships and defenses are just handled differently because they work differently. But the strength totals are the same and are accurate either way, and the details are now correct in the tooltips and C-clicks.

* Fixed the "Retrieve Spent Science" text being offset low on its button for some reason.

Issue History

Date Modified Username Field Change
Jul 6, 2021 7:29 pm Metrekec New Issue
Jul 6, 2021 7:29 pm Metrekec File Added: missing_ship_info.png
Jul 6, 2021 7:29 pm Metrekec File Added: Missing_Direct_Upgrade_text.save
Jul 10, 2021 11:09 am Daniexpert Note Added: 0062357
Jul 10, 2021 11:09 am Daniexpert File Added: 2021-07-10 17_09_01-AIWar2.png
Jul 16, 2021 10:13 pm Daniexpert Status new => confirmed
Jul 20, 2021 7:07 am Daniexpert Relationship added related to 0025420
Aug 6, 2021 7:47 am Daniexpert Relationship added has duplicate 0025484
Aug 12, 2021 10:58 pm x4000Bughunter Assigned To => x4000Bughunter
Aug 12, 2021 10:58 pm x4000Bughunter Status confirmed => feedback
Aug 12, 2021 10:58 pm x4000Bughunter Note Added: 0062696
Aug 13, 2021 2:35 pm Daniexpert Note Added: 0062709
Aug 13, 2021 2:35 pm Daniexpert File Added: 2021-08-13 20_32_34-AIWar2.png
Aug 16, 2021 4:58 pm x4000Bughunter Note Added: 0062725
Aug 17, 2021 12:56 am x4000Bughunter Status feedback => resolved
Aug 17, 2021 12:56 am x4000Bughunter Resolution open => fixed
Aug 17, 2021 12:56 am x4000Bughunter Fixed in Version => Beta 3.510 Threads And Science
Aug 17, 2021 12:56 am x4000Bughunter Note Added: 0062730