View Issue Details

IDProjectCategoryLast Update
0025420AI War 2GUIAug 30, 2021 3:04 pm
ReporterRedPine Assigned Tox4000Bughunter  
Severityminor 
Status assignedResolutionreopened 
Product Version3.311 Engineer Multitasking 
Fixed in VersionBeta 3.510 Threads And Science 
Summary0025420: Tech Pane: "Number of Shiplines that use this tech" is incorrect
DescriptionIn this save, the "Ambush Tech" claims that it applies to 6 ships and 3 turrets, when it actually only applies to 2 shiplines and 1 turrets.
Potential shiplines I could obtain are 6 shiplines and 1 turrets.

Save uploaded.

Same issue in a second unrelated campaign. Save uploaded.

Ambush Tech is the best example of this bug, but Artillery and many other techs have the same problem.
TagsNo tags attached.

Relationships

related to 0025307 closedBadgerBadger Tech TAB showing incorrect number of Ships/Defences 
related to 0025374 resolvedx4000Bughunter Direct Upgrade ctrl+click additional information does not show the upgrade info for upgraded centerpiece 

Activities

RedPine

Jul 16, 2021 11:52 am

reporter  

savesave.savemet (73 bytes)   
UK
336466757
3749
ZSpire
Random
Difficulty 8
2
<color=#a3c1ad>TZR</color>
savesave.savemet (73 bytes)   
savesave.save (531,357 bytes)
UnresponsiveFlagship.save (379,184 bytes)
UnresponsiveFlagship.savemet (71 bytes)   
X0
3528931
5983
XSpire
Random
Difficulty 8
1
<color=#a3c1ad>TZR</color>

Exlium

Jul 17, 2021 10:11 am

reporter   ~0062486

Are the ambush ships minelayers or carriers? It might be counting the ship line they spawn in.

RedPine

Jul 19, 2021 5:45 pm

reporter   ~0062511

If you want the worst offender, scroll to the bottom of this list. Alien hull is listed 7-2, when I have 0 shiplines and 0 capturable. The only techs that aren't messed up are Disruption, Engineering, Command, Minefield, and StationKeepers. Every single other tech is showing incorrect values. My only mod is Civilian Industries. This is happening across multiple new campaigns. I don't know why this is happening.


Ambush 6 shiplines 2 turret lines. Light Minelayer Frigate, Minelayer Frigate, Ambush Turret. (Potentially, 6 shiplines and 1 turret are capturable.)

Even if the frigates are counting as 2 shiplines, that would give me 4 shiplines and 1 turret, not 6 and 2. Note that I only have the single line of Ambush turrets you start with, I haven't gotten hacked to get any more.

Artillery 3 shiplines 2 turret lines. Bombard, Siege Frigate. Concussion Turret, Holocene Missile Turret. (2 shiplines and 1 turretline capturable).

I only have one copy of each shipline, and yet one of them is being counted twice somehow.

Core 1 shipline 3 turret lines. Sentinel Gunboat, Tritium Sniper Turret. (3 turrets capturable).

Completely off.

Disruptive - this tech is behaving. I have 3 shiplines and 3 turretlines, just like it says.

Parasite 2 shiplines 1 turret line, even though I only have 1 shipline.

Melee 2 shiplines 1 turretline, even though I have 1 shipline and ZERO turrets. 2 shiplines and 2 turrets are capturable.

Piercing 2 shiplines 2 turretlines, even though I have ZERO in both! 4 shiplines, 2 turretlines, 1 mine capturable.

Raid 1 shipline, even though I have ZERO ships. Two shiplines capturable.

Splash 3-1, should be 1-1. 4 shiplines capturable.

Subterfuge 3-2, should be 1-2. 3 shiplines capturable.

Light Hull 7. Should be 1. 10 capturable.
Medium Hull 9. Should be 5. 5 capturable.
Heavy 8. Should be 4. 11 capturable.
Turret 19. Should be 13, 11 capturable.
Alien 7-2. Should be 0. 0 Capturable.

RedPine

Jul 19, 2021 6:14 pm

reporter   ~0062514

Screenshot. All of the techs (except the 5 I mentioned above) are messed up like this.
The tech pane says 7 shiplines 2 turrets, the tooltip says 2 lines of defenses, and no ships at all are listed.
I have the Hydral Hobbiests as my only outguard, but they would be expatriate not alien.
image.png (1,839,255 bytes)

RedPine

Jul 19, 2021 6:50 pm

reporter   ~0062516

Started a brand new campaign, all mods disabled, verified integrity of the install.

Game start: All techs are displaying correctly, with the following exceptions:
Orbital Mining (2-0). No lines displayed in tooltip. 2 lines affected according to the tooltip. I assume it refers to the Asteroid Home Settlement and Asteroid Power Plant, which both list Orbital Mining in their own tooltips.
Mobile Fort (2-0). No lines, 2 lines affected. I assume it refers to the two started battlestations, which both list Mobile Fort as their tech.

Captured a single planet, containing an ARS, TSS, and flagship with a Raid FFL, Veloceraptor, and Dagger (all of which are, in an extreme event of fortune, copies of my Raid starting fleet).
Techs now have the following inconsistencies:
The Tech Pane does not count a second copy of the same shipline to be a separate shipline. This might be intended behavior.
Forcefields count mobile forcefields as "ships", Home Forcefields as "defenses", and Immobile Forcefields as "defenses". This might be intended behavior.

Since the bug hasn't appeared, even after saving and reloading, I can rule out the ARS, TSS, and capturing new flagships as culprits.
I can also rule out counting the same shipline multiple times due to multiple mark levels.

If I can pinpoint the exact point in my campaign where the bug appears, that should help.

RedPine

Jul 19, 2021 7:09 pm

reporter   ~0062517

PINPOINTED!

SavePre03
Before taking my third command station, no significant anomalies in the tech pane.

SavePost03
After destroying my third command station, three expatriate ship hulls popped up in the tech pane, despite not owning any outguard. I haven't even claimed my new flagship yet - destroying the command station, in and of itself, was enough to trigger this bug.
SavePre03.save (285,293 bytes)
SavePre03.savemet (70 bytes)   
X0
360298122
549
TZXR
Random
Difficulty 8
0
<color=#a3c1ad>TZR</color>
SavePre03.savemet (70 bytes)   
SavePost03.save (292,358 bytes)
SavePost03.savemet (70 bytes)   
X0
360298122
665
TZXR
Random
Difficulty 8
0
<color=#a3c1ad>TZR</color>
SavePost03.savemet (70 bytes)   

RedPine

Jul 19, 2021 7:41 pm

reporter   ~0062518

Owning the ARS/TSS doesn't cause any problems, but after hacking them I got more of this bug.

I am quite confused as to what is going on. If you have any trouble replicating these issues, let me know and I'll drop more saves for you. Otherwise, I'll stop spamming this issue.

Daniexpert

Jul 20, 2021 7:07 am

developer   ~0062523

0025420:0062516 You should take into account this particular bug that doesn't show centerpieces, asteroid powerplants, etc. in the tech panels ( 0025374 ): that makes things harder to check.

x4000Bughunter

Aug 12, 2021 10:58 pm

administrator   ~0062697

Is this fixed in 3.509? If anyone can confirm, that would be awesome. Thank you!

x4000Bughunter

Aug 16, 2021 4:58 pm

administrator   ~0062726

First bit:

* Fixed an issue where when you were looking at the effect of direct upgrades for a fleet, it would not show you anything that did not have an explicit ship cap. So for instance, the command station and the metal harvesters, which are a "what you have here is what is there" sort of count were being omitted from that view.

x4000Bughunter

Aug 17, 2021 12:57 am

administrator   ~0062731

Thanks!

* Added a new CalculateMarkLevelForShipLine() that does the comprehensive logic for calculating the mark level for a ship line at a fleet.
** Before some of this data was a bit embedded in other logic, making it harder to read as well as impossible to get at any way other than by actually having a ship line of the specific type in a fleet.

* The way that estimations of how many ships and how much strength you will gain from upgrades has been redone heavily.
** This takes into account the differing levels of units in your various fleets, for one thing.
** Additionally, if you have fleets with different levels and you C-click into a tech, it will show you the various levels with those total counts.
** This may fix the turret count thing? Not sure yet.

* Added a new CollapseFromFleetsForTypeDownToTypesByMarkLevel() to ship lister utils.
** Previously, we were only ever able to see the global player average mark level of things, and not the actual marks that differed based on fleet upgrades. Now it breaks it out when it needs to.

* The way that fleet ship caps are calculated is now very slightly different when there are units that use MultiplierToAllFleetCaps, such as for turrets.
** This multiplier is now used at the very end of all other multipliers, rather than at the start, which means we can now calculate differentiate caps properly without having to know the starting ship cap.
** The overall impact to gameplay probably will be slight, but will affect the number of turrets that are in each cap somewhat.
** Unless the math was done wrong somehow or there was an implication we missed, in which case let us know how many extra or fewer turrets you have...

* When you have completed a tech line, its tooltip is now more correct in that it is clear that no more upgrades will happen.

* When you're on the refund screen for techs, C-clicking and tooltips no longer say things about upgrading, they only say things about the refund. Minor confusing text details, essentially.

* A variety of windows talking about techs of ships now show the tech roman numeral after the ship name. This is a help for new players in particular, and makes it so no-one has to perfectly memorize those colors.

* The tech tooltip actually breaks out ships and defenses seprately for the line items, same as it does for the tallies and total strength counting.
** In general, there is better seperation and formatting now so you can see what the heck is going on.

* C-clicking in the science retrieval window finally shows the proper fleets and totals.

* The totals for the ship lines were indeed fixed by Badger recently, but the number of defensive lines increased was still a bit off, showing the defensive TYPES, not lines.
** The strength totals for both were accurate, though. And honestly, because of the funky way that turrets and such work, it makes more sense to show the types. So the tooltips have been updated to say that those are by type. Since they are and that makes sense.
** TLDR: ships and defenses are just handled differently because they work differently. But the strength totals are the same and are accurate either way, and the details are now correct in the tooltips and C-clicks.

* Fixed the "Retrieve Spent Science" text being offset low on its button for some reason.

RedPine

Aug 30, 2021 3:01 pm

reporter   ~0062778

Issue persists. I don't see an option to attach screenshots or saves, is that because the issue is marked as closed?

The worst offender is "Melee", which claims to apply to 2 shiplines and 2 turrets despite me owning no melee ships in either category.

Again, producing the bug is easy. Start any game under any settings, capture a few planets, and the techpane will be incorrect. If anyone else has difficulty replicating this bug, please let me know so we can figure out what's going on. If this is a bug specific to me, I would like to know.

RedPine

Aug 30, 2021 3:04 pm

reporter   ~0062779

Here we go. Exact same issue, applies to nearly all techs with no discernable pattern. The more planets I take, the worse it gets.
20210830125613_1.jpg (391,901 bytes)

Issue History

Date Modified Username Field Change
Jul 16, 2021 11:52 am RedPine New Issue
Jul 16, 2021 11:52 am RedPine File Added: savesave.savemet
Jul 16, 2021 11:52 am RedPine File Added: savesave.save
Jul 16, 2021 11:52 am RedPine File Added: UnresponsiveFlagship.save
Jul 16, 2021 11:52 am RedPine File Added: UnresponsiveFlagship.savemet
Jul 16, 2021 10:18 pm Daniexpert Relationship added related to 0025307
Jul 17, 2021 10:11 am Exlium Note Added: 0062486
Jul 19, 2021 5:45 pm RedPine Note Added: 0062511
Jul 19, 2021 6:14 pm RedPine Note Added: 0062514
Jul 19, 2021 6:14 pm RedPine File Added: image.png
Jul 19, 2021 6:22 pm Daniexpert Status new => acknowledged
Jul 19, 2021 6:22 pm Daniexpert Category Graphical Bug => GUI
Jul 19, 2021 6:50 pm RedPine Note Added: 0062516
Jul 19, 2021 7:09 pm RedPine Note Added: 0062517
Jul 19, 2021 7:09 pm RedPine File Added: SavePre03.save
Jul 19, 2021 7:09 pm RedPine File Added: SavePre03.savemet
Jul 19, 2021 7:09 pm RedPine File Added: SavePost03.save
Jul 19, 2021 7:09 pm RedPine File Added: SavePost03.savemet
Jul 19, 2021 7:41 pm RedPine Note Added: 0062518
Jul 20, 2021 7:07 am Daniexpert Note Added: 0062523
Jul 20, 2021 7:07 am Daniexpert Relationship added related to 0025374
Aug 12, 2021 10:58 pm x4000Bughunter Assigned To => x4000Bughunter
Aug 12, 2021 10:58 pm x4000Bughunter Status acknowledged => feedback
Aug 12, 2021 10:58 pm x4000Bughunter Note Added: 0062697
Aug 16, 2021 4:58 pm x4000Bughunter Note Added: 0062726
Aug 17, 2021 12:57 am x4000Bughunter Status feedback => resolved
Aug 17, 2021 12:57 am x4000Bughunter Resolution open => fixed
Aug 17, 2021 12:57 am x4000Bughunter Fixed in Version => Beta 3.510 Threads And Science
Aug 17, 2021 12:57 am x4000Bughunter Note Added: 0062731
Aug 30, 2021 3:01 pm RedPine Status resolved => feedback
Aug 30, 2021 3:01 pm RedPine Resolution fixed => reopened
Aug 30, 2021 3:01 pm RedPine Note Added: 0062778
Aug 30, 2021 3:04 pm RedPine Note Added: 0062779
Aug 30, 2021 3:04 pm RedPine File Added: 20210830125613_1.jpg
Aug 30, 2021 3:04 pm RedPine Status feedback => assigned