View Issue Details

IDProjectCategoryLast Update
0025484AI War 2Bug - GameplayAug 17, 2021 12:56 am
ReporterEcthelon Assigned Tox4000Bughunter  
Severityminor 
Status resolvedResolutionduplicate 
Product VersionBeta 3.504 Multiplayer Achievements 
Fixed in VersionBeta 3.510 Threads And Science 
Summary0025484: Some ships don't appear in science summaries
DescriptionSometimes the list of what lines will be upgraded by a tech seem incomplete.

For example, in the attached save I own a parasite citadel but the mobile fort tech states that I don't have anything applicable to upgrade (despite a strength estimate of the upgrade).
TagsNo tags attached.

Relationships

duplicate of 0025374 resolvedx4000Bughunter Direct Upgrade ctrl+click additional information does not show the upgrade info for upgraded centerpiece 

Activities

Ecthelon

Aug 6, 2021 7:15 am

reporter  

Manual.save (278,735 bytes)

x4000Bughunter

Aug 12, 2021 10:58 pm

administrator   ~0062695

Is this fixed in 3.509? If anyone can confirm, that would be awesome. Thank you!

Ecthelon

Aug 13, 2021 4:01 am

reporter   ~0062706

I'm afraid this old save still shows the same issue. The parasite citadel isn't counted in the list of lines that will be upgraded for "mobile fort". In fact there isn't even a strength estimate for the tech any more.
Manual 2.save (460,983 bytes)

x4000Bughunter

Aug 16, 2021 4:58 pm

administrator   ~0062727

First bit:

* Fixed an issue where when you were looking at the effect of direct upgrades for a fleet, it would not show you anything that did not have an explicit ship cap. So for instance, the command station and the metal harvesters, which are a "what you have here is what is there" sort of count were being omitted from that view.

x4000Bughunter

Aug 17, 2021 12:56 am

administrator   ~0062729

Thanks!

* Added a new CalculateMarkLevelForShipLine() that does the comprehensive logic for calculating the mark level for a ship line at a fleet.
** Before some of this data was a bit embedded in other logic, making it harder to read as well as impossible to get at any way other than by actually having a ship line of the specific type in a fleet.

* The way that estimations of how many ships and how much strength you will gain from upgrades has been redone heavily.
** This takes into account the differing levels of units in your various fleets, for one thing.
** Additionally, if you have fleets with different levels and you C-click into a tech, it will show you the various levels with those total counts.
** This may fix the turret count thing? Not sure yet.

* Added a new CollapseFromFleetsForTypeDownToTypesByMarkLevel() to ship lister utils.
** Previously, we were only ever able to see the global player average mark level of things, and not the actual marks that differed based on fleet upgrades. Now it breaks it out when it needs to.

* The way that fleet ship caps are calculated is now very slightly different when there are units that use MultiplierToAllFleetCaps, such as for turrets.
** This multiplier is now used at the very end of all other multipliers, rather than at the start, which means we can now calculate differentiate caps properly without having to know the starting ship cap.
** The overall impact to gameplay probably will be slight, but will affect the number of turrets that are in each cap somewhat.
** Unless the math was done wrong somehow or there was an implication we missed, in which case let us know how many extra or fewer turrets you have...

* When you have completed a tech line, its tooltip is now more correct in that it is clear that no more upgrades will happen.

* When you're on the refund screen for techs, C-clicking and tooltips no longer say things about upgrading, they only say things about the refund. Minor confusing text details, essentially.

* A variety of windows talking about techs of ships now show the tech roman numeral after the ship name. This is a help for new players in particular, and makes it so no-one has to perfectly memorize those colors.

* The tech tooltip actually breaks out ships and defenses seprately for the line items, same as it does for the tallies and total strength counting.
** In general, there is better seperation and formatting now so you can see what the heck is going on.

* C-clicking in the science retrieval window finally shows the proper fleets and totals.

* The totals for the ship lines were indeed fixed by Badger recently, but the number of defensive lines increased was still a bit off, showing the defensive TYPES, not lines.
** The strength totals for both were accurate, though. And honestly, because of the funky way that turrets and such work, it makes more sense to show the types. So the tooltips have been updated to say that those are by type. Since they are and that makes sense.
** TLDR: ships and defenses are just handled differently because they work differently. But the strength totals are the same and are accurate either way, and the details are now correct in the tooltips and C-clicks.

* Fixed the "Retrieve Spent Science" text being offset low on its button for some reason.

Issue History

Date Modified Username Field Change
Aug 6, 2021 7:15 am Ecthelon New Issue
Aug 6, 2021 7:15 am Ecthelon File Added: Manual.save
Aug 6, 2021 7:47 am Daniexpert Relationship added duplicate of 0025374
Aug 6, 2021 7:56 am Daniexpert Status new => confirmed
Aug 6, 2021 7:56 am Daniexpert Description Updated
Aug 12, 2021 10:58 pm x4000Bughunter Assigned To => x4000Bughunter
Aug 12, 2021 10:58 pm x4000Bughunter Status confirmed => feedback
Aug 12, 2021 10:58 pm x4000Bughunter Note Added: 0062695
Aug 13, 2021 4:01 am Ecthelon Note Added: 0062706
Aug 13, 2021 4:01 am Ecthelon File Added: Manual 2.save
Aug 13, 2021 4:01 am Ecthelon Status feedback => assigned
Aug 16, 2021 4:58 pm x4000Bughunter Note Added: 0062727
Aug 17, 2021 12:56 am x4000Bughunter Status assigned => resolved
Aug 17, 2021 12:56 am x4000Bughunter Resolution open => duplicate
Aug 17, 2021 12:56 am x4000Bughunter Fixed in Version => Beta 3.510 Threads And Science
Aug 17, 2021 12:56 am x4000Bughunter Note Added: 0062729