View Issue Details

IDProjectCategoryLast Update
0019343AI War 2[All Projects] Bug - GameplayApr 10, 2018 9:28 pm
ReporterMckloshivAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.701 
Fixed in Version0.705 
Summary0019343: Skipping Lobby Screen
DescriptionIf you open up the settings from the title screen and then cancel out of it and click on start new game, it will instantly spawn in the game; bypassing the lobby screen. You can still quit the game and go back to the title to start a new game and successfully enter the lobby after that, though.
TagsNo tags attached.

Relationships

has duplicate 0019327 closedkeith.lamothe Game starts immediately, skipping Selection Screen 
has duplicate 0019382 closedkeith.lamothe New game setup screen is skipped if "settings" are accessed before pressing "start new game" 

Activities

x4000Bughunter

Jan 26, 2018 12:56 pm

administrator   ~0046736

I can confirm that this still happens in 0.702, although not reliably. Sometimes it does, other times not, and my mouse is not anywhere near the Start Game button.

x4000Bughunter

Jan 29, 2018 9:55 am

administrator   ~0046766

0019382 might be the repro case we need, not sure.

x4000Bughunter

Jan 31, 2018 11:06 pm

administrator   ~0046801

Badger, did your fix to something related to this in 0.703 also fix this?

BadgerBadger

Feb 1, 2018 8:57 am

manager   ~0046803

I only changed stuff in the Settings menu, so I don't see why that would have fixed this. If it did that would be great though!

x4000Bughunter

Feb 1, 2018 9:26 am

administrator   ~0046805

Got it -- thanks!

BadgerBadger

Feb 2, 2018 3:34 pm

manager   ~0046833

Neither Mckloshiv nor I can recreate this on .703 (I spoke with him on discord). We can leave it open for a bit in case someone else finds a scenario, otherwise it looks like 0019382 must have somehow fixed this too.

x4000Bughunter

Feb 2, 2018 3:37 pm

administrator   ~0046834

Marking as feedback, then. Sweet!

Dune

Feb 2, 2018 5:28 pm

administrator   ~0046836

Okay, I moved this to Limbo in Trello

x4000Bughunter

Feb 2, 2018 11:10 pm

administrator   ~0046842

Thanks! Good catch.

BadgerBadger

Apr 10, 2018 9:28 pm

manager   ~0047410

This one hasn't cropped up for months

Issue History

Date Modified Username Field Change
Jan 19, 2018 1:20 pm Mckloshiv New Issue
Jan 19, 2018 4:27 pm BadgerBadger Relationship added has duplicate 0019327
Jan 24, 2018 5:00 pm x4000Bughunter Assigned To => keith.lamothe
Jan 24, 2018 5:00 pm x4000Bughunter Status new => assigned
Jan 26, 2018 12:56 pm x4000Bughunter Note Added: 0046736
Jan 28, 2018 1:06 pm BadgerBadger Relationship added has duplicate 0019382
Jan 29, 2018 9:55 am x4000Bughunter Note Added: 0046766
Jan 31, 2018 11:06 pm x4000Bughunter Assigned To keith.lamothe => BadgerBadger
Jan 31, 2018 11:06 pm x4000Bughunter Status assigned => feedback
Jan 31, 2018 11:06 pm x4000Bughunter Note Added: 0046801
Feb 1, 2018 8:57 am BadgerBadger Note Added: 0046803
Feb 1, 2018 9:26 am x4000Bughunter Note Added: 0046805
Feb 1, 2018 9:26 am x4000Bughunter Assigned To BadgerBadger => keith.lamothe
Feb 1, 2018 9:26 am x4000Bughunter Status feedback => assigned
Feb 2, 2018 3:34 pm BadgerBadger Note Added: 0046833
Feb 2, 2018 3:37 pm x4000Bughunter Status assigned => feedback
Feb 2, 2018 3:37 pm x4000Bughunter Note Added: 0046834
Feb 2, 2018 5:28 pm Dune Note Added: 0046836
Feb 2, 2018 11:10 pm x4000Bughunter Note Added: 0046842
Apr 10, 2018 9:28 pm BadgerBadger Status feedback => resolved
Apr 10, 2018 9:28 pm BadgerBadger Resolution open => fixed
Apr 10, 2018 9:28 pm BadgerBadger Fixed in Version => 0.705
Apr 10, 2018 9:28 pm BadgerBadger Note Added: 0047410