View Issue Details

IDProjectCategoryLast Update
0019382AI War 2[All Projects] GUIJan 29, 2018 8:00 pm
ReporterBummeriAssigned Tokeith.lamothe 
Severitymajor 
Status closedResolutionduplicate 
Product Version0.702 Activating Mk1 Grinding Machine 
Fixed in Version0.703 
Summary0019382: New game setup screen is skipped if "settings" are accessed before pressing "start new game"
DescriptionWhat happens:
accessing "settings" first, breaks "start new game" by starting the game without any setup screen.

What should happen:
Accessing settings menu should not affect start new game buttons behaviour, After accessing "settings", "Start new game" should still give normal setup screen for the game.

Repro Steps:
1. Start game
2. Press "settings" in mainmenu and then cancel
3. Press "Start new game"
4. A new game starts without any setup of planets selection or game settings screen appearing.
TagsNo tags attached.

Relationships

duplicate of 0019343 resolvedkeith.lamothe Skipping Lobby Screen 

Activities

Dune

Jan 28, 2018 10:07 am

administrator   ~0046760

This my be a duplicate of an earlier bug report, but I can seem to find it at the moment. This definitely needs to be checked out,

BadgerBadger

Jan 29, 2018 8:00 pm

manager   ~0046776

Fixed. I don't think this resolves 0019343 though.

Issue History

Date Modified Username Field Change
Jan 28, 2018 7:44 am Bummeri New Issue
Jan 28, 2018 10:06 am Dune Assigned To => x4000Bughunter
Jan 28, 2018 10:06 am Dune Status new => assigned
Jan 28, 2018 10:07 am Dune Status assigned => considering
Jan 28, 2018 10:07 am Dune Note Added: 0046760
Jan 28, 2018 1:06 pm BadgerBadger Relationship added duplicate of 0019343
Jan 29, 2018 9:55 am x4000Bughunter Assigned To x4000Bughunter => keith.lamothe
Jan 29, 2018 9:55 am x4000Bughunter Status considering => assigned
Jan 29, 2018 8:00 pm BadgerBadger Status assigned => closed
Jan 29, 2018 8:00 pm BadgerBadger Resolution open => duplicate
Jan 29, 2018 8:00 pm BadgerBadger Fixed in Version => 0.703
Jan 29, 2018 8:00 pm BadgerBadger Note Added: 0046776