View Issue Details

IDProjectCategoryLast Update
0026744AI War 2Bug - OtherMay 19, 2022 10:33 am
ReporterEluthena Assigned ToDaniexpert  
Severityminor 
Status resolvedResolutionfixed 
Product Version4.006 Careful Of That Federation! 
Fixed in Version5.012 Necromancer Balance 
Summary0026744: Galaxy view significant graphical (and intel/visibility) problems when loading one save after another
DescriptionThe galaxy view becomes messy, incorrect, and/or reveals information you shouldn't be able to see when you load one save, then load a save from a different campaign. Various examples below, including one where all hidden planets have been revealed when loading a save with "hide unexplored planets" enabled after loading one with it disabled.

This can only be fixed by completely closing the game/application and restarting it. Loading another save just changes the particular graphical glitches happening.
TagsNo tags attached.

Relationships

related to 0026699 resolvedDaniexpert Roguelike option "Hide Unexplored Planets" bugged when reloading earlier save 
related to 0026896 resolvedChris_McElligottPark Crash report 
related to 0027021 resolvedDaniexpert galaxy map showing non-existent planet names 

Activities

Eluthena

Mar 17, 2022 4:22 pm

reporter  

Screenshot (441).png (2,828,956 bytes)
Screenshot (443).png (3,311,851 bytes)
Screenshot (442).png (3,104,424 bytes)

Eluthena

Mar 17, 2022 6:24 pm

reporter   ~0065498

Also noticed this from another bug report: This makes enemy units and neutral units visible in the planet sidebar of unexplored planets. So not just a graphical bug.
Screenshot (444).png (1,066,712 bytes)

Daniexpert

Apr 22, 2022 10:11 am

manager   ~0066257

I'm unable to reproduce these visual bugs. Has anyone had them happen lately?
Regarding 0026744:0065498, it's not showing on the sidebar what's on that planet, but what was on the previously selected planet (in fact you can see the added text "No vision here"). I'll fix that in the meanwhile.

Daniexpert

Apr 22, 2022 10:20 am

manager   ~0066259

0026699 Explains how to reproduce it, so we're good on that.

Eluthena

Apr 28, 2022 10:30 pm

reporter   ~0066537

It seems better than before, but I am still seeing the issue where loading a save with "hide unexplored planets" turned on after loading a save with it turned off causes hidden planets to be revealed.
Additional note, I noticed this doesn't happen when creating a new campaign with "hide unexplored planets" turned on, it only happens if you load an existing save.

Daniexpert

May 19, 2022 10:29 am

manager   ~0066810

* Fixed a graphical bug that showed unexplored planets, links and names when reloading previous saves that had the "hide unexplored planets" setting enabled.
** This should also fix similar bugs with planet names from previous campaigns appearing on new ones created during the same game session.

Thank you!

Issue History

Date Modified Username Field Change
Mar 17, 2022 4:22 pm Eluthena New Issue
Mar 17, 2022 4:22 pm Eluthena File Added: Screenshot (441).png
Mar 17, 2022 4:22 pm Eluthena File Added: Screenshot (443).png
Mar 17, 2022 4:22 pm Eluthena File Added: Screenshot (442).png
Mar 17, 2022 6:22 pm Eluthena Summary Galaxy view significant graphical problems when loading one save after another => Galaxy view significant graphical (and intel/visibility) problems when loading one save after another
Mar 17, 2022 6:22 pm Zer0h1nder Relationship added related to 0026699
Mar 17, 2022 6:24 pm Eluthena Note Added: 0065498
Mar 17, 2022 6:24 pm Eluthena File Added: Screenshot (444).png
Mar 17, 2022 6:25 pm Eluthena Category Graphical Bug => Bug - Other
Apr 4, 2022 11:47 am Daniexpert Assigned To => Daniexpert
Apr 4, 2022 11:47 am Daniexpert Status new => assigned
Apr 10, 2022 4:21 pm BadgerBadger Relationship added related to 0026896
Apr 10, 2022 4:22 pm BadgerBadger Sticky Issue No => Yes
Apr 17, 2022 8:19 pm Daniexpert Relationship added related to 0027021
Apr 22, 2022 10:11 am Daniexpert Status assigned => requires feedback
Apr 22, 2022 10:11 am Daniexpert Note Added: 0066257
Apr 22, 2022 10:20 am Daniexpert Note Added: 0066259
Apr 28, 2022 10:30 pm Eluthena Note Added: 0066537
May 19, 2022 10:29 am Daniexpert Note Added: 0066810
May 19, 2022 10:29 am Daniexpert Status requires feedback => resolved
May 19, 2022 10:29 am Daniexpert Fixed in Version => 5.011 Autobuild And Home Ark Strength
May 19, 2022 10:29 am Daniexpert Resolution open => fixed
May 19, 2022 10:33 am Daniexpert Fixed in Version 5.011 Autobuild And Home Ark Strength => 5.012 Necromancer Balance