View Issue Details

IDProjectCategoryLast Update
0023773AI War 2[All Projects] Bug - OtherNov 11, 2020 2:58 pm
ReportertadrinthAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version2.507 Bugfixes 
Fixed in Version2.630 Arbitrary Icon Inclusion And Weapon Exclusion 
Summary0023773: is_partial_record doesn't seem to be copying old attributes for GameEntity records
DescriptionTried to mod the starting number of pike turrets on human command stations.

As I understand it, the following should keep everything on the Pike Turret the same, except amend the min and max fleet memberships.

Instead, I think this wipes all the attributes of the Pike Turret; certainly everything that's supposed to copy from the Pike fails to do so.

<?xml version="1.0" encoding="utf-8"?>
<root>
   <entity name="PikeTurret" is_partial_record="true">
    <fleet_membership name="PlayerHomeCommand" min="12" max="12" is_partial_record="true"/>
  </entity>
</root>

I was able to get it to work by putting all the attributes on the PikeTurret, but I'm pretty sure that's not how this is supposed to work.
TagsNo tags attached.

Relationships

related to 0023958 resolvedx4000Bughunter Modding - is_partial_record giving troubles 

Activities

ParadoxSong

Nov 7, 2020 6:10 pm

reporter   ~0059509

Is_partial_record currently doesn't function, see #modding on the discord for advice from the community in the meantime!

x4000Bughunter

Nov 9, 2020 12:11 pm

administrator   ~0059513

A partial record on a fleet membership will mean nothing, as a fleet membership is not a main node. If you set <entity name="PikeTurret" is_partial_record="true">, then it should only apply new things from that, but if there are errors then I guess let me know.

Essentially, if you take is_partial_record="true" off the fleet membership but otherwise leave your stuff the same, I'd expect it to work now, in the new version: https://wiki.arcengames.com/index.php?title=AI_War_2:Multiplayer_Alpha_And_Beta#Giant_Overhaul_Of_Xml_Parsing_For_Accuracy_And_Speed

tadrinth

Nov 9, 2020 12:38 pm

reporter   ~0059515

Awesome, I will test once the new version comes out.

x4000Bughunter

Nov 10, 2020 9:33 am

administrator   ~0059530

Sounds good! It's out now, so fingers crossed. It has fixed all the other broken mods, so hopefully it also gets this one.

tadrinth

Nov 11, 2020 1:30 pm

reporter   ~0059557

Yep, mod now works without having to copy the full turret definitions! Been playing a test game and I'm quite pleased with it, I'll post the updated version on the forums at some point.

x4000Bughunter

Nov 11, 2020 2:58 pm

administrator   ~0059559

Sweet! That's wonderful news. :)

There's some new funkiness going on in 0024090, which I am looking into. But hopefully that will be fixed today also.

Issue History

Date Modified Username Field Change
Sep 19, 2020 12:41 am tadrinth New Issue
Sep 22, 2020 11:22 am tadrinth Description Updated View Revisions
Nov 7, 2020 6:09 pm ParadoxSong Relationship added duplicate of 0023958
Nov 7, 2020 6:10 pm ParadoxSong Note Added: 0059509
Nov 9, 2020 12:00 pm TechSY730 Relationship replaced related to 0023958
Nov 9, 2020 12:11 pm x4000Bughunter Assigned To => x4000Bughunter
Nov 9, 2020 12:11 pm x4000Bughunter Status new => feedback
Nov 9, 2020 12:11 pm x4000Bughunter Note Added: 0059513
Nov 9, 2020 12:38 pm tadrinth Note Added: 0059515
Nov 9, 2020 12:38 pm tadrinth Status feedback => assigned
Nov 10, 2020 9:33 am x4000Bughunter Note Added: 0059530
Nov 11, 2020 1:30 pm tadrinth Note Added: 0059557
Nov 11, 2020 2:58 pm x4000Bughunter Status assigned => resolved
Nov 11, 2020 2:58 pm x4000Bughunter Resolution open => fixed
Nov 11, 2020 2:58 pm x4000Bughunter Fixed in Version => 2.630 Arbitrary Icon Inclusion And Weapon Exclusion
Nov 11, 2020 2:58 pm x4000Bughunter Note Added: 0059559