View Issue Details

IDProjectCategoryLast Update
0022965AI War 2[All Projects] Bug - GameplayMar 21, 2020 4:24 pm
ReporterArnaudBAssigned Tox4000Bughunter 
Severityminor 
Status assignedResolutionopen 
Product Version2.008 Transport Loading Hotfix 
Fixed in Version 
Summary0022965: Extremely severe targeting delays with Spire Fleet
DescriptionUpon noticing that my fleet took a long time to kill 50 Strength when I have hundreds strength worth of Spire firepower with a Mark IV military station AND turrets around I investigated a bit.

I sent the fleet to a nearby planet and looked upon their firing time. For all ships from frigate to Battleships, there are IMMENSE delays in firing weapons for many of the ships. This also happened on planets with enemy turrets in range and such.

Spire ships with 1 second delay have as much as 18 seconds "time since last fired" despite having enemies in range. Even straight in the middle of enemies forces, multiple ships including battleships have 4 or 6 seconds since last fired.

I am unsure if this was always the case or if this is happening now due to the large amount of units around in the galaxy. This is the quick start scenario "You Belong to Us" by Zeus.
TagsNo tags attached.

Relationships

related to 0023049 new Oddly bad performance. 

Activities

ArnaudB

Mar 7, 2020 7:29 am

reporter  

Rush 1.rar (1,126,497 bytes)
20200307132058_1.jpg (483,572 bytes)
20200307132051_1.jpg (534,410 bytes)
20200307131947_1.jpg (530,099 bytes)
20200307131956_1.jpg (531,258 bytes)
20200307132007_1.jpg (525,054 bytes)

BadgerBadger

Mar 7, 2020 11:24 am

manager   ~0056382

At a guess, the targeting threads are taking forever to run.

ArnaudB

Mar 7, 2020 1:13 pm

reporter   ~0056384

Worth noting that the AI ships on the planet didn't have those delays. They had the same "since last fired" as their weapon delay.

x4000Bughunter

Mar 7, 2020 6:18 pm

administrator   ~0056386

The targeting threads might still be slow as the culprit, since the AI ships probably are able to shoot at large targets for quite a while before they die. So they would be continuously firing thanks to not needing new targets, or being able to use targets from their list for a goodly while even if the very first target dies. The spire are vaporizing all the things they hit, probably, so their target lists become invalid after 1 shot probably.

Usually the targeting list should take around half a second at most to generate, and then be delayed by another 200ms or so after that before it gets applied. In the escape menu, you should see a Targeting Cycle count and then a time for the last targeting cycle go past. You have to hit spacebar while in the escape menu to unpause and see it going. I am guessing that those are taking 18 seconds or so for some reason on your machine. I can look into it more on Monday, but if you are able to confirm what you're seeing in those thread timings in the escape menu that would be useful data. My machine might not perform the same as I might have more cores than you, or whatever other advantage.

Thanks!

ArnaudB

Mar 8, 2020 7:17 am

reporter   ~0056390

After some testing the targeting cycle can climb to 12-16 seconds when in planets with lots of strength. However I caught multiple cases of Spire ships in the middle of enemies ships, with 4+ seconds since last fired, with 'time since last targeting cycle' between 0.6 and 1.7 seconds.

My CPU is good:
processorType: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz
processorCount: 12
processorFrequency: 2592
systemMemorySize: 16187
It's top-end for a laptop computer. It shouldn't have problems dealing with the simulation (and I am still at 500% simulation speed). Maybe it counts the 'time since last fired' in game-time and the cycle in real-time?

20200308121037_1.jpg (341,540 bytes)
20200308121031_1.jpg (511,435 bytes)
20200308121042_1.jpg (339,304 bytes)

x4000Bughunter

Mar 8, 2020 12:20 pm

administrator   ~0056395

Exactly so, the in game stats are all in game time, whereas the targeting time and similar is in real time. So 1.7s of real-time at 500% game speed is over 8 seconds of game time. I would expect big delays there.

Your processor is stronger than mine, so that shouldn't be the issue. It sounds like something is slowing down the targeting cycles in a lot of cases, so we will have to investigate those. Thanks for the report!

Cyborg

Mar 8, 2020 6:42 pm

reporter   ~0056402

This is happpening to me also with bombard ships.

Issue History

Date Modified Username Field Change
Mar 7, 2020 7:29 am ArnaudB New Issue
Mar 7, 2020 7:29 am ArnaudB File Added: 20200307132058_1.jpg
Mar 7, 2020 7:29 am ArnaudB File Added: 20200307131956_1.jpg
Mar 7, 2020 7:29 am ArnaudB File Added: 20200307132007_1.jpg
Mar 7, 2020 7:29 am ArnaudB File Added: 20200307132051_1.jpg
Mar 7, 2020 7:29 am ArnaudB File Added: 20200307131947_1.jpg
Mar 7, 2020 7:29 am ArnaudB File Added: Rush 1.rar
Mar 7, 2020 11:24 am BadgerBadger Note Added: 0056382
Mar 7, 2020 1:13 pm ArnaudB Note Added: 0056384
Mar 7, 2020 6:18 pm x4000Bughunter Note Added: 0056386
Mar 8, 2020 7:17 am ArnaudB File Added: 20200308121042_1.jpg
Mar 8, 2020 7:17 am ArnaudB File Added: 20200308121037_1.jpg
Mar 8, 2020 7:17 am ArnaudB File Added: 20200308121031_1.jpg
Mar 8, 2020 7:17 am ArnaudB Note Added: 0056390
Mar 8, 2020 12:20 pm x4000Bughunter Note Added: 0056395
Mar 8, 2020 12:21 pm x4000Bughunter Assigned To => x4000Bughunter
Mar 8, 2020 12:21 pm x4000Bughunter Status new => assigned
Mar 8, 2020 6:42 pm Cyborg Note Added: 0056402
Mar 21, 2020 4:24 pm BadgerBadger Relationship added related to 0023049