View Issue Details

IDProjectCategoryLast Update
0022732AI War 2[All Projects] Bug - OtherApr 1, 2020 3:43 pm
ReporterNRSirLimboAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionduplicate 
Product Version1.321 Enjoy Your Break, Voice Lady 
Fixed in Version2.016 Thunderchild 
Summary0022732: XML Modding bug: First default starter fleet is frozen until changed at least once
DescriptionNote: This issue was only exposed for XML Modding purposes. Just extract the GalacticConquest.zip into the XML mod folder.

Long story short: When changing out all the default fleet designs with my new ones that featured new variants of transport flagships it became evident that unless the chosen starter fleet is changed at least once the flagship spawned will ALWAYS be the default variant.

So as in the screenshot the starter fleet is the "War Guard Alpha" which comes in a coordinator flagship. Only that when it is spawned without first selecting a different fleet and then re-selecting the War Guard Alpha the normal transport flagship still gets spawned.

Probably just some issue with not refreshing things.
TagsNo tags attached.

Relationships

duplicate of 0023052 resolvedx4000Bughunter Bug with Faction interface: Choice Boxes revert to default icon despite displaying otherwise 

Activities

NRSirLimbo

Jan 31, 2020 11:12 pm

reporter  

20200201051026_1.jpg (397,141 bytes)
GalacticConquest.zip (37,011 bytes)
20200201051019_1.jpg (316,970 bytes)

NRSirLimbo

Feb 1, 2020 7:13 am

reporter   ~0055853

As far as I've tested this bug seems to be mostly harmless, but it prevents auto-building of any type (station-keepers, engineers, factories,...)

NRSirLimbo

Feb 1, 2020 8:12 am

reporter   ~0055854

Edit: Ignore the upper one. Wrote it in the wrong issue...

x4000Bughunter

Apr 1, 2020 3:43 pm

administrator   ~0056648

Thanks!

* We're now using the ability to load savegamems into the lobby to make it so that every time you open the lobby, it now has the selected options that you last used -- factions and otherwise.
** This fixes several bugs with things showing values that were not a match to the underlying data, as well as making it a lot more convenient in general.

Issue History

Date Modified Username Field Change
Jan 31, 2020 11:12 pm NRSirLimbo New Issue
Jan 31, 2020 11:12 pm NRSirLimbo File Added: 20200201051026_1.jpg
Jan 31, 2020 11:12 pm NRSirLimbo File Added: 20200201051019_1.jpg
Jan 31, 2020 11:12 pm NRSirLimbo File Added: GalacticConquest.zip
Feb 1, 2020 7:13 am NRSirLimbo Note Added: 0055853
Feb 1, 2020 8:12 am NRSirLimbo Note Added: 0055854
Mar 22, 2020 11:20 am NRSirLimbo Relationship added duplicate of 0023052
Apr 1, 2020 3:43 pm x4000Bughunter Assigned To => x4000Bughunter
Apr 1, 2020 3:43 pm x4000Bughunter Status new => resolved
Apr 1, 2020 3:43 pm x4000Bughunter Resolution open => duplicate
Apr 1, 2020 3:43 pm x4000Bughunter Fixed in Version => 2.016 Thunderchild
Apr 1, 2020 3:43 pm x4000Bughunter Note Added: 0056648