View Issue Details

IDProjectCategoryLast Update
0022416AI War 2[All Projects] Bug - GameplayJun 5, 2020 1:31 pm
ReporterAdmiralAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version1.024 After Death 
Fixed in VersionBeta 2.062 Savegame/Networking Data Compaction 
Summary0022416: Cannot assign "None" hotkey to a fleet
Description(This has been happening on all versions since 1.0, as far as I can recall.)

If I assign a fleet the hotkey "None," the system after a few ticks will re-assign it the next free numerical hotkey.
TagsNo tags attached.

Relationships

related to 0022535 new Add more Fleet Groups 
related to 0022251 resolvedx4000Bughunter Cannot set hotkey to None for flagships 
related to 0022935 resolvedx4000Bughunter Fleet hotkey cannot be set to "None" 

Activities

x4000Bughunter

Jan 6, 2020 4:04 pm

administrator   ~0055357

Yep, sorry about this one. One of the things I need to clean up; you've identified a goodly such list!

Admiral

Jan 6, 2020 4:53 pm

reporter   ~0055363

Maybe I will rename myself to AdmiralBughunter. :)

Obviously with the duplicate, okay to close one or the other.

x4000Bughunter

Jan 6, 2020 4:55 pm

administrator   ~0055364

Oh, I don't mind the duplicates. And I appreciate all the bug reports even if I have been distracted from most of the ones at this level in the short term. :)

x4000Bughunter

Jun 5, 2020 1:31 pm

administrator   ~0057200

Thanks!

* Fixed a very old and very annoying bug where any strike or officer fleets you tried to assign to the None hotkey would reassign themselves a second later.

Issue History

Date Modified Username Field Change
Dec 24, 2019 12:05 pm Admiral New Issue
Jan 6, 2020 3:53 pm Admiral Relationship added related to 0022535
Jan 6, 2020 4:01 pm RocketAssistedPuffin Relationship added duplicate of 0022251
Jan 6, 2020 4:04 pm x4000Bughunter Note Added: 0055357
Jan 6, 2020 4:53 pm Admiral Note Added: 0055363
Jan 6, 2020 4:55 pm x4000Bughunter Note Added: 0055364
Mar 5, 2020 7:58 am RocketAssistedPuffin Relationship added related to 0022935
Mar 5, 2020 7:58 am RocketAssistedPuffin Relationship replaced related to 0022251
Jun 5, 2020 1:31 pm x4000Bughunter Assigned To => x4000Bughunter
Jun 5, 2020 1:31 pm x4000Bughunter Status new => resolved
Jun 5, 2020 1:31 pm x4000Bughunter Resolution open => fixed
Jun 5, 2020 1:31 pm x4000Bughunter Fixed in Version => Beta 2.062 Savegame/Networking Data Compaction
Jun 5, 2020 1:31 pm x4000Bughunter Note Added: 0057200