View Issue Details

IDProjectCategoryLast Update
0021124AI War 2[All Projects] Graphical BugJul 22, 2019 2:28 pm
ReporterptarthAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBETA 0.853 An Officer And A Bunch Of Fleets 
Fixed in Version0.877 The Strikecraft Goldilocks Zone 
Summary0021124: Shots firing in random directions
DescriptionUnder varying circumstances, typically those with high volumes of shots, that you can end up with many shots looking like they are fired in random directions. I'm guessing that this is caused by the target becoming invalid (death, out of range). For ships with high damage and high number sequential salvos this is especially noticeable. I'm guessing putting validation check on the shot at the time it is spawned rather than when the system starts shooting may help with this, or some other method of updating the target location with a more sensible value when the target becomes invalid.

TagsNo tags attached.

Relationships

related to 0020748 resolvedBadgerBadger Shots going to bottom left corner 
related to 0021139 resolvedBadgerBadger Rapidly flashing diagonal blasts 

Activities

x4000Bughunter

Jul 8, 2019 10:59 am

administrator   ~0052080

Is this still a thing that happens in the latest versions? A savegame in the new post-fleets stuff would be welcome if anyone runs across one. Thanks!

RocketAssistedPuffin

Jul 8, 2019 11:19 am

developer   ~0052087

From what I recall, yes. I believe it's caused by sequential firing salvo weapons. When a target for a shot later in the salvo dies, it'll fire that shot to the bottom left corner.

I think almost no unit has sequential salvo weapons now, though. I haven't seen it since.

x4000Bughunter

Jul 8, 2019 11:47 am

administrator   ~0052088

Is there a reason for us to keep sequential shots around at all? It seems like that was causing a lot of bugs (more than just this, and it doesn't seem worthwhile unless I'm missing something.

RocketAssistedPuffin

Jul 8, 2019 11:58 am

developer   ~0052092

I always set it to false for the big things, so they seemed more impressive, and ptarth made the point about it reducing the DPS. I took it off Strikecraft since it looked a bit absurd with every Pike or MLRS Corvette spamming shots constantly, plus the noise.

So...I don't think there is a reason?

x4000Bughunter

Jul 8, 2019 12:34 pm

administrator   ~0052095

It looks like most non-AOE ships are using it in order to have their shots slightly staggered, blah. I'll have to leave it in for now.

BadgerBadger

Jul 22, 2019 2:28 pm

manager   ~0052296

Fixed

Issue History

Date Modified Username Field Change
Apr 23, 2019 5:04 pm ptarth New Issue
Apr 25, 2019 1:18 pm BadgerBadger Relationship added related to 0021139
Jul 8, 2019 10:58 am x4000Bughunter Relationship added related to 0020748
Jul 8, 2019 10:59 am x4000Bughunter Note Added: 0052080
Jul 8, 2019 11:19 am RocketAssistedPuffin Note Added: 0052087
Jul 8, 2019 11:47 am x4000Bughunter Note Added: 0052088
Jul 8, 2019 11:58 am RocketAssistedPuffin Note Added: 0052092
Jul 8, 2019 12:34 pm x4000Bughunter Note Added: 0052095
Jul 22, 2019 2:28 pm BadgerBadger Assigned To => BadgerBadger
Jul 22, 2019 2:28 pm BadgerBadger Status new => resolved
Jul 22, 2019 2:28 pm BadgerBadger Resolution open => fixed
Jul 22, 2019 2:28 pm BadgerBadger Fixed in Version => 0.877 The Strikecraft Goldilocks Zone
Jul 22, 2019 2:28 pm BadgerBadger Note Added: 0052296