View Issue Details

IDProjectCategoryLast Update
0020787AI War 2[All Projects] Bug - GameplayApr 22, 2019 7:42 pm
Reporterwm46Assigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionduplicate 
Product Version0.806 Sabre Company 
Fixed in VersionBETA 0.853 An Officer And A Bunch Of Fleets 
Summary0020787: MLRS Multifire not working when on Nanocaust world
DescriptionSpecifically the two types of Nanobot centers seem to prevent MLRS ships from multitargeting. Until the center is destroyed, these ships (and presumably others too?) will refuse to target more than one ship.
TagsNo tags attached.

Relationships

duplicate of 0020771 resolvedx4000Bughunter Pike Corvette Multi-Shot Not Working 

Activities

wm46

Apr 21, 2019 11:09 pm

reporter   ~0051256

I would like to bump this issue. With the change of making targeting favor XML priority more this occurs more than ever with things like AI fortresses and superfortresses. Right now a lot of the multishots on fleet centerpieces are useless when fighting on worlds that have fortresses, golems, and other high priority targets.

Citadel wont use multishot.save (518,726 bytes)

wm46

Apr 22, 2019 6:05 pm

reporter   ~0051299

I just sent a revision that addresses this issue in the one specific situation above. More testing might be needed but most issues should be fixed (I hope)

x4000Bughunter

Apr 22, 2019 7:42 pm

administrator   ~0051308

Fantastic! I've put this note into the wiki:

* Some complicated code fixes from WeaponMaster have been put in place to hopefully solve the "multi-shot doesn't function when there's an enemy fortress or other super important item present" issue. Please let us know if this doesn't fix it, or any other strange cases wind up happening, but things seem okay from some limited testing so far.


Thanks so much!

Issue History

Date Modified Username Field Change
Nov 17, 2018 12:04 am wm46 New Issue
Dec 4, 2018 4:41 pm Dune Assigned To => x4000Bughunter
Dec 4, 2018 4:41 pm Dune Status new => acknowledged
Apr 21, 2019 11:05 pm wm46 Relationship added duplicate of 0020771
Apr 21, 2019 11:09 pm wm46 File Added: Citadel wont use multishot.save
Apr 21, 2019 11:09 pm wm46 Note Added: 0051256
Apr 22, 2019 6:05 pm wm46 Note Added: 0051299
Apr 22, 2019 7:42 pm x4000Bughunter Status acknowledged => resolved
Apr 22, 2019 7:42 pm x4000Bughunter Resolution open => duplicate
Apr 22, 2019 7:42 pm x4000Bughunter Fixed in Version => BETA 0.853 An Officer And A Bunch Of Fleets
Apr 22, 2019 7:42 pm x4000Bughunter Note Added: 0051308