View Issue Details

IDProjectCategoryLast Update
0019605AI War 2[All Projects] GUIApr 29, 2018 12:21 pm
ReporterhawkAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.740 Clean Up That Nebula, Young Man! 
Fixed in Version0.741 Music Part 1 Of 2 
Summary0019605: Confused sidebar
DescriptionI am experiencing this bug in the current version (0.740). Original bug report copied below:

I have managed to confuse the Construction tab of the sidebar thus. It looks like everything is bumped down a level.

You can reproduce the problem with this save game. Go to Lakota and open the Construction tab. Then go to Kesselman and look at the construction tab there.

Note: Badger deleted the attachments that were relevant to the previous reproduction because they were confusing. All the remaining comments (aka from today) are pertinent
TagsNo tags attached.

Relationships

related to 0019571 resolvedx4000Bughunter Confused sidebar 

Activities

BadgerBadger

Apr 26, 2018 6:24 pm

manager   ~0047474

Hawk, what did you do to trigger the problem? Do you have a save game and instructions?

hawk

Apr 26, 2018 8:59 pm

reporter   ~0047475

It's the exact same as you described in the original bug report.
-have the "constructor menu" open on one of your planets
-select another planet
-you should see ghost icons.

I believe it bugs the opposite way as well but its not as noticeable.

I can load up a save game but (for me) it's happening very consistently.

hawk

Apr 26, 2018 9:06 pm

reporter   ~0047476

Sorry, not "ghost". You can click them, so just offset. You might have to do the above without being paused. I just tried on-pause and it wouldn't replicate until unpaused.

hawk

Apr 26, 2018 9:14 pm

reporter   ~0047477

Here's the most current save game started in v.740. The bugged bar won't be present on initial load up but if you do the above it *should* replicate.
Please forgive the massacre happening in game. I didn't know the Dyson was bugged went I started this game :(

Bad Dyson.save (2,800,887 bytes)

BadgerBadger

Apr 26, 2018 9:16 pm

manager   ~0047478

Wait, what's wrong with the Dyson?

hawk

Apr 26, 2018 9:23 pm

reporter   ~0047479

Poor phasing on my part. It creates AI threat. You entered that bug report here ==> https://bugtracker.arcengames.com/view.php?id=19420

BadgerBadger

Apr 26, 2018 9:26 pm

manager   ~0047480

Ah, yeah, that makes sense. I've looked at the save and you're right. For Chris, the simple recreate scenario: Go to Korn. Open the Construction menu. Now go to any AI planet (I used Overmars) with the construction menu still open; you'll see the constructors are still there

x4000Bughunter

Apr 29, 2018 12:12 pm

administrator   ~0047501

To clarify, when I do this I only see the things from the infrastructure tab -- which is for building a space dock or a starship constructor. All the higher-up stuff works fine, and the defenses section simply had been empty. Is that matching what you're seeing?

hawk

Apr 29, 2018 12:21 pm

reporter   ~0047502

This may have been meant for Badger but I'll let you know what I see as well. I just started a brand new game, clicked the "construct" tab, opened the galaxy map, clicked random enemy planet, and get the attached.

I get infrastructure and defense icons. Ships from the Ark and Flagship don't show though so that part seem to be working as intended.

2018-04-29.png (1,304,763 bytes)

x4000Bughunter

Apr 29, 2018 12:21 pm

administrator   ~0047503

Thanks!

* Fixed an issue where the construction part of the sidebar could show some stale data when switching from a planet with a builder to one without a builder.

Issue History

Date Modified Username Field Change
Apr 26, 2018 6:12 pm hawk New Issue
Apr 26, 2018 6:12 pm hawk Issue generated from: 0019571
Apr 26, 2018 6:12 pm hawk Relationship added related to 0019571
Apr 26, 2018 6:24 pm BadgerBadger Note Added: 0047474
Apr 26, 2018 8:59 pm hawk Note Added: 0047475
Apr 26, 2018 9:06 pm hawk Note Added: 0047476
Apr 26, 2018 9:14 pm hawk File Added: Bad Dyson.save
Apr 26, 2018 9:14 pm hawk Note Added: 0047477
Apr 26, 2018 9:16 pm BadgerBadger Note Added: 0047478
Apr 26, 2018 9:23 pm hawk Note Added: 0047479
Apr 26, 2018 9:26 pm BadgerBadger Note Added: 0047480
Apr 26, 2018 9:26 pm BadgerBadger Assigned To => BadgerBadger
Apr 26, 2018 9:26 pm BadgerBadger Status new => assigned
Apr 26, 2018 9:27 pm BadgerBadger File Deleted: sidebar.savemet
Apr 26, 2018 9:27 pm BadgerBadger File Deleted: sidebar.save
Apr 26, 2018 9:27 pm BadgerBadger File Deleted: sidebarConfused.png
Apr 26, 2018 9:28 pm BadgerBadger Description Updated View Revisions
Apr 27, 2018 9:36 am BadgerBadger Assigned To BadgerBadger => x4000Bughunter
Apr 29, 2018 12:12 pm x4000Bughunter Note Added: 0047501
Apr 29, 2018 12:21 pm hawk File Added: 2018-04-29.png
Apr 29, 2018 12:21 pm hawk Note Added: 0047502
Apr 29, 2018 12:21 pm x4000Bughunter Status assigned => resolved
Apr 29, 2018 12:21 pm x4000Bughunter Resolution open => fixed
Apr 29, 2018 12:21 pm x4000Bughunter Fixed in Version => 0.741 Music Part 1 Of 2
Apr 29, 2018 12:21 pm x4000Bughunter Note Added: 0047503