View Issue Details

IDProjectCategoryLast Update
0019571AI War 2[All Projects] GUIApr 26, 2018 6:12 pm
ReporterBadgerBadgerAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.718 
Fixed in Version0.721-0.722 Down The Wormhole 
Summary0019571: Confused sidebar
DescriptionI have managed to confuse the Construction tab of the sidebar thus. It looks like everything is bumped down a level.

You can reproduce the problem with this save game. Go to Lakota and open the Construction tab. Then go to Kesselman and look at the construction tab there.
TagsNo tags attached.

Relationships

related to 0019605 resolvedx4000Bughunter Confused sidebar 

Activities

BadgerBadger

Apr 6, 2018 7:59 pm

manager  

sidebar.savemet (46 bytes)
sidebarConfused.png (1,903,872 bytes)
sidebar.save (2,788,392 bytes)

BadgerBadger

Apr 7, 2018 6:13 pm

manager   ~0047380

It looks like we aren't properly clearing the previous BuldConstructor rows. Though the code theoretically looks like it should be doing so...

x4000Bughunter

Apr 8, 2018 8:25 pm

administrator   ~0047390

Thanks!

* Fixed a bug from the last two versions of the game where the construction sidebar could be confused and show a bunch of extra junk offset in the wrong places.

Issue History

Date Modified Username Field Change
Apr 6, 2018 7:59 pm BadgerBadger New Issue
Apr 6, 2018 7:59 pm BadgerBadger Status new => assigned
Apr 6, 2018 7:59 pm BadgerBadger Assigned To => x4000Bughunter
Apr 6, 2018 7:59 pm BadgerBadger File Added: sidebar.savemet
Apr 6, 2018 7:59 pm BadgerBadger File Added: sidebar.save
Apr 6, 2018 7:59 pm BadgerBadger File Added: sidebarConfused.png
Apr 7, 2018 6:13 pm BadgerBadger Note Added: 0047380
Apr 8, 2018 8:25 pm x4000Bughunter Status assigned => resolved
Apr 8, 2018 8:25 pm x4000Bughunter Resolution open => fixed
Apr 8, 2018 8:25 pm x4000Bughunter Fixed in Version => 0.721-0.722 Down The Wormhole
Apr 8, 2018 8:25 pm x4000Bughunter Note Added: 0047390
Apr 26, 2018 6:12 pm hawk Issue cloned: 0019605
Apr 26, 2018 6:12 pm hawk Relationship added related to 0019605