View Issue Details

IDProjectCategoryLast Update
0019585AI War 2[All Projects] Bug - OtherAug 4, 2018 4:14 pm
ReporterRingorAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.720 
Fixed in Version0.754 Shifting That Furniture 
Summary0019585: Keypresses recorded twice
DescriptionLinux 64bit, Ubuntu 17.10

Every keypress is recorded twice. An "r" becomes "rr", "Shift-r" becomes "rR".
Tested in input boxes on profile name and screen size.

Btw: native resolution is 3440x1440, window opened as roughly 40x600 the first time.
After restart it opened in 600x600 (which is quite tiny for that resolution) and selecting
sensible values is difficult when every keypress is doubled. ;-)
TagsNo tags attached.

Relationships

related to 0019517 resolvedx4000Bughunter Linux: Text input registers keys twice 

Activities

x4000Bughunter

Apr 12, 2018 4:15 pm

administrator   ~0047417

So, turns out that this is a known bug in unity that has been fixed in their 2018.1 beta version: https://issuetracker.unity3d.com/issues/linux-keystrokes-recorded-twice

Their 2017.4 version, which is their most recent (just came out) non-beta version, does not include this fix. We're on 2017.3, and right now there's no good reason for us to upgrade until 2018.1 comes out, which hopefully will be in the next couple of months.

Sorry about the hassle with this, I know the issue is annoying (to put it mildly). The general stability of the game would likely suffer if we tried to upgrade to 2018.1 before they removed it from beta status, though. :/

BadgerBadger

Aug 1, 2018 1:00 pm

manager   ~0048180

I think this should be fixed now in the current version of unity, right?

x4000Bughunter

Aug 1, 2018 1:38 pm

administrator   ~0048181

Yes, it should be -- I meant to come back here and check. Is this still happening for you, Ringor?

Ringor

Aug 4, 2018 3:32 pm

reporter   ~0048200

No. Now I can enter text normally.

Thanks!

BadgerBadger

Aug 4, 2018 4:14 pm

manager   ~0048201

Fixed by unity upgrade

Issue History

Date Modified Username Field Change
Apr 12, 2018 1:49 pm Ringor New Issue
Apr 12, 2018 4:00 pm BadgerBadger Relationship added related to 0019517
Apr 12, 2018 4:15 pm x4000Bughunter Assigned To => x4000Bughunter
Apr 12, 2018 4:15 pm x4000Bughunter Status new => assigned
Apr 12, 2018 4:15 pm x4000Bughunter Note Added: 0047417
Aug 1, 2018 1:00 pm BadgerBadger Note Added: 0048180
Aug 1, 2018 1:38 pm x4000Bughunter Note Added: 0048181
Aug 4, 2018 3:32 pm Ringor Note Added: 0048200
Aug 4, 2018 4:14 pm BadgerBadger Status assigned => resolved
Aug 4, 2018 4:14 pm BadgerBadger Resolution open => fixed
Aug 4, 2018 4:14 pm BadgerBadger Fixed in Version => 0.754 Shifting That Furniture
Aug 4, 2018 4:14 pm BadgerBadger Note Added: 0048201