View Issue Details

IDProjectCategoryLast Update
0019517AI War 2[All Projects] GUISep 5, 2018 9:22 pm
ReporterHistidineAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.714 
Fixed in Version 
Summary0019517: Linux: Text input registers keys twice
DescriptionWhen I try to type something in a text field (e.g. screen resolution setting), every key input is duplicated.
e.g. current value: 1600
press "0" once
new value: 160000

Backspace and delete are also affected. It is still possible to input the actually desired values through cut and paste, but this is annoying.

Ingame hotkeys do not appear to be affected.

Ubuntu 16.04 LTS
TagsNo tags attached.

Relationships

related to 0019585 resolvedx4000Bughunter Keypresses recorded twice 

Activities

BadgerBadger

Mar 21, 2018 11:05 am

manager   ~0047255

Might be ubuntu/debian specific. Fedora works fine for me.

x4000Bughunter

Mar 23, 2018 8:03 pm

administrator   ~0047287

I don't see anything super explicit that would cause this. Any linux users who stumble upon this, can you test the exact fields in question and see if you get the same behavior? Also, Histidine, now that this is 64-bit only do you have the same issue?

Histidine

Mar 23, 2018 8:22 pm

reporter   ~0047289

Still occurs for me (it's been insensitive to 32 bit vs. 64 bit back when both were available).

Random observation: The issue mostly goes away when I switch my text input mode to Japanese (Mozc) with hiragana. Mozc direct input (i.e. English) still has the issue.

Toggling the repeat keys setting in OS has no effect.

...I'm suspecting the issue results from an obscure quirk in my local settings...? Well, we'll see if anyone else reports the issue.

x4000Bughunter

Mar 27, 2018 9:47 am

administrator   ~0047303

Got it -- I'll mark this as unable to repro for now, and hopefully nobody else runs into it. It's probably a bug in unity itself, though. :/

x4000Bughunter

Apr 12, 2018 4:14 pm

administrator   ~0047416

So, turns out that this is a known bug in unity that has been fixed in their 2018.1 beta version: https://issuetracker.unity3d.com/issues/linux-keystrokes-recorded-twice

Their 2017.4 version, which is their most recent (just came out) non-beta version, does not include this fix. We're on 2017.3, and right now there's no good reason for us to upgrade until 2018.1 comes out, which hopefully will be in the next couple of months.

Sorry about the hassle with this, I know the issue is annoying (to put it mildly). The general stability of the game would likely suffer if we tried to upgrade to 2018.1 before they removed it from beta status, though. :/

x4000Bughunter

Aug 1, 2018 1:39 pm

administrator   ~0048182

We've updated unity versions, and this should now be fixed. Can you confirm when you get a chance, Histidine?

Issue History

Date Modified Username Field Change
Mar 21, 2018 7:57 am Histidine New Issue
Mar 21, 2018 9:20 am x4000Bughunter Assigned To => x4000Bughunter
Mar 21, 2018 9:20 am x4000Bughunter Status new => assigned
Mar 21, 2018 11:05 am BadgerBadger Note Added: 0047255
Mar 23, 2018 8:03 pm x4000Bughunter Status assigned => feedback
Mar 23, 2018 8:03 pm x4000Bughunter Note Added: 0047287
Mar 23, 2018 8:22 pm Histidine Note Added: 0047289
Mar 23, 2018 8:22 pm Histidine Status feedback => assigned
Mar 27, 2018 9:47 am x4000Bughunter Status assigned => closed
Mar 27, 2018 9:47 am x4000Bughunter Resolution open => unable to reproduce
Mar 27, 2018 9:47 am x4000Bughunter Note Added: 0047303
Apr 12, 2018 4:00 pm BadgerBadger Relationship added related to 0019585
Apr 12, 2018 4:14 pm x4000Bughunter Status closed => assigned
Apr 12, 2018 4:14 pm x4000Bughunter Note Added: 0047416
Aug 1, 2018 1:39 pm x4000Bughunter Note Added: 0048182
Sep 5, 2018 9:22 pm x4000Bughunter Status assigned => resolved
Sep 5, 2018 9:22 pm x4000Bughunter Resolution unable to reproduce => fixed