Arcen Idea Tracker (Bugs and Features)

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryDate SubmittedLast Update
0018948AI War 2[All Projects] Crash/ExceptionFeb 27, 2017 3:57 pmMar 3, 2017 10:27 am
ReporterMatruchus 
Assigned Tox4000Bughunter 
Severitycrash 
StatusfeedbackResolutionopen 
Product Version 
Fixed in Version 
Summary0018948: Game crashes on startup
DescriptionTried to launch the game on Linux Mint 17.3 64bit with the last version of Catalyst drivers installed. The game crashes on startup. Essentially a blue box appears that then crashes to desktop.
TagsNo tags attached.
Attached Fileslog file icon Player.log [^] (65,801 bytes) Feb 27, 2017 4:06 pm

- Relationships
related to 0018972resolvedx4000Bughunter Game crashes on first startup to a blue screen 

-  Notes
(0045750)
x4000Bughunter (administrator)
Feb 27, 2017 4:04 pm

Ah yeah, that's what was happening in my VM on my OSX machine with an intel card, too. I've never seen a blue screen in unity prior to that.

This is working for some other folks in linux, most likely on nvidia, and I'm not sure what distros.

Can you upload the log file from this location? ~/.config/unity3d/CompanyName/ProductName/Player.log

It should be Arcen Games or similar, and then AI War 2.
(0045751)
Matruchus (reporter)
Feb 27, 2017 4:07 pm
edited on: Feb 27, 2017 4:25 pm

Ok, uploaded the file now. Forgot where it was :)

It could be the problem that I have two graphics cards. The Intel integrated card and a discrete R9 270x.

(0045752)
x4000Bughunter (administrator)
Feb 27, 2017 4:25 pm

Thanks!

Okay, this seems to be a flavor of the same issues these folks were facing: https://forum.planet-nomads.com/archive/index.php/t-415.html [^]

To summarize what they were finding:

1. First try just verifying the steam cache of local files for the game -- it may be as simple as something downloaded wrong, evidently.

2. None of the sqllite stuff they are talking about is at all relevant here, by the by.

3. This may or may not have any help:
sudo apt-get update
sudo apt-get install lsb-release

4. start with -force-opengl arguments may help?

5. It might be an OpenGL issue in general, based on this: https://forum.unity3d.com/threads/linux-export-is-dead.390356/ [^]

You can run glxinfo | grep "OpenGL version"

It may also be some other type of problem, based on what is being said in that thread. It's related to AMD drivers or the OpenGL version used, at any rate.
(0045753)
Matruchus (reporter)
Feb 27, 2017 4:42 pm

1. Tried that before posting on Mantis - everything verified ok.

3. Tried that - everything already on the newest level for lsb-release.

4. How do I do that?

5. GlXinfo:
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon R9 200 Series
OpenGL core profile version string: 4.3.13416 Core Profile Context 15.302
OpenGL core profile shading language version string: 4.40
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.13416 Compatibility Profile Context 15.302
OpenGL shading language version string: 4.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:

6. After the blue scree of death and restarting the system I had to go recovery mode since the game seems to have crashed opengl? Aka the graphical system couldn't be loaded. Tried several times. Thankfully recovery mode reinitialized the graphics.
(0045754)
x4000Bughunter (administrator)
Feb 27, 2017 4:48 pm
edited on: Feb 27, 2017 4:50 pm

Okay, yikes -- that's pretty severe of a crash there, for sure.

To do item 4, simply use that as the command line arguments when launching the game from steam (In the Steam Library, right click the game and go to Properties. Click the SET LAUNCH OPTIONS... button, then add your command line arguments in the popup dialog.), or just use bash to launch it that way.

THAT said, I am thinking that perhaps it is the antialiasing that is eating your machine right now. It's currently slammed up at 8x MSAA, which may be more than what that particular card can do; 4X may be what it maxes out at. I'm going to make an update that will let you set that, and that may default to something more like 2X MSAA just to have overall best compatibility in general.

(0045755)
Matruchus (reporter)
Feb 27, 2017 5:08 pm

Tried the force option no difference.

Amd Catalyst had anti aliasing set to application specifications. Manually I could change it to up to 8EQ. Still the card might not support 8X MSAA as you said. Well will see what happens with the next update.
(0045798)
x4000Bughunter (administrator)
Mar 1, 2017 4:06 pm

All right... any luck in 0.102? https://wiki.arcengames.com/index.php?title=AI_War_2:Earlier_Than_Early_Alpha#Version_0.102 [^]

You may need to go into PlayerData/settings.dat and change the antialiasing to Off, I'm not sure.

The force opengl thing might also work, not sure.
(0045799)
x4000Bughunter (administrator)
Mar 1, 2017 4:50 pm

For me, on my VM, it's still completely busted:

/home/josh/.local/share/Steam/SteamApps/common/AI War 2/AIWar2Linux.x86_64' -force-opengl
Found path: /home/josh/.local/share/Steam/SteamApps/common/AI War 2/AIWar2Linux.x86_64
Mono path[0] = '/home/josh/.local/share/Steam/SteamApps/common/AI War 2/AIWar2Linux_Data/Managed'
Mono path[1] = '/home/josh/.local/share/Steam/SteamApps/common/AI War 2/AIWar2Linux_Data/Mono'
Mono config path = '/home/josh/.local/share/Steam/SteamApps/common/AI War 2/AIWar2Linux_Data/Mono/etc'
PlayerConnection initialized from /home/josh/.local/share/Steam/SteamApps/common/AI War 2/AIWar2Linux_Data (debug = 0)
PlayerConnection initialized network socket : 0.0.0.0 55216
Multi-casting "[IP] 10.211.55.4 [Port] 55216 [Flags] 3 [Guid] 3093016418 [EditorId] 627841707 [Version] 1048832 [Id] LinuxPlayer(10.211.55.4) [Debug] 1" to [225.0.0.222:54997]...
Waiting for connection from host on [0.0.0.0:55216]...
Timed out. Continuing without host connection.
Started listening to [0.0.0.0:55216]
Using monoOptions --debugger-agent=transport=dt_socket,embedding=1,defer=y,address=0.0.0.0:56418
PlayerConnection already initialized - listening to [0.0.0.0:55216]
displaymanager : xrandr version warning. 1.4
client has 1 screens
displaymanager screen (0)(default): 1251 x 782
Using libudev for joystick management


Importing game controller configs
Aborted (core dumped)
(0045800)
x4000Bughunter (administrator)
Mar 1, 2017 4:54 pm

When running it from the terminal, it looks like this throws an error message set that is basically what is happening in KSP: http://forum.kerbalspaceprogram.com/index.php?/topic/137457-ubuntu-1404-64bit-unity-crash-on-load/ [^]

Unfortunately... https://forum.unity3d.com/threads/auto-graphics-api-for-linux-missing.444403/ [^]

Based on that second link, it looks like all of the previous workarounds that would let linux run on OpenGL2 are just dead and gone. Basically if it doesn't support a certain level of OpenGLCore, then it just freaks out and dies. Apparently in MESA you can fake it having a higher level, but I have no idea how to do that, or if that's really a good idea.

It looks like Unity may have kinda-silently removed support for a certain kind of OpenGL on Linux only, which is super frustrating. They've then added in Vulkan support in 5.6, which we're not yet on... but I don't know that that will actually fix it in terms of letting us choose an API directly again (aka I'm not sure if this is an interface thing in the GUI editor, or if actual underlying support was purposefully removed).

This is super frustrating, if that's the case. It basically would mean that hardware below a certain set of specs will only run on Windows or OSX, not Linux, because of this specific OpenGL limitation.
(0045821)
x4000Bughunter (administrator)
Mar 2, 2017 11:02 am

Okay, so here's what I've found out:

- Basically, OpenGL2.x support was completely removed in Unity 5.5, which is quite frustrating and was not well-advertised as something that would happen: https://www.gamingonlinux.com/articles/unity-55-released-removes-legacy-opengl-support.8627 [^]

- This is mostly an issue for Linux machines running something OLDER than Sandy Bridge intel GPUs. Apparently the MESA drivers do indeed need to be updated, and can be: https://www.phoronix.com/scan.php?page=news_item&px=MTc5MjY [^]

- Further notes about the level of support indicate that even an Intel HD Graphics 2000 should be able to run OpenGL 3.3. Minimum of 3.2 is now required, but 3.3 should work: https://en.wikipedia.org/wiki/List_of_Intel_graphics_processing_units#Sixth_generation [^]

-Any intel GPU older than 2011 (aka pre-Sandy Bridge, aka anything prior to the 6th generation of intel processors) will definitely NOT work. Of course, with a discrete GPU those processors can still be used with the game, but just not as the GPU powering it.

-Why exactly your machine is reporting MESA support of only 3.1, I'm not sure. It may actually be a driver thing after all!
(0045822)
x4000Bughunter (administrator)
Mar 2, 2017 11:04 am

Crud, wrong thread -- you're on AMD catalyst and yours should be A-OK. It was probably the AA issue.
(0045859)
Matruchus (reporter)
Mar 3, 2017 7:37 am

First of sorry to respond so late. Well I tried running it again with the updated version but still the same. Eitherway have to reinstall the system since it did totally break my GUI and the system now only loads in recovery mode. I guess I will try with a Linux system with a rolling release that has newer kernel with new amd drivers. Maybe it will work then.
(0045867)
x4000Bughunter (administrator)
Mar 3, 2017 10:27 am

No problem -- but holy cow that's alarming that your entire GUI broke and only loads in recovery mode. There's no way a program like unity should be allowed to do that; when it's launching, it's not even to our code yet. Sounds like there was already something wrong on your system perhaps.

I found a bit ago today that my own linux laptop was not playing sound, and so it would hang on youtube videos as well as whenever I closed AI War 2. Opening it was fine, but closing it I would have to force kill the process.

After updating to the latest version of ubuntu, sound was back. Then AI War 2 exited normally, youtube played normally, and so on.

Anyway, I hope that the GUI issues you were seeing are just something that was already wrong, just not yet surfaced for whatever reason. :/

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
Feb 27, 2017 3:57 pm Matruchus New Issue
Feb 27, 2017 4:04 pm x4000Bughunter Note Added: 0045750
Feb 27, 2017 4:04 pm x4000Bughunter Assigned To => x4000Bughunter
Feb 27, 2017 4:04 pm x4000Bughunter Status new => assigned
Feb 27, 2017 4:06 pm Matruchus File Added: Player.log
Feb 27, 2017 4:07 pm Matruchus Note Added: 0045751
Feb 27, 2017 4:20 pm Matruchus Note Edited: 0045751 View Revisions
Feb 27, 2017 4:25 pm Matruchus Note Edited: 0045751 View Revisions
Feb 27, 2017 4:25 pm x4000Bughunter Note Added: 0045752
Feb 27, 2017 4:42 pm Matruchus Note Added: 0045753
Feb 27, 2017 4:48 pm x4000Bughunter Note Added: 0045754
Feb 27, 2017 4:50 pm x4000Bughunter Note Edited: 0045754 View Revisions
Feb 27, 2017 5:08 pm Matruchus Note Added: 0045755
Mar 1, 2017 4:06 pm x4000Bughunter Note Added: 0045798
Mar 1, 2017 4:06 pm x4000Bughunter Status assigned => feedback
Mar 1, 2017 4:50 pm x4000Bughunter Note Added: 0045799
Mar 1, 2017 4:54 pm x4000Bughunter Note Added: 0045800
Mar 2, 2017 10:36 am x4000Bughunter Relationship added related to 0018972
Mar 2, 2017 11:02 am x4000Bughunter Note Added: 0045821
Mar 2, 2017 11:04 am x4000Bughunter Note Added: 0045822
Mar 3, 2017 7:37 am Matruchus Note Added: 0045859
Mar 3, 2017 7:37 am Matruchus Status feedback => assigned
Mar 3, 2017 10:27 am x4000Bughunter Note Added: 0045867
Mar 3, 2017 10:27 am x4000Bughunter Status assigned => feedback


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker