View Issue Details

IDProjectCategoryLast Update
0027390AI War 2Balance IssueJul 8, 2022 4:28 pm
ReporterLord Of Nothing Assigned ToCRCGamer  
Severityminor 
Status resolvedResolutionfixed 
Product Version5.012 Necromancer Balance 
Summary0027390: Spire Module Balance
DescriptionOkay, so I've been sitting on this for a while. I've played a couple of Spire games now since the module rework, and I think there's some room for improvement with the module balancing. (Which is to be expected as I don't think it's ever got a proper balance pass)
So:
Spire Frigates:
I think the laser pulse is too cheap in module point cost compared to everything else. I would suggest it be increased in cost to 2 module points.
I think the heavy hull and shield modules are too expensive on this ship. On larger ships a 3 module point cost seems appropriate, but on the frigate that leaves the laser pulse as the only possible weapon, so they are essentially unusable (and if the above change was made they would be actually unusable.) I would suggest they be reduced to 2 module points, but their multiplier be reduced appropriately as well.
I don't think the gravity drain should be on them at all, but it's too late to do anything about it now.

Spire Destroyers:
First we must consider that the destroyer costs 4 times as many slots as 1 frigate, but has only 2x the health, and 2x the damage on it's basic coilbeam (but 3x bonus vs large enemies). So it is arguably already underpowered vs the frigate. But it also gets a bad deal on it's module usability:
The Light Gravitic Railgun is an extremely poor deal. It has the same module point cost as the basic coilbeam, but deals approximately one eight of the damage, and has no damage bonus. Even accounting for the engine slow, this is very low. I would suggest reducing it to 1 module point from 2, and it could arguably still do with a boost to it's damage as well.
The Heavy Gravitic Railgun is closer to balanced, but arguably the engine slow's maximum affected Gx is too high. It can slow some things that are really not supposed to be slowed - I would suggest reducing the affected Gx to 22 or lower. NEVERMIND, Nothing to see here...
As with the frigate, I think the heavy hull and shield modules are too expensive on this ship. On larger ships a 3 module point cost seems appropriate, but on the destroyer they are currently literally unusable, as there is no weapon that can be fitted at the same time. I would suggest they be reduced to 2 module points, but their multiplier be reduced appropriately as well.

Cruiser (Non-Flagship)
The Light Coilbeam is a little too good. I would suggest that at the very least it's damage should be reduced to 50% of the standard coilbeam.
On the other hand, the Gravity drain is probably a little expensive. I still wouldn't even consider using it if it was 3 points rather than 4, but standardising it with the frigate and destroyer costs would be a start.

Battleship (Non-Flagship)
For some reason it's tractor beam option is actually weaker than the Cruiser.

Cruiser (Flagship)
The bubble forcefield module is very expensive for what you get. If you use it, you're getting no increase to fleet durability, and you can't fit any weaponry on the cruiser itself. This doesn't seem worth it. I would suggest reducing it's point cost by at least 1, and I personally think reducing it by 2 would be perfectly reasonable.

Battleship (Flagship)
The bubble forcefield module is very expensive for what you get. The issue isn't as severe as with the cruiser, so I would only suggest a reduction of 1 module point.
The Gravitic Core is fairly overpowered. I would suggest reducing the slow magnitude, as this works better across different gravwell sizes.
Has the same tractor beam issue as the Non-Flagship version.

Dreadnaught (Flagship)
I think the laser pulse is too cheap in module point cost compared to everything else. I would suggest it be increased in cost to 2 module points.
The Gravitic Railcannon: Arguably the engine slow's maximum affected Gx is too high. It can slow some things that are really not supposed to be slowed - I would suggest reducing the affected Gx to 22 or lower. I will also note that they have twice the DPS, relative to the main weapons, as the gravitic railcannons on the destroyer and battleship.
The bubble forcefield module is very expensive for what you get. The issue isn't as severe as with the cruiser, so I would only suggest a reduction of 1 module point.
The Gravitic Core is insanely strong. I would suggest increasing the cost to 3 module points as well as reducing the slow magnitude, for the same reasons as the battleship.
TagsNo tags attached.

Activities

Lord Of Nothing

May 22, 2022 11:25 pm

reporter   ~0066853

I will also note that I actually think the extra hull and extra shield modules are significantly underpowered for their cost, compared to just getting more weaponry, beyond what I've enumerated above, but I'm much more reluctant to suggest buffing these since this would contribute to further power creep - since they tend to be fitted into your module build anyway when you can't afford more weaponry - and Spire is already *pretty* strong.

CRCGamer

May 27, 2022 5:47 am

developer   ~0066874

Just halve the shots per salvo of the Pulse Laser weapons on the Frigate and Dreadnoughts instead of adjusting module point cost.
As for the gravity gen on the Destroyer that can be max_mark'd to zero and thus disabled in games going forward. Honestly I'd suggest the non-flagship cruisers and below get the same treatment so that the slows only show up at battleship and above for non-flagships.
The destroyer railgun engine gX affected for slows has been lower than 22 ever since the first pass I did immediately the week after modules went in.
The reason the light railgun does so much less damage is because its effectively trading damage potential for spread infinite range CC like a Spider Turret. It shouldn't be adjusted beyond maybe doubling the base damage.

Lord Of Nothing

May 28, 2022 1:07 pm

reporter   ~0066887

Ah, sorry about that on the destroyer railgun, I'm not sure how I made that mistake. The halving shots on the laser pulses is a much more elegant solution, I wish I'd thought of it. ;)

CRCGamer

Jul 5, 2022 2:31 pm

developer   ~0067054

I have done a huge sweep of the weapons and gravity effects for modular Spire ships. I also lightly touched upon the passive durability modules of the frigate and destroyer class vessels.

BadgerBadger

Jul 8, 2022 4:28 pm

manager   ~0067062

Going to set this as fixed then.

Issue History

Date Modified Username Field Change
May 22, 2022 11:02 pm Lord Of Nothing New Issue
May 22, 2022 11:09 pm Lord Of Nothing Description Updated
May 22, 2022 11:25 pm Lord Of Nothing Note Added: 0066853
May 23, 2022 1:29 am BadgerBadger Assigned To => zeusalmighty
May 23, 2022 1:29 am BadgerBadger Status new => assigned
May 27, 2022 5:47 am CRCGamer Note Added: 0066874
May 28, 2022 1:07 pm Lord Of Nothing Note Added: 0066887
May 28, 2022 1:08 pm Lord Of Nothing Description Updated
May 28, 2022 1:08 pm Lord Of Nothing Description Updated
Jul 5, 2022 2:31 pm CRCGamer Note Added: 0067054
Jul 8, 2022 4:28 pm BadgerBadger Assigned To zeusalmighty => CRCGamer
Jul 8, 2022 4:28 pm BadgerBadger Status assigned => resolved
Jul 8, 2022 4:28 pm BadgerBadger Resolution open => fixed
Jul 8, 2022 4:28 pm BadgerBadger Note Added: 0067062