View Issue Details

IDProjectCategoryLast Update
0027075AI War 2Balance IssueMay 21, 2022 10:07 pm
ReporterBob_1 Assigned ToDaniexpert  
Severitymajor 
Status closedResolutionno change required 
Product Version5.000 End Of An Era 
Summary0027075: Corrosive effect Penetrates Bubble Shields
DescriptionIn my current game I ran into the issue that a single corrosive guardian can take out multiple force field generators with its death explosion. I was very surprised to see that the corrosive effect ignores shields and can just kill the super weak generator.

This effectively makes it so that if 1 of these guardians ever gets close to a shield generator It is guaranteed to die. I feel like this is either an oversight or a serious balance issue as many planets become undefendable if attacked like that.

I can understand it ignoring personal shielding as its niche but bubble shields should be immune considering their tiny health.
TagsNo tags attached.

Relationships

related to 0027120 resolvedzeusalmighty Corrosive Guardians Slaughtering Turrets 

Activities

BadgerBadger

Apr 22, 2022 3:34 pm

manager   ~0066266

I feel like this is working as intended, but if others disagree I can modify the effect

BadgerBadger

Apr 28, 2022 1:18 pm

manager   ~0066531

This is a pretty different problem from the corrosive guardian issue

KDR_11k

Apr 28, 2022 5:16 pm

reporter   ~0066533

Seems odd, after all fusion weapons don't go through bubble shields like they do through personal shields so I'd expect corrosion to work the same way. Specialized anti-bubble weapons just do bonus damage, never bypass it.

Issue History

Date Modified Username Field Change
Apr 22, 2022 3:29 pm Bob_1 New Issue
Apr 22, 2022 3:34 pm BadgerBadger Note Added: 0066266
Apr 28, 2022 12:08 pm Bob_1 Relationship added related to 0027120
Apr 28, 2022 1:18 pm BadgerBadger Note Added: 0066531
Apr 28, 2022 5:16 pm KDR_11k Note Added: 0066533
May 21, 2022 10:07 pm Daniexpert Assigned To => Daniexpert
May 21, 2022 10:07 pm Daniexpert Status new => closed
May 21, 2022 10:07 pm Daniexpert Resolution open => no change required