View Issue Details

IDProjectCategoryLast Update
0026101AI War 2Bug - OtherJan 14, 2022 9:26 pm
Reporterlinux-tyyppi Assigned Tox4000Bughunter  
Severitymajor 
Status resolvedResolutionfixed 
Product VersionBeta 3.783 The Return Of Multiplayer! 
Fixed in VersionBeta 3.784 Tractor Recursion 
Summary0026101: Factions shut down from fatal errors
DescriptionI have a save file that gets that title error. Multiple factions are shutting down.
How to reproduce:
Open save "before bug.save", unpause, wait less than a minute and there are lots of errors. Reproduce for me every time.
Also I have "after bug.save" from moment later when bugs have happened. That is bugged every time I open it and unpause.
If I load few minutes earlier save and do same thing, bug happens sometimes, but not always.
TagsNo tags attached.

Activities

linux-tyyppi

Jan 12, 2022 2:15 pm

reporter  

after bug.save (716,521 bytes)
before bug.save (654,553 bytes)

linux-tyyppi

Jan 12, 2022 2:47 pm

reporter   ~0063750

This is a save file from a moment earlier, if that helps. If I do the same thing, bug happens sometimes, but not always.
What I do:
Move all fleets to planet "Deep-Web". After clearing the planet, hack cruiser Voidpiercer Cruiser for fleet number 4.
moment earlier.save (648,013 bytes)

x4000Bughunter

Jan 13, 2022 6:23 pm

administrator   ~0063768

Thanks for the saves! Can I also have the ArcenDebugLog.txt? In this case, that's probably what I need, since this is unreliable. I may have fixed it already with the other fixes going into this build, not sure.

linux-tyyppi

Jan 14, 2022 2:22 am

reporter   ~0063788

The bug does not happen anymore with the latest beta version. Even the "after bug.save" isn't bugged anymore.

x4000Bughunter

Jan 14, 2022 9:26 pm

administrator   ~0063797

Wonderful, thank you for the confirmation!

Issue History

Date Modified Username Field Change
Jan 12, 2022 2:15 pm linux-tyyppi New Issue
Jan 12, 2022 2:15 pm linux-tyyppi File Added: after bug.save
Jan 12, 2022 2:15 pm linux-tyyppi File Added: before bug.save
Jan 12, 2022 2:47 pm linux-tyyppi Note Added: 0063750
Jan 12, 2022 2:47 pm linux-tyyppi File Added: moment earlier.save
Jan 13, 2022 6:23 pm x4000Bughunter Assigned To => x4000Bughunter
Jan 13, 2022 6:23 pm x4000Bughunter Status new => feedback
Jan 13, 2022 6:23 pm x4000Bughunter Note Added: 0063768
Jan 14, 2022 2:22 am linux-tyyppi Note Added: 0063788
Jan 14, 2022 2:22 am linux-tyyppi Status feedback => assigned
Jan 14, 2022 9:26 pm x4000Bughunter Status assigned => resolved
Jan 14, 2022 9:26 pm x4000Bughunter Resolution open => fixed
Jan 14, 2022 9:26 pm x4000Bughunter Fixed in Version => Beta 3.784 Tractor Recursion
Jan 14, 2022 9:26 pm x4000Bughunter Note Added: 0063797