View Issue Details

IDProjectCategoryLast Update
0026075AI War 2Bug - GameplayJan 10, 2022 10:00 am
Reporterdeadone77 Assigned ToBadgerBadger  
Severitymajor 
Status resolvedResolutionfixed 
Product VersionBeta 3.774 Metal Flows 
Fixed in VersionBeta 3.782 Smooth Reloading 
Summary0026075: Endgame-endless threat per second
DescriptionAt the start of this save all is still good, but if i take one of the 2 planets (Flame Outside V, Elraine) in the top middle, endless threat will start every 5 seconds.
This can still be triggered in 3.781.
TagsNo tags attached.

Activities

deadone77

Jan 7, 2022 2:55 am

reporter  

BadgerBadger

Jan 7, 2022 6:47 pm

manager   ~0063698

This hunter force is spawning due to the TaggedUnitIncomeData code. Unclear why there's so much of it...

x4000Bughunter

Jan 9, 2022 3:57 pm

administrator   ~0063720

Badger, it's generating infinite force at a very fast rate against the Dark Zenith Epistyle that is allied to the player. It's also generating what looks like infinite force at a smaller rate against the MDC that the player has.

I don't think that infinitely-generating stuff is the way to go, but rather if it's up to some cap that makes sense I suppose. Also, if it's something that the player controls and can deal with (the MDC), we should probably let them know what is happening so that it's not opaque.

I am not familiar with the TaggedUnitIncomeData code or when it was added or why, so I don't have a good solution in mind. Not sure if you have any ideas? This seems like mostly a problem if the player has strong allies, but it's hard to be sure.

BadgerBadger

Jan 9, 2022 4:26 pm

manager   ~0063723

Last edited: Jan 9, 2022 4:29 pm

So this was added a long time ago to give the AI some bonus resources against certain objectives. It was added in the DLC2 timeframe to A. give the AI a mechanism to counteract the DZ and B. to replace the "AI gets bonus exo-strikes against MDCs" with a less obvious mechanism.

The problem is that the AI should not be getting a ton of ships, just a few. This problem seems to be a recent breakage.

x4000Bughunter

Jan 9, 2022 9:31 pm

administrator   ~0063725

Thanks!

* The "tagged unit income" that was a hunter mechanic added about a year ago has been removed for now.
** Essentially, it could result in a variety of rare late-game situations where there were infinitely-spawning units, or just an unbalanced number in general, although that was probably pretty rare.
** Overall we've added a lot of other mechanics (border aggression, wormhole invasions) that go after the same concept in a more interesting way, so we'll probably re-implement a hunter mechanic against specific targets in a fashion like that.
** For now, simply getting rid of a source of infinite spawns seemed like the first step.

deadone77

Jan 10, 2022 5:44 am

reporter   ~0063732

FYI, there a 2 Dark Zenith Epistyle factions in this game, one is allied to the player and one is not
and Extragalactic forces are set to IGNORE the player+allies but not other minor factions.
Maybe the AI is confuse becauze against one Dark Zenith Epistyle it can spawn Extragalactic forces and against the other not.

x4000Bughunter

Jan 10, 2022 10:00 am

administrator   ~0063733

That might be part of it, yeah -- this is quite a useful save, thank you!

Issue History

Date Modified Username Field Change
Jan 7, 2022 2:55 am deadone77 New Issue
Jan 7, 2022 2:55 am deadone77 File Added: 3774abcdefghijklmnopqrstuvwx.save
Jan 7, 2022 6:47 pm BadgerBadger Note Added: 0063698
Jan 9, 2022 3:55 pm x4000Bughunter Assigned To => BadgerBadger
Jan 9, 2022 3:55 pm x4000Bughunter Status new => assigned
Jan 9, 2022 3:57 pm x4000Bughunter Note Added: 0063720
Jan 9, 2022 4:26 pm BadgerBadger Note Added: 0063723
Jan 9, 2022 4:29 pm BadgerBadger Note Edited: 0063723
Jan 9, 2022 9:31 pm x4000Bughunter Status assigned => resolved
Jan 9, 2022 9:31 pm x4000Bughunter Resolution open => fixed
Jan 9, 2022 9:31 pm x4000Bughunter Fixed in Version => Beta 3.782 Smooth Reloading
Jan 9, 2022 9:31 pm x4000Bughunter Note Added: 0063725
Jan 10, 2022 5:44 am deadone77 Note Added: 0063732
Jan 10, 2022 10:00 am x4000Bughunter Note Added: 0063733