View Issue Details

IDProjectCategoryLast Update
0024828AI War 2Gameplay IdeaMay 12, 2022 5:21 pm
Reporterzeusalmighty Assigned Tozeusalmighty  
Severityminor 
Status resolvedResolutionfixed 
Product Version2.900 First Press Build 
Summary0024828: Architrave feature -- have a planetary cap for the Castra (defensive structure)
DescriptionI have reworked the ZA's Castra (formerly a turret) into a 2-stage structure to encourage raiding the ZA

The first stage is the Castra. It's basically a minor distribution node. Kill it for the resources, but it then spawns a phased version of itself

The Phased Castra acts similarly to the Dire Guardian lair from classic. It will every 30 minutes release D.Guardian tier ZA units.

The problem is that the ZA builds way too many Castra. So I would love a planetary cap of 1 Castra per planet.

I think planetary is preferable to galactic because you would still get weird planets with 5 of them or something.

TagsNo tags attached.

Relationships

parent of 0024840 resolvedzeusalmighty ZA bugreport -- Castra building over planet cap 

Activities

zeusalmighty

May 6, 2021 9:22 pm

manager   ~0061393

I kept the Castra a defensive structure because it makes sense that it is placed under protection

BadgerBadger

May 7, 2021 10:52 am

manager   ~0061402

I have added a cap of 1 per planet

zeusalmighty

May 9, 2021 8:01 pm

manager   ~0061468

I'm still seeing 2 on a planet
2 Castra on 1 planet.save (218,896 bytes)

BadgerBadger

May 12, 2021 10:04 am

manager   ~0061530

I believe this should be fixed.

Issue History

Date Modified Username Field Change
May 6, 2021 9:16 pm zeusalmighty New Issue
May 6, 2021 9:22 pm zeusalmighty Note Added: 0061393
May 7, 2021 10:52 am BadgerBadger Note Added: 0061402
May 8, 2021 12:55 am zeusalmighty Relationship added parent of 0024840
May 9, 2021 8:01 pm zeusalmighty File Added: 2 Castra on 1 planet.save
May 9, 2021 8:01 pm zeusalmighty Note Added: 0061468
May 12, 2021 10:04 am BadgerBadger Assigned To => zeusalmighty
May 12, 2021 10:04 am BadgerBadger Status new => assigned
May 12, 2021 10:04 am BadgerBadger Note Added: 0061530
May 12, 2022 5:21 pm zeusalmighty Status assigned => resolved
May 12, 2022 5:21 pm zeusalmighty Resolution open => fixed