View Issue Details

IDProjectCategoryLast Update
0024687AI War 2[All Projects] Gameplay IssueApr 16, 2021 9:51 am
ReportervincoAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version2.800 The Paradigm Shift 
Fixed in Version2.802 Multiplayer Steams Onward 
Summary0024687: Error on first spire relic hack
DescriptionI completed the first spire relic hack in a new 2.8 game, and encountered the error in the attached image.

4/14/2021 10:02:32 PM 2.800 SINGLEP Exception hit during DoSuccessfulCompletionLogic_CalledFromMainSimOnly debug code 3100 System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.External.Hacking_SearchForRelic.DoSuccessfulCompletionLogic_Extra (Arcen.AIW2.Core.GameEntity_Squad Target, Arcen.AIW2.Core.Planet planet, Arcen.AIW2.Core.GameEntity_Squad Hacker, Arcen.AIW2.Core.ArcenSimContext Context, Arcen.AIW2.Core.HackingType type, Arcen.AIW2.Core.HackingEvent Event) [0x000b6] in <87a184a619a94ca4a875eefa1fe69ebd>:0
  at Arcen.AIW2.External.BaseHackingImplementation.DoSuccessfulCompletionLogic_CalledFromMainSimOnly (Arcen.AIW2.Core.GameEntity_Squad TargetOrNull, Arcen.AIW2.Core.Planet planet, Arcen.AIW2.Core.GameEntity_Squad Hacker, Arcen.AIW2.Core.ArcenSimContext Context, Arcen.AIW2.Core.HackingType type, Arcen.AIW2.Core.HackingEvent Event) [0x0045d] in <87a184a619a94ca4a875eefa1fe69ebd>:0
TagsNo tags attached.

Activities

vinco

Apr 14, 2021 10:07 pm

reporter  

Spire error.JPG (272,560 bytes)
v1.savemet (112 bytes)
v1.save (352,457 bytes)

BadgerBadger

Apr 16, 2021 2:10 am

manager   ~0061127

I can't reproduce this problem but I'll add some defensive code at some point

x4000Bughunter

Apr 16, 2021 9:51 am

administrator   ~0061128

Thanks!

* Fixed an exception that could happen when completing a spire relic hack if the spire relic was not on a nearby planet.

Issue History

Date Modified Username Field Change
Apr 14, 2021 10:07 pm vinco New Issue
Apr 14, 2021 10:07 pm vinco File Added: Spire error.JPG
Apr 14, 2021 10:07 pm vinco File Added: v1.save
Apr 14, 2021 10:07 pm vinco File Added: v1.savemet
Apr 16, 2021 2:10 am BadgerBadger Note Added: 0061127
Apr 16, 2021 9:51 am x4000Bughunter Assigned To => x4000Bughunter
Apr 16, 2021 9:51 am x4000Bughunter Status new => resolved
Apr 16, 2021 9:51 am x4000Bughunter Resolution open => fixed
Apr 16, 2021 9:51 am x4000Bughunter Fixed in Version => 2.802 Multiplayer Steams Onward
Apr 16, 2021 9:51 am x4000Bughunter Note Added: 0061128