View Issue Details

IDProjectCategoryLast Update
0024644AI War 2[All Projects] Crash/ExceptionApr 6, 2021 5:02 pm
ReporterStrategic SageAssigned Tox4000Bughunter 
Severitymajor 
Status closedResolutionunable to reproduce 
Product VersionBeta 2.765 The Hunt For Frigates And Civilians 
Fixed in Version 
Summary0024644: Fatal Error
DescriptionThe attached was an autosave; I cannot reproduce the issue when loading a save less than two minutes earlier, so it seems to be some sort of rare occurence type. This save cannot even be loaded, index outside the bounds of the array error results when trying. AI War 2 became non-responsive at around the time of this autosave, if that helps.
TagsNo tags attached.

Activities

Strategic Sage

Apr 1, 2021 2:59 pm

reporter  

FatalError.save (519,208 bytes)

x4000Bughunter

Apr 6, 2021 11:58 am

administrator   ~0061020

I think I asked on discord and I think that the answer was no, but is there anything in your error log from this time? If it errored right before (or during) saving, then a corrupt save happening after that is a secondary problem that I can't really address directly. It's kind of a "there's keeps being blood on my pants" problem if you keep cutting your leg. Since blood-resistant pants are impossible, and the cuts are the larger problem, I need to know what on earth is doing this leg-cutting and deal with that.

That was a slightly gruesome version of the explanation, but essentially downstream bugs are all byproducts like that.

Strategic Sage

Apr 6, 2021 12:49 pm

reporter   ~0061023

I didn't remember to check the error log right after it happened, so no - nothing I can give there. In that case, I'll just hope whatever the cause is rears it's head again so more info can be found.

x4000Bughunter

Apr 6, 2021 5:02 pm

administrator   ~0061024

Thanks! I'll mark this one as closed for now, then. There are a number of fatal errors that either were recently fixed or are about to be, so knock on wood hopefully it is one of those.

Issue History

Date Modified Username Field Change
Apr 1, 2021 2:59 pm Strategic Sage New Issue
Apr 1, 2021 2:59 pm Strategic Sage File Added: FatalError.save
Apr 6, 2021 11:58 am x4000Bughunter Note Added: 0061020
Apr 6, 2021 11:58 am x4000Bughunter Assigned To => x4000Bughunter
Apr 6, 2021 11:58 am x4000Bughunter Status new => feedback
Apr 6, 2021 12:49 pm Strategic Sage Note Added: 0061023
Apr 6, 2021 12:49 pm Strategic Sage Status feedback => assigned
Apr 6, 2021 5:02 pm x4000Bughunter Status assigned => closed
Apr 6, 2021 5:02 pm x4000Bughunter Resolution open => unable to reproduce
Apr 6, 2021 5:02 pm x4000Bughunter Note Added: 0061024