View Issue Details

IDProjectCategoryLast Update
0024643AI War 2[All Projects] Bug - GameplayApr 28, 2021 10:47 am
ReporterZweihander2021Assigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBeta 2.765 The Hunt For Frigates And Civilians 
Fixed in Version2.810 Hotfix for Death 
Summary0024643: AI golems forming AI officer fleets that cannot be destroyed
DescriptionThere is a AI golem that just refuses to die. It has the same crippled status as a regular flagship, and is also part of an Officer fleet as a hunter fleet member. Its right behind my territory
TagsNo tags attached.

Activities

Zweihander2021

Apr 1, 2021 4:14 am

reporter  

AI Officers.save (385,929 bytes)

BadgerBadger

Apr 1, 2021 3:06 pm

manager   ~0060991

Is this a DLC2 save?

zeusalmighty

Apr 1, 2021 4:51 pm

developer   ~0060992

This sounds like one of Arnaud's golems (for DLC 2) without looking at the save

x4000Bughunter

Apr 6, 2021 12:00 pm

administrator   ~0061021

This sounds like AI golems in general, which have not really been used in practice in a long time.

x4000Bughunter

Apr 6, 2021 12:16 pm

administrator   ~0061022

Planet Leirserson, Gladiator AI type, it's the Preserver golem. I think that basically the "AI variant" of this is not set up properly like in the base game golems.

I went in and looked, and essentially this is the non-AI variant of the golem for some reason. @zeusalmighty did you fix something with this in the recent past? Because it looks correct in the current code.

zeusalmighty

Apr 26, 2021 2:23 pm

developer   ~0061245

I haven't done anything with Arnaud's golems. But I can confirm I have been seeing these golems seed (specifically with the Gladiator AI type) and they still cripple instead of dying like conventional AI golems

So this is still an issue that will need to be resolved

x4000Bughunter

Apr 26, 2021 2:26 pm

administrator   ~0061246

Cool, thanks for the heads up. Will look into it!

x4000Bughunter

Apr 28, 2021 10:47 am

administrator   ~0061256

Thanks!

* Adjusted things so that non-human factions can never have the crippled status on their units. So even if a human-style golem gets added to an AI (as was happening with some DLC2 golems and the Gladiator AI type), you'll never run into them being immortal crippled gods. This seemed like the most expedient way to fix the issue, especially when thinking about mods that might make the same sort of error. Just make it not an error.

x4000Bughunter

Apr 28, 2021 10:47 am

administrator   ~0061257

Oh -- and this one I did test, and it works.

Issue History

Date Modified Username Field Change
Apr 1, 2021 4:14 am Zweihander2021 New Issue
Apr 1, 2021 4:14 am Zweihander2021 File Added: AI Officers.save
Apr 1, 2021 3:06 pm BadgerBadger Note Added: 0060991
Apr 1, 2021 4:51 pm zeusalmighty Note Added: 0060992
Apr 6, 2021 12:00 pm x4000Bughunter Note Added: 0061021
Apr 6, 2021 12:16 pm x4000Bughunter Note Added: 0061022
Apr 6, 2021 12:17 pm x4000Bughunter Assigned To => x4000Bughunter
Apr 6, 2021 12:17 pm x4000Bughunter Status new => feedback
Apr 26, 2021 2:23 pm zeusalmighty Note Added: 0061245
Apr 26, 2021 2:26 pm x4000Bughunter Note Added: 0061246
Apr 28, 2021 10:47 am x4000Bughunter Status feedback => resolved
Apr 28, 2021 10:47 am x4000Bughunter Resolution open => fixed
Apr 28, 2021 10:47 am x4000Bughunter Fixed in Version => 2.810 Hotfix for Death
Apr 28, 2021 10:47 am x4000Bughunter Note Added: 0061256
Apr 28, 2021 10:47 am x4000Bughunter Note Added: 0061257