View Issue Details

IDProjectCategoryLast Update
0024604AI War 2Bug - GameplayApr 7, 2021 2:56 pm
ReporterIthuriel0 Assigned Tox4000Bughunter  
Severityminor 
Status resolvedResolutionfixed 
Product VersionBeta 2.762 Performance Hotfix 
Fixed in VersionBeta 2.770 Multiplayer Metal 
Summary0024604: AI Spire Citadel beam weapon deals absurd damage to targets other than its main target
DescriptionThe Spire Citadel is doing far too much damage with its main beam compared to what the tooltip says. At times it fires one shot at one Spire ship, and another one nearby takes over 1,500,000 damage. Zoom into Estocade from the attached save "Too much damage" and watch the first few shots from the Spire Citadel. One at least some of them, the Spire Battleships present at this planet will take over a million and a half damage. Weirdly, this is often not actually the Spire ship that the Citadel shot at.

I've also attached a save named "Telium hack" which is from right before I tried attacking this Citadel. If you mass all Spire ships present at the planet of James and order them to kill the Citadel on Estocade (making sure that they all go through the wormhole at about the same time), the entire fleet dies in about 34 seconds. That is:
-2x Battleship Flagship
-3x Cruiser Flagship
-1x Cruiser
-1x Destroyer
-4x Frigates
As far as I can tell, this is almost entirely done by the Spire Citadel. There is an OMD on the planet, but the Spire fleet kills it within a few seconds of entering the system. I can't see anything present in this system that can deal 0000154:0000070 million damage in 30 seconds.

I also just tried attacking the Citadel with a single Battleship Flagship and nothing else. The Battleship successfully killed the Citadel solo, where the entire combined fleet died trying to do so. When I try and send 2 Battleships simultaneously instead of just 1, one of the Battleships get crippled before even getting in range of the Spire Citadel. (Remember that one solo Battleship was enough to kill the Citadel previously).

Something is clearly going on here where the AI Spire Citadel's beam is dealing massive damage to enemies other than its main target.
TagsNo tags attached.

Activities

Ithuriel0

Mar 26, 2021 2:37 am

reporter  

Too much damage.save (1,172,776 bytes)
Telium Hack.save (1,151,629 bytes)

Lord Of Nothing

Mar 26, 2021 9:10 am

reporter   ~0060897

I must admit, I was wondering if something similar was happening with an AI Spire research lab last night, but the system was a lot busier so it was hard to be sure and didn't make a good mantis case.

Zweihand

Mar 26, 2021 10:35 am

reporter   ~0060899

Also a quick spire match to test something else (Railgun shop). I concur, I had the citadel and research lab wiping out entire fleets. Can't say this applies to all beam weapons but it seems a bit inconsistent too.

Lord Of Nothing

Mar 26, 2021 7:25 pm

reporter   ~0060925

I think this bug affects all coilbeams. I had a go at an old AI homeworld assault that I used to loose overwhelmingly, and this time my spirefleet butchered it's way through with effortless ease (spirefleet ~17k strength), aI defence fleet ~45k strength, and the AI lost more than 25k strength for barely any losses of my own), right up until the AI dragons (Coilbeams!) came back, and then my fleet was butchered itself in seconds.
I then re-tried, and didn't focus the AI mothership, which has a coilbeam, and my fleet died much earlier.
I then re-tried again, paying more attention, and things were fine until the dragons, and I could watch all the healthbars of my fleet going down at once by large amounts - and these are dreadnaught healthbars, mind.

There was also a case earlier where I was watching a single low level city structure shooting at an exo wave, and it looked like things were melting far faster than a mere 60k DPS should be achieving.

This got me curious enough to do a test in the attached saves closely watching a single spire cruiser. It has a 60k coilbeam, so that's a max of 120k damage per shot. Taking it against the ships in the first save seems suspicious, it kills them far faster than it ought to. But the really interesting one is the second save, where it is targeting some poor old ai tachyon sentinels. They have 72500 HP each. A line of three is shot by the coilbeam. the target survives, with 2500 hp, but the other two die completely.
coilbeam test 2.save (219,742 bytes)
coilbeam test.save (231,661 bytes)

Zweihand

Mar 26, 2021 9:10 pm

reporter   ~0060929

Yeah, it seems like coil beams are the main culprit here because regular old multibeam doesn't work

Zweihand

Mar 27, 2021 2:57 pm

reporter   ~0060937

Just tested today with lost spire frigate. The photo lance and other beam weapon types don't have this problem, just coil beams do

zharmad

Mar 29, 2021 5:03 pm

reporter   ~0060959

Okay, so this is why the Dragons and an Spire Research Lab was causing so much more trouble than the rest of the AI forces in my current game. Two Dragons disabled my entire Spire fleet (7 cities worth) in a shoot out, losing one Dragon in the process.

x4000Bughunter

Apr 7, 2021 2:56 pm

administrator   ~0061028

* ArnaudB fixed a math bug of ours where Coilbeams were dealing 100x as much damage as intended to any targets beyond the first. Essentially, the math forgot to divide by 100 at the end of doing some percentage calculations.
** Thanks to ArnaudB for fixing, and Ithuriel0, Lord Of Nothing, Zweihander2021, zharmad, and others for reporting.

Issue History

Date Modified Username Field Change
Mar 26, 2021 2:37 am Ithuriel0 New Issue
Mar 26, 2021 2:37 am Ithuriel0 File Added: Too much damage.save
Mar 26, 2021 2:37 am Ithuriel0 File Added: Too much damage.savemet
Mar 26, 2021 2:37 am Ithuriel0 File Added: Telium Hack.save
Mar 26, 2021 2:37 am Ithuriel0 File Added: Telium Hack.savemet
Mar 26, 2021 9:10 am Lord Of Nothing Note Added: 0060897
Mar 26, 2021 10:35 am Zweihand Note Added: 0060899
Mar 26, 2021 7:25 pm Lord Of Nothing File Added: coilbeam test 2.save
Mar 26, 2021 7:25 pm Lord Of Nothing File Added: coilbeam test.save
Mar 26, 2021 7:25 pm Lord Of Nothing Note Added: 0060925
Mar 26, 2021 9:10 pm Zweihand Note Added: 0060929
Mar 27, 2021 2:57 pm Zweihand Note Added: 0060937
Mar 29, 2021 5:03 pm zharmad Note Added: 0060959
Apr 7, 2021 2:56 pm x4000Bughunter Assigned To => x4000Bughunter
Apr 7, 2021 2:56 pm x4000Bughunter Status new => resolved
Apr 7, 2021 2:56 pm x4000Bughunter Resolution open => fixed
Apr 7, 2021 2:56 pm x4000Bughunter Fixed in Version => Beta 2.770 Multiplayer Metal
Apr 7, 2021 2:56 pm x4000Bughunter Note Added: 0061028