View Issue Details

IDProjectCategoryLast Update
0024445AI War 2[All Projects] Gameplay IssueFeb 20, 2021 2:30 pm
Reporterx4000BughunterAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionno change required 
Product VersionBeta 2.742 Hacking Balance 
Fixed in Version 
Summary0024445: Make scourge scale based on science gathered, not science spent.
DescriptionThis plays poorly with science refunds, as ArnaudB notes. And in general it encourages science hoarding.
TagsNo tags attached.

Activities

BadgerBadger

Feb 18, 2021 12:30 pm

manager   ~0060563

I think the science required should probably be increased.

BadgerBadger

Feb 18, 2021 12:35 pm

manager   ~0060564

This was intended to be an invisible mechanic that just made the scourge seem to scale up with your available power.

x4000Bughunter

Feb 18, 2021 1:28 pm

administrator   ~0060565

I remember the discussions from back at the time of... one of the things that players tend to notice in general is that eventually invisible mechanics leak out and it becomes part of the meta. Then you get other players going "why didn't I know this?"

I agree with the general concept of something that scales with player power, but even in RPGs with level-scaling, players tend to notice and then plan around that in some fashion. If mission rewards don't scale, do all the missions in the area early or it's useless. If they do, skip some and come back later, etc, for maybe outsized rewards for simple quests.

I remember in Chrono Trigger, there were some mysterious boxes that you could open only halfway through the game and on, once you had a special item. But since it involved time travel, if you opened them in the earlier eras first, then you'd miss out on stuff from the later eras. This is intuitive, but was never explained. So it's better to go era by era, opening them in reverse order, to collect the boxes multiple times without a paradox kicking in for whatever reason.

I think that... invisible mechanics are tricky. I like them, but I recognize the challenges they present at the same time.

x4000Bughunter

Feb 20, 2021 2:30 pm

administrator   ~0060580

Looks like this has been handled a different way by Arnaud.

Issue History

Date Modified Username Field Change
Feb 18, 2021 11:50 am x4000Bughunter New Issue
Feb 18, 2021 11:50 am x4000Bughunter Status new => assigned
Feb 18, 2021 11:50 am x4000Bughunter Assigned To => x4000Bughunter
Feb 18, 2021 12:30 pm BadgerBadger Note Added: 0060563
Feb 18, 2021 12:35 pm BadgerBadger Note Added: 0060564
Feb 18, 2021 1:28 pm x4000Bughunter Note Added: 0060565
Feb 20, 2021 2:30 pm x4000Bughunter Status assigned => closed
Feb 20, 2021 2:30 pm x4000Bughunter Resolution open => no change required
Feb 20, 2021 2:30 pm x4000Bughunter Note Added: 0060580