View Issue Details

IDProjectCategoryLast Update
0023708AI War 2[All Projects] Bug - GameplaySep 14, 2020 11:43 am
ReporterMasterGeeseAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionduplicate 
Product Version2.500 Multiplayer Alpha Begins Now! 
Fixed in Version2.504 Clarity And Fair Play 
Summary0023708: Thunderchild Regenerating childs while being hit
DescriptionUsing Civilian Industries mod.

There is a thunderchild in Terrible Majesty that is being hit but is still regenerating shields as if out of combat.
TagsNo tags attached.

Relationships

duplicate of 0023670 resolvedx4000Bughunter Ship is regenerating while being shot at 
related to 0023715 resolvedx4000Bughunter The "repair when drastically outnumber" skews deep strike raiding and exo-war unit balance (and possibly more) 

Activities

MasterGeese

Sep 12, 2020 1:26 pm

reporter  

regenerating thunderchild.save (6,624,517 bytes)

x4000Bughunter

Sep 14, 2020 11:43 am

administrator   ~0058501

Thanks!

* On September 6, we added the following: "QoL tweak for repair. Any ships on a planet where you outnumber the enemies 10 to 1, or the enemies have less that .2 strength are eligible to be repaired immediately. The previous rule was 'Any ships on a planet without enemies'"
** This now only applies to ships and structures of factions that are friendly to the humans. Any neutral or enemy factions will now use the old style of logic that existed prior to September 6th.
** This prevents the AI and Exos in particular from developing invincible shields when they have overwhelming firepower against you, among some other unintended consequences.

Issue History

Date Modified Username Field Change
Sep 12, 2020 1:26 pm MasterGeese New Issue
Sep 12, 2020 1:26 pm MasterGeese File Added: regenerating thunderchild.save
Sep 12, 2020 2:41 pm crawlers Relationship added duplicate of 0023670
Sep 12, 2020 8:09 pm Ovalcircle Relationship added related to 0023715
Sep 14, 2020 11:43 am x4000Bughunter Assigned To => x4000Bughunter
Sep 14, 2020 11:43 am x4000Bughunter Status new => resolved
Sep 14, 2020 11:43 am x4000Bughunter Resolution open => duplicate
Sep 14, 2020 11:43 am x4000Bughunter Fixed in Version => 2.504 Clarity And Fair Play
Sep 14, 2020 11:43 am x4000Bughunter Note Added: 0058501