View Issue Details

IDProjectCategoryLast Update
0023698AI War 2[All Projects] Bug - OtherSep 14, 2020 6:43 pm
ReporterRocketAssistedPuffinAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBeta 2.502 Regression Fixes 
Fixed in Version2.505 Multiplayer Alpha Starts, Take Two 
Summary0023698: Multiplayer: Large desync on Client
DescriptionWith StarKelp as host and me as Client, if I attempt to capture a planet, the Command Station soon disappears. Attempting to build it again will indicate one already exists, and soon the new one will also disappear. StarKelp reports it is there on his side.

His Stations also do this to my view. Saving, then loading has them all appear for me correctly.

We tried the..."Log All Decoded Network Sync Data To Disk" option, and have both my file, his, and the save required. Blow up the AI Command Station, build one as me (name "Puffin"). Few seconds later it should vanish.

Can report that AIP from planets at least is working, and so is Hacking Points. AIP did temporarily go up to 70 on my side visually, but corrected to 50 shortly after.
TagsNo tags attached.

Relationships

related to 0023686 resolvedx4000Bughunter Multiplayer: client ships are being deleted rather than synced properly on first planet. 

Activities

RocketAssistedPuffin

Sep 11, 2020 1:54 pm

reporter  

NetworkSyncMessagesHost.zip (2,189,786 bytes)
Blow_It_Up.save (256,639 bytes)
NetworkSyncMessagesPuffinClient.zip (2,241,425 bytes)

x4000Bughunter

Sep 11, 2020 2:47 pm

administrator   ~0058454

Something is Very Very Wrong with ship sync, and I'm not sure what that is, yet. Hopefully these are all the same sort of issue, but fingers crossed. I'll take a look at your logs and see if they have any clues, but for me the logs are clean but the actual activity that is being caused is just... wrong for some reason.

x4000Bughunter

Sep 11, 2020 3:28 pm

administrator   ~0058457

Update: I have run a comparison of the log files from those two machines, and I can confirm that they are identical. The host sent exactly what the client received. The client code is just bad, I have a feeling. That confirms it's the same sort of thing I've been seeing incorrectly in my test last night.

I'll see if I can fix it all in one swoop (fingers crossed).

x4000Bughunter

Sep 14, 2020 6:43 pm

administrator   ~0058511

Thanks!

This all seems to be resolved now!

https://wiki.arcengames.com/index.php?title=AI_War_2:Multiplayer_Alpha_And_Beta#Multiplayer_Sync_Initial_Implementation_Now_Tests_Out_Initially_Working

Though there will be new issues, I'm sure.

Issue History

Date Modified Username Field Change
Sep 11, 2020 1:54 pm RocketAssistedPuffin New Issue
Sep 11, 2020 1:54 pm RocketAssistedPuffin File Added: NetworkSyncMessagesHost.zip
Sep 11, 2020 1:54 pm RocketAssistedPuffin File Added: NetworkSyncMessagesPuffinClient.zip
Sep 11, 2020 1:54 pm RocketAssistedPuffin File Added: Blow_It_Up.save
Sep 11, 2020 2:45 pm x4000Bughunter Relationship added related to 0023686
Sep 11, 2020 2:45 pm x4000Bughunter Assigned To => x4000Bughunter
Sep 11, 2020 2:45 pm x4000Bughunter Status new => assigned
Sep 11, 2020 2:47 pm x4000Bughunter Note Added: 0058454
Sep 11, 2020 3:28 pm x4000Bughunter Note Added: 0058457
Sep 14, 2020 6:43 pm x4000Bughunter Status assigned => resolved
Sep 14, 2020 6:43 pm x4000Bughunter Resolution open => fixed
Sep 14, 2020 6:43 pm x4000Bughunter Fixed in Version => 2.505 Multiplayer Alpha Starts, Take Two
Sep 14, 2020 6:43 pm x4000Bughunter Note Added: 0058511