View Issue Details

IDProjectCategoryLast Update
0023345AI War 2[All Projects] Crash/ExceptionJun 30, 2020 4:15 pm
Reporterrelmz32Assigned Tox4000Bughunter 
Severityblock 
Status resolvedResolutionfixed 
Product VersionBeta 2.086 Tell Me About The Zenith, Voice Lady 
Fixed in VersionBeta 2.088 Banishment of Undead AIs 
Summary0023345: New games don't start in 2.086
Descriptionjust constant "System.MissingFieldException: Field 'Arcen.AIW2.Core.GameEntityTypeData.Tags' not found." prevent the game from starting.
TagsNo tags attached.

Relationships

duplicate of 0023344 resolvedx4000Bughunter Bug report -- Saves still broken (maybe more so) 
related to 0023347 resolvedx4000Bughunter MissingFieldException spam immediately after game start, unable to save game 

Activities

relmz32

Jun 29, 2020 11:20 pm

reporter  

ArcenDebugLog.txt (2,064,860 bytes)

marty651

Jun 30, 2020 12:27 am

reporter   ~0057454

I can confirm this. Same here with new games but also saved ones. Needs to kill the game process to get out of the log loop.
The problem does not occur in v. 2084.

x4000Bughunter

Jun 30, 2020 9:29 am

administrator   ~0057457

There's a bug in my new compiler chain, sorry about this! Working on fixing it.

I would use the beta_currentstable branch for now until this resolves.

Sorry about this!

x4000Bughunter

Jun 30, 2020 4:15 pm

administrator   ~0057465

Thanks!

* Fixed several different compiler chain issues that could lead to copying a silly number of dlls to the GameData\ModdableLogicDLLs folder, and in a couple of cases could then also lead to us not getting all of the code actually where it needed to go.
** One result of this was in the prior beta version, there were some MethodNotFound exceptions because outdated versions of the external dlls were in place.

Issue History

Date Modified Username Field Change
Jun 29, 2020 11:20 pm relmz32 New Issue
Jun 29, 2020 11:20 pm relmz32 File Added: ArcenDebugLog.txt
Jun 30, 2020 12:27 am marty651 Note Added: 0057454
Jun 30, 2020 9:29 am x4000Bughunter Note Added: 0057457
Jun 30, 2020 9:29 am x4000Bughunter Relationship added duplicate of 0023344
Jun 30, 2020 9:29 am x4000Bughunter Assigned To => x4000Bughunter
Jun 30, 2020 9:29 am x4000Bughunter Status new => assigned
Jun 30, 2020 3:57 pm BadgerBadger Relationship added related to 0023347
Jun 30, 2020 4:15 pm x4000Bughunter Status assigned => resolved
Jun 30, 2020 4:15 pm x4000Bughunter Resolution open => fixed
Jun 30, 2020 4:15 pm x4000Bughunter Fixed in Version => Beta 2.088 Banishment of Undead AIs
Jun 30, 2020 4:15 pm x4000Bughunter Note Added: 0057465