View Issue Details

IDProjectCategoryLast Update
0023339AI War 2[All Projects] Bug - GameplayJul 1, 2020 1:34 pm
ReporterOryutzenAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product VersionBeta 2.083 External Data Hotfix 
Fixed in VersionBeta 2.088 Banishment of Undead AIs 
Summary0023339: Mousing over certain units that aren't mine drops an exception
DescriptionSeems to be an error, but every time I mouse over certain units, including enemy strikecraft and scourge warriors (or at least some of them), it throws up an exception. Units that trigger the exception do so consistently.
TagsNo tags attached.

Relationships

related to 0023348 resolvedx4000Bughunter Problem with GetRandomRowWithTag 

Activities

Oryutzen

Jun 26, 2020 9:29 pm

reporter  

Glitchin out.save (247,712 bytes)
Glitchin out.savemet (96 bytes)

BadgerBadger

Jun 27, 2020 3:14 pm

manager   ~0057446

Last edited: Jun 27, 2020 3:18 pm

View 3 revisions

Hey Chris, I've been seeing another issue that looks related:

6/27/2020 1:12:02 PM
Exception in entity tooltip text generation at stage 30531:System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
  at System.Collections.Concurrent.ConcurrentDictionary`2[TKey,TValue].ThrowKeyNotFoundException () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0
  at System.Collections.Concurrent.ConcurrentDictionary`2[TKey,TValue].get_Item (TKey key) [0x0000b] in <1f0c1ef1ad524c38bbc5536809c46b48>:0
  at Arcen.Universal.GameSettings.GetBoolBySetting (System.String setting) [0x00001] in <02a180520903413b933cafcdd61805fd>:0
  at Arcen.AIW2.External.Window_InGameHoverEntityInfo.GetTextForEntity (Arcen.Universal.ArcenDoubleCharacterBuffer buffer, Arcen.AIW2.Core.GameEntity_Base EntityBase, Arcen.AIW2.Core.Fleet+Membership MembershipBase, Arcen.AIW2.Core.GameEntityTypeData TypeDataOrNull, System.Int32 OptionalCountToShow, Arcen.AIW2.Core.Faction ForFactionOrNull, System.Byte OptionalForMarkLevel, Arcen.AIW2.Core.FromSidebarType IsFromSidebarType, Arcen.AIW2.External.ShipExtraDetailsInfo DetailsType) [0x044ff] in <786308d0b3124cc299b6215ca861a61e>:0


This is from the following line:
                    debugStage = 30531;
                    if ( ( relatedEntityOrNull.PlanetFaction.Faction.GetIsFriendlyToLocalFaction() && detailLevel >= TooltipDetail.Full)
                       || GameSettings.Current.GetBoolBySetting( "ShowFireteamHistory" ) )

It looks like it's unsafe to use your new ConcurrentDictionary under some circumstances. We definitely need to look at the player's settings when generating hovertext.


I could reproduce this by hovering over any units that are in fireteams (hunter, etc)

BadgerBadger

Jun 27, 2020 3:25 pm

manager   ~0057447

Last edited: Jun 27, 2020 3:25 pm

View 2 revisions

The setting in question is this one, which was enabled in DLC1:

Setting/TSR_Settings.xml: <setting name="ShowFireteamHistory" category="Debug" display_name="Show Fireteam Histories" type="BoolToggle" default="False"

But that setting doesn't seem to be appearing in the game anymore. I use that setting all the time for development of fireteam related stuff.

Confusingly, I definitely have DLC1 enabled.

You can recreate this easily with the Einde 5 save game from https://bugtracker.arcengames.com/view.php?id=23237

x4000Bughunter

Jun 30, 2020 11:02 am

administrator   ~0057458

This may fix it, or at least stop the error:

* Fixed a case of the GameSettings directly referencing RowsByName, which should never happen. Things should no longer error out if settings are missing.

BadgerBadger

Jun 30, 2020 4:01 pm

manager   ~0057464

Seems fixed now

x4000Bughunter

Jul 1, 2020 1:34 pm

administrator   ~0057488

I'm glad -- hopefully you are seeing the actual setting, etc, too. It did not come up in my other debugging on 0023348.

Issue History

Date Modified Username Field Change
Jun 26, 2020 9:29 pm Oryutzen New Issue
Jun 26, 2020 9:29 pm Oryutzen File Added: Glitchin out.save
Jun 26, 2020 9:29 pm Oryutzen File Added: Glitchin out.savemet
Jun 27, 2020 3:14 pm BadgerBadger Note Added: 0057446
Jun 27, 2020 3:15 pm BadgerBadger Assigned To => x4000Bughunter
Jun 27, 2020 3:15 pm BadgerBadger Status new => assigned
Jun 27, 2020 3:15 pm BadgerBadger Note Edited: 0057446 View Revisions
Jun 27, 2020 3:18 pm BadgerBadger Note Edited: 0057446 View Revisions
Jun 27, 2020 3:25 pm BadgerBadger Note Added: 0057447
Jun 27, 2020 3:25 pm BadgerBadger Note Edited: 0057447 View Revisions
Jun 30, 2020 11:02 am x4000Bughunter Note Added: 0057458
Jun 30, 2020 4:01 pm BadgerBadger Status assigned => resolved
Jun 30, 2020 4:01 pm BadgerBadger Resolution open => fixed
Jun 30, 2020 4:01 pm BadgerBadger Fixed in Version => Beta 2.088 Banishment of Undead AIs
Jun 30, 2020 4:01 pm BadgerBadger Note Added: 0057464
Jul 1, 2020 1:34 pm x4000Bughunter Note Added: 0057488
Jul 1, 2020 1:34 pm x4000Bughunter Relationship added related to 0023348