View Issue Details

IDProjectCategoryLast Update
0023338AI War 2[All Projects] Crash/ExceptionJun 26, 2020 9:58 am
ReporterNRSirLimboAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionduplicate 
Product VersionBeta 2.082 Are Wormholes Visible To The Naked Eye? 
Fixed in VersionBeta 2.083 External Data Hotfix 
Summary0023338: Galaxy Creation fails
DescriptionIn the current beta it's impossible to start a new custom game or quick start.
It seems the galaxy creation has a cascade of errors.

Tested it with verified steam files and set-to-default settings and controls.
TagsNo tags attached.

Relationships

duplicate of 0023337 resolvedx4000Bughunter Exception when opening lobby and unable to start campaign 

Activities

NRSirLimbo

Jun 26, 2020 6:46 am

reporter  

ArcenDebugLog.txt (799,769 bytes)

NRSirLimbo

Jun 26, 2020 6:48 am

reporter   ~0057433

Probably should'a checked, but it seems ANGRYABOUTELVES has hit the same issue and was faster.

x4000Bughunter

Jun 26, 2020 9:58 am

administrator   ~0057435

Thanks!

* Fixed a bug in the last few versions (since parallel load) that was causing exceptions in trying to cast to external data for various factions.
** We were not initially seeing this much, for some reason, but StarKelp was running into it internally with his own mod doing it intermittently. Now it's happening regularly after we put in some enforced sorting on these rows.
** For now we've just fixed the problem with the existing data, but this whole thing exposes an underlying weakness in the way that we link external data into the game. If people later are playing with multiple mods and change their mod order, they will potentially wind up with this bug without us being able to fix it (as far as their existing campaigns go). If both mods both have external data on the same units, which is actually not the majority case at all. So it's probably an outside chance of it happening naturally in playing. At any rate, it's on our list of things to refactor sometime after multiplayer, to be a bit more flexible in general, just in case.

Issue History

Date Modified Username Field Change
Jun 26, 2020 6:46 am NRSirLimbo New Issue
Jun 26, 2020 6:46 am NRSirLimbo File Added: ArcenDebugLog.txt
Jun 26, 2020 6:48 am NRSirLimbo Relationship added duplicate of 0023337
Jun 26, 2020 6:48 am NRSirLimbo Note Added: 0057433
Jun 26, 2020 9:58 am x4000Bughunter Assigned To => x4000Bughunter
Jun 26, 2020 9:58 am x4000Bughunter Status new => resolved
Jun 26, 2020 9:58 am x4000Bughunter Resolution open => duplicate
Jun 26, 2020 9:58 am x4000Bughunter Fixed in Version => Beta 2.083 External Data Hotfix
Jun 26, 2020 9:58 am x4000Bughunter Note Added: 0057435