View Issue Details

IDProjectCategoryLast Update
0023230AI War 2[All Projects] Crash/ExceptionJun 30, 2020 6:07 pm
ReporterKalieumAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version2.048 Bugfixes 
Fixed in VersionBeta 2.088 Banishment of Undead AIs 
Summary0023230: Error in targeting logic System.NullReferenceException: Object reference not set to an instance of an object
DescriptionWas playing the game normally, clearing up defences and threat when the game popped up with the error. It seemed happy to let me keep playing, but I saved and quit so I don't know if it would have had more issues had it kept running.
Looking at the log I started this game late October last year (and hadn't come back to it until ~a week ago) so it's been through a few versions, but it was running fine for a good two and a half hours prior to this.

The attached autosave is from ~five minutes prior, though I haven't confirmed if it's reproducible.
TagsNo tags attached.

Activities

Kalieum

May 28, 2020 10:39 pm

reporter  

Just after bug.savemet (94 bytes)
ArcenDebugLog.txt (37,969 bytes)
10/31/2017 11:16:18 PM	Calling RunInitialSetup for Arcen.AIW2.External.InitialSetupForDLL from AIWarExternalCode
10/31/2017 11:16:18 PM	Finished calling RunInitialSetup for Arcen.AIW2.External.InitialSetupForDLL from AIWarExternalCode
10/31/2017 11:16:20 PM	Harmless Info: dll AIWarExternalVisualizationCode does not contain a IInitialSetupForDLL type. This is fine, but if you're the author of that dll and want it to run init-code, it ain't happening right now.
10/31/2017 11:16:54 PM	World Created, Launching Server
10/31/2017 11:16:54 PM	Successfully opened host socket
10/31/2017 11:26:45 PM	Shutting Down Socket
10/31/2017 11:26:45 PM	PLAYER DISCONNECTED 0.0.0.0=>0
10/31/2017 11:26:45 PM	World Created, Launching Server
10/31/2017 11:26:45 PM	Successfully opened host socket
10/31/2017 11:30:09 PM	Shutting Down Socket
10/31/2017 11:30:09 PM	PLAYER DISCONNECTED 0.0.0.0=>0
10/23/2019 1:21:26 AM	Current directory used: D:/Games/Steam/steamapps/common/AI War 2/
Process Count = 0 so PlayerDataDirectory used: D:/Games/Steam/steamapps/common/AI War 2/PlayerData/
10/23/2019 1:21:26 AM	Boot up FleetOS (0.2980s)
10/23/2019 1:21:26 AM	graphicsDeviceType in use: Direct3D11
graphicsDeviceVersion in use: Direct3D 11.0 [level 11.0]
graphicsMultiThreaded: True
graphicsShaderLevel: 50
operatingSystem: Windows 7  (6.1.0) 64bit
graphicsDeviceName: NVIDIA GeForce GTX 770
graphicsDeviceID: 4484
graphicsDeviceVendor: NVIDIA
graphicsDeviceVendorID: 4318
graphicsDeviceVersion: Direct3D 11.0 [level 11.0]
graphicsMemorySize: 1979
maxTextureSize: 16384
npotSupport: Full
processorType: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
processorCount: 4
processorFrequency: 3500
systemMemorySize: 16330
supportedRenderTargetCount: 8
supportsComputeShaders: True
supportsShadows: True
usesReversedZBuffer: True
10/23/2019 1:21:26 AM	Check System Logs For Rogue Intelligence (0.0190s)
10/23/2019 1:21:26 AM	Organizing Alien Translation Routines (0.2720s)
10/23/2019 1:21:26 AM	Remembering Alamo (0.0950s)
10/23/2019 1:21:26 AM	Generating Framerates (0.0250s)
10/23/2019 1:21:26 AM	Bring Cloaking Systems Online (0.0090s)
10/23/2019 1:21:26 AM	Game Version: 1.001
10/23/2019 1:21:26 AM	Eject Trash Into Hyperspace (0.0210s)
10/23/2019 1:21:26 AM	Recalculate Speed Of Light (0.0510s)
10/23/2019 1:21:26 AM	Check Nearby Stellar Masses (0.0390s)
10/23/2019 1:21:26 AM	No resolution change was required.
10/23/2019 1:21:26 AM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
10/23/2019 1:21:26 AM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
10/23/2019 1:21:26 AM	Refresh Optical Lensing (0.0260s)
10/23/2019 1:21:27 AM	Revise Fundamental Physical Laws (0.1400s)
10/23/2019 1:21:27 AM	Boot Audio Comms (0.0180s)
10/23/2019 1:21:27 AM	Establish Individual Audio Links (0.0130s)
10/23/2019 1:21:27 AM	Prepare Explosions and Crackles (0.3740s)
10/23/2019 1:21:27 AM	Optimize Comfort On Command Decks (0.0650s)
10/23/2019 1:21:27 AM	Check For Extra Modules (0.0160s)
10/23/2019 1:21:27 AM	Calculate Odds Of Success (0.0160s)
10/23/2019 1:21:27 AM	Briefly Panic (0.1480s)
10/23/2019 1:21:27 AM	Install Confidence Routines (0.1820s)
10/23/2019 1:21:28 AM	Bring Commander Interface Online (0.2420s)
10/23/2019 1:21:28 AM	Motivate All Crews (0.0670s)
10/23/2019 1:21:28 AM	Externalizing Patterns (0.0370s)
10/23/2019 1:21:28 AM	Disengaging Constants (0.3550s)
10/23/2019 1:21:28 AM	Late Axionic Computations (0.0870s)
10/23/2019 1:21:28 AM	Thinking Of Advice (0.0070s)
10/23/2019 1:21:28 AM	Degaussing Advice (0.1870s)
10/23/2019 1:21:28 AM	Naming All Known Planets (0.0230s)
10/23/2019 1:21:28 AM	Remembering Speeds (0.0330s)
10/23/2019 1:21:29 AM	Prioritizing Targets (0.0140s)
10/23/2019 1:21:29 AM	Rebooting Sensor Arrays (0.0220s)
10/23/2019 1:21:29 AM	Unloading Prismatic Grid (0.0340s)
10/23/2019 1:21:29 AM	Thinking Of Objectives (0.0080s)
10/23/2019 1:21:29 AM	Re-Aligning Objectives (0.0290s)
10/23/2019 1:21:29 AM	Inhibiting Visual Scans (0.0250s)
10/23/2019 1:21:29 AM	Synthesizing Vocals (0.0080s)
10/23/2019 1:21:29 AM	Ventilating Scenarios (0.0250s)
10/23/2019 1:21:29 AM	Decontaminating Targeting Systems (0.0320s)
10/23/2019 1:21:29 AM	Ejecting Tactical Core (0.0180s)
10/23/2019 1:21:29 AM	Calibrating Formations (0.0070s)
10/23/2019 1:21:29 AM	Intercepting Galactic Maps (0.0140s)
10/23/2019 1:21:29 AM	Sterilizing Test Chamber (0.0100s)
10/23/2019 1:21:29 AM	Faction Diagnostics (0.0150s)
10/23/2019 1:21:29 AM	Buffering Hackers (0.0160s)
10/23/2019 1:21:29 AM	Inverting Death (0.0130s)
10/23/2019 1:21:29 AM	Linear Field Variance (0.0630s)
10/23/2019 1:21:29 AM	Charging Marks (0.0160s)
10/23/2019 1:21:29 AM	Range Manifolds (0.0090s)
10/23/2019 1:21:29 AM	Purging ROFs (0.0100s)
10/23/2019 1:21:29 AM	Manipulating Speeds (0.0090s)
10/23/2019 1:21:29 AM	Detecting Projectiles (0.0070s)
10/23/2019 1:21:29 AM	Grouping Flow Fields (0.0450s)
10/23/2019 1:21:29 AM	Modulating Flow Field Groups (0.0410s)
10/23/2019 1:21:29 AM	Designing Fleets (0.1690s)
10/23/2019 1:21:29 AM	Thinking Of Technologies (0.0110s)
10/23/2019 1:21:29 AM	Categorizing Starboard Sensors (0.0080s)
10/23/2019 1:21:29 AM	Injecting Galactic Variables (0.0610s)
10/23/2019 1:21:29 AM	Discharging Colored Ions (0.0400s)
10/23/2019 1:21:29 AM	Replicating Ion Colors (0.0060s)
10/23/2019 1:21:31 AM	Investigating Starfields (1.9431s)
10/23/2019 1:21:37 AM	Fondly Remembering Distant Planets (6.2754s)
10/23/2019 1:21:38 AM	Investigating Map Signatures (0.0450s)
10/23/2019 1:21:38 AM	Collating Solar Systems (0.0110s)
10/23/2019 1:21:38 AM	Categorizing All Planets (0.0040s)
10/23/2019 1:21:38 AM	Organizing Commands (0.0390s)
10/23/2019 1:21:38 AM	Calculating Firing Cones (0.0290s)
10/23/2019 1:21:39 AM	Jailbreaking Favorite Ship Parts (0.8861s)
10/23/2019 1:21:40 AM	Calculate Improbability (1.7841s)
10/23/2019 1:21:40 AM	Issuing Orders (0.0050s)
10/23/2019 1:21:40 AM	Augmenting Infusers (0.0080s)
10/23/2019 1:21:40 AM	Infusing (0.0330s)
10/23/2019 1:21:40 AM	Post-Proton Surge (0.0030s)
10/23/2019 1:21:40 AM	Calibrate Weapons Arrays (0.0310s)
10/23/2019 1:21:40 AM	Stimulate Modulation (0.0130s)
10/23/2019 1:21:41 AM	ArcenAssetBundleCache.InstantiatedObjects: 804
10/23/2019 1:21:41 AM	Load Surrogates (0.9091s)
10/23/2019 1:21:41 AM	Load Historical Documents (0.0020s)
10/23/2019 1:21:41 AM	15.7 seconds total load time.
Boot up FleetOS (0.3s)
Organizing Alien Translation Routines (0.3s)
Prepare Explosions and Crackles (0.4s)
Disengaging Constants (0.4s)
Investigating Starfields (1.9s)
Fondly Remembering Distant Planets (6.3s)
Jailbreaking Favorite Ship Parts (0.9s)
Calculate Improbability (1.8s)
Load Surrogates (0.9s)
10/23/2019 1:21:42 AM
Hello Steam user 'Kalieum'

  at System.Environment.get_StackTrace () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <b767637ee7f242c89ef063f5a736b53c>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <b767637ee7f242c89ef063f5a736b53c>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <b767637ee7f242c89ef063f5a736b53c>:0 
  at ArcenGameController.Update () [0x00000] in <7ecb30de8af740679f32416cd22b54b6>:0 

10/23/2019 1:23:52 AM	Base Color:  AIWC_Purple    Trim Color:  c1E90FF
10/23/2019 2:01:50 AM	Start Generate FULL Map with Tutorial_01 and seed 123456 and planet count 80 and 10 factions
10/23/2019 2:01:50 AM	World Created, Launching Server
10/23/2019 2:01:50 AM	Could not find LinkedFaction '' to assign to planet 'Sidelander', -1
10/23/2019 2:01:50 AM	PlayerAccount Kalieum has now been put in control of faction 1.
10/23/2019 2:01:50 AM	Successfully opened host socket
10/23/2019 2:16:22 AM	Base Color:  AIWC_Purple    Trim Color:  c00FFFF
10/23/2019 2:16:28 AM	Base Color:  AIWC_Purple    Trim Color:  c007BA7
10/23/2019 2:16:38 AM	Start Generate Partial Map with Clusters and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:16:38 AM	World Created, Launching Server
10/23/2019 2:17:03 AM	Start Generate Partial Map with Octopus and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:03 AM	Generate Partial Map Complete
10/23/2019 2:17:17 AM	Start Generate Partial Map with Simple and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:17 AM	Generate Partial Map Complete
10/23/2019 2:17:23 AM	Start Generate Partial Map with Realistic and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:24 AM	Generate Partial Map Complete
10/23/2019 2:17:28 AM	Start Generate Partial Map with D18Rings and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:28 AM	Generate Partial Map Complete
10/23/2019 2:17:36 AM	Start Generate Partial Map with D18Swirl and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:36 AM	Generate Partial Map Complete
10/23/2019 2:17:45 AM	Start Generate Partial Map with D18Bubbles and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:45 AM	Generate Partial Map Complete
10/23/2019 2:17:51 AM	Start Generate Partial Map with ClustersMicrocosm and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:17:51 AM	Generate Partial Map Complete
10/23/2019 2:18:01 AM	Start Generate Partial Map with Snake and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:01 AM	Generate Partial Map Complete
10/23/2019 2:18:09 AM	Start Generate Partial Map with Concentric and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:09 AM	Generate Partial Map Complete
10/23/2019 2:18:30 AM	Start Generate Partial Map with X and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:30 AM	Generate Partial Map Complete
10/23/2019 2:18:37 AM	Start Generate Partial Map with X and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:37 AM	Generate Partial Map Complete
10/23/2019 2:18:39 AM	Start Generate Partial Map with X and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:39 AM	Generate Partial Map Complete
10/23/2019 2:18:44 AM	Start Generate Partial Map with Grid and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:44 AM	Generate Partial Map Complete
10/23/2019 2:18:59 AM	Start Generate Partial Map with Maze and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:18:59 AM	Generate Partial Map Complete
10/23/2019 2:19:06 AM	Start Generate Partial Map with Maze and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:06 AM	Generate Partial Map Complete
10/23/2019 2:19:09 AM	Start Generate Partial Map with Maze and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:09 AM	Generate Partial Map Complete
10/23/2019 2:19:12 AM	Start Generate Partial Map with Maze and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:12 AM	Generate Partial Map Complete
10/23/2019 2:19:16 AM	Start Generate Partial Map with Wheel and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:16 AM	Generate Partial Map Complete
10/23/2019 2:19:24 AM	Start Generate Partial Map with Honeycomb and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:24 AM	Generate Partial Map Complete
10/23/2019 2:19:33 AM	Start Generate Partial Map with Encapsulated and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:33 AM	Generate Partial Map Complete
10/23/2019 2:19:33 AM	Start Generate Partial Map with Encapsulated and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:33 AM	Generate Partial Map Complete
10/23/2019 2:19:41 AM	Start Generate Partial Map with Wheel and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:41 AM	Generate Partial Map Complete
10/23/2019 2:19:57 AM	Start Generate Partial Map with Wheel and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:19:57 AM	Generate Partial Map Complete
10/23/2019 2:20:16 AM	Start Generate Partial Map with Wheel and seed 574457079 and planet count 80 and 16 factions
10/23/2019 2:20:16 AM	Generate Partial Map Complete
10/23/2019 2:35:53 AM	Start Generate FULL Map with Wheel and seed 574457079 and planet count 80 and 17 factions
10/23/2019 2:35:54 AM	Generate FULL Map Complete
10/23/2019 3:12:20 AM	No resolution change was required.
10/23/2019 3:12:20 AM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
10/23/2019 3:12:20 AM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
10/23/2019 3:41:50 AM	PLAYER DISCONNECTED 0.0.0.0=>0
5/18/2020 1:57:17 AM	Current directory used: D:/Games/Steam/steamapps/common/AI War 2/
Process Count = 0 so PlayerDataDirectory used: D:/Games/Steam/steamapps/common/AI War 2/PlayerData/
5/18/2020 1:57:17 AM	Boot up FleetOS (0.3050s)
5/18/2020 1:57:18 AM	graphicsDeviceType in use: Direct3D11
graphicsDeviceVersion in use: Direct3D 11.0 [level 11.0]
graphicsMultiThreaded: True
graphicsShaderLevel: 50
operatingSystem: Windows 7  (6.1.0) 64bit
graphicsDeviceName: NVIDIA GeForce GTX 770
graphicsDeviceID: 4484
graphicsDeviceVendor: NVIDIA
graphicsDeviceVendorID: 4318
graphicsDeviceVersion: Direct3D 11.0 [level 11.0]
graphicsMemorySize: 1979
maxTextureSize: 16384
npotSupport: Full
processorType: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
processorCount: 4
processorFrequency: 3500
systemMemorySize: 16330
supportedRenderTargetCount: 8
supportsComputeShaders: True
supportsShadows: True
usesReversedZBuffer: True
5/18/2020 1:57:18 AM	Check System Logs For Rogue Intelligence (1.1181s)
5/18/2020 1:57:18 AM	Game Version: 2.032
5/18/2020 1:57:18 AM	Eject Trash Into Hyperspace (0.3230s)
5/18/2020 1:57:18 AM	Expansions:  The Spire Rises (Installed!)  Zenith Onslaught (NOT INSTALLED)  
5/18/2020 1:57:18 AM	Check For Extra Modules (0.1380s)
5/18/2020 1:57:18 AM	Warning: skipped mod "_Vanilla" in XMLLoadingOrder.txt because we couldn't find any mod with that name
5/18/2020 1:57:18 AM	Bring Cloaking Systems Online (0.0900s)
5/18/2020 1:57:19 AM	Remembering Alamo (0.1410s)
5/18/2020 1:57:19 AM	Generating Framerates (0.0250s)
5/18/2020 1:57:19 AM	Recalculate Speed Of Light (0.1460s)
5/18/2020 1:57:19 AM	Optimize Comfort On Command Decks (0.0440s)
5/18/2020 1:57:19 AM	Check Nearby Stellar Masses (0.0110s)
5/18/2020 1:57:19 AM	No resolution change was required.
5/18/2020 1:57:19 AM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
5/18/2020 1:57:19 AM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
5/18/2020 1:57:19 AM	Refresh Optical Lensing (0.0110s)
5/18/2020 1:57:19 AM	Revise Fundamental Physical Laws (0.5140s)
5/18/2020 1:57:19 AM	Boot Audio Comms (0.0700s)
5/18/2020 1:57:19 AM	Establish Individual Audio Links (0.0340s)
5/18/2020 1:57:20 AM	Prepare Explosions and Crackles (0.4600s)
5/18/2020 1:57:21 AM	Calculate Odds Of Success (0.7860s)
5/18/2020 1:57:24 AM	Briefly Panic (3.3032s)
5/18/2020 1:57:24 AM	Install Confidence Routines (0.2340s)
5/18/2020 1:57:24 AM	Bring Commander Interface Online (0.2390s)
5/18/2020 1:57:25 AM	Motivate All Crews (0.0980s)
5/18/2020 1:57:25 AM	Externalizing Patterns (0.0700s)
5/18/2020 1:57:25 AM	Disengaging Constants (0.3930s)
5/18/2020 1:57:25 AM	Late Axionic Computations (0.3500s)
5/18/2020 1:57:25 AM	Connecting to Fleet Command (0.0280s)
5/18/2020 1:57:25 AM	Thinking Of Advice (0.0490s)
5/18/2020 1:57:26 AM	Degaussing Advice (0.3230s)
5/18/2020 1:57:26 AM	Naming All Known Planets (0.0200s)
5/18/2020 1:57:26 AM	Remembering Speeds (0.0230s)
5/18/2020 1:57:26 AM	Prioritizing Targets (0.0240s)
5/18/2020 1:57:26 AM	Rebooting Sensor Arrays (0.0170s)
5/18/2020 1:57:26 AM	Unloading Prismatic Grid (0.0180s)
5/18/2020 1:57:26 AM	Thinking Of Objectives (0.0080s)
5/18/2020 1:57:26 AM	Re-Aligning Objectives (0.0240s)
5/18/2020 1:57:26 AM	Inhibiting Visual Scans (0.0470s)
5/18/2020 1:57:26 AM	Synthesizing Vocals (0.0080s)
5/18/2020 1:57:26 AM	Ventilating Scenarios (0.0510s)
5/18/2020 1:57:26 AM	Decontaminating Targeting Systems (0.0200s)
5/18/2020 1:57:26 AM	Ejecting Tactical Core (0.0080s)
5/18/2020 1:57:26 AM	Calibrating Formations (0.0070s)
5/18/2020 1:57:26 AM	Intercepting Galactic Maps (0.0120s)
5/18/2020 1:57:26 AM	Sterilizing Test Chamber (0.0380s)
5/18/2020 1:57:26 AM	Faction Diagnostics (0.0870s)
5/18/2020 1:57:26 AM	Buffering Hackers (0.0610s)
5/18/2020 1:57:26 AM	Inverting Death (0.0800s)
5/18/2020 1:57:26 AM	Linear Field Variance (0.0910s)
5/18/2020 1:57:26 AM	Charging Marks (0.0220s)
5/18/2020 1:57:26 AM	Guarding The Posts (0.0410s)
5/18/2020 1:57:26 AM	Range Manifolds (0.0170s)
5/18/2020 1:57:27 AM	Purging ROFs (0.0170s)
5/18/2020 1:57:27 AM	Manipulating Speeds (0.0110s)
5/18/2020 1:57:27 AM	Detecting Projectiles (0.0080s)
5/18/2020 1:57:27 AM	Grouping Flow Fields (0.0300s)
5/18/2020 1:57:27 AM	Modulating Flow Field Groups (0.0760s)
5/18/2020 1:57:27 AM	Designing Fleets (0.2380s)
5/18/2020 1:57:27 AM	Thinking Of Technologies (0.0220s)
5/18/2020 1:57:27 AM	Categorizing Starboard Sensors (0.0450s)
5/18/2020 1:57:27 AM	Injecting Galactic Variables (0.0560s)
5/18/2020 1:57:27 AM	Discharging Colored Ions (0.0340s)
5/18/2020 1:57:27 AM	Replicating Ion Colors (0.0390s)
5/18/2020 1:57:29 AM	Ignoring Starfields (1.7621s)
5/18/2020 1:57:35 AM	Mapping Distant Planets (6.1013s)
5/18/2020 1:57:35 AM	Investigating Map Signatures (0.0560s)
5/18/2020 1:57:35 AM	Collating Solar Systems (0.0150s)
5/18/2020 1:57:35 AM	Categorizing All Planets (0.0040s)
5/18/2020 1:57:35 AM	Organizing Commands (0.0280s)
5/18/2020 1:57:35 AM	Calculating Firing Cones (0.0040s)
5/18/2020 1:57:40 AM	Declaring Ship Parts At Customs (5.3353s)
5/18/2020 1:58:05 AM	Ejecting Data Cores (24.4964s)
5/18/2020 1:58:05 AM	Issuing Orders (0.0070s)
5/18/2020 1:58:05 AM	Augmenting Infusers (0.0350s)
5/18/2020 1:58:05 AM	Infusing (0.1500s)
5/18/2020 1:58:05 AM	Post-Proton Surge (0.0050s)
5/18/2020 1:58:05 AM	Calibrate Weapons Arrays (0.1030s)
5/18/2020 1:58:05 AM	Stimulate Modulation (0.0340s)
5/18/2020 1:58:06 AM	ArcenAssetBundleCache.InstantiatedObjects: 972
5/18/2020 1:58:08 AM	Load Surrogates (2.3431s)
5/18/2020 1:58:08 AM	Load Historical Documents (0.0090s)
5/18/2020 1:58:08 AM	51.1 seconds total load time.
Boot up FleetOS (0.3s)
Check System Logs For Rogue Intelligence (1.1s)
Eject Trash Into Hyperspace (0.3s)
Revise Fundamental Physical Laws (0.5s)
Prepare Explosions and Crackles (0.5s)
Calculate Odds Of Success (0.8s)
Briefly Panic (3.3s)
Disengaging Constants (0.4s)
Late Axionic Computations (0.4s)
Degaussing Advice (0.3s)
Ignoring Starfields (1.8s)
Mapping Distant Planets (6.1s)
Declaring Ship Parts At Customs (5.3s)
Ejecting Data Cores (24.5s)
Load Surrogates (2.3s)
5/18/2020 1:58:08 AM	Hello Steam user 'Kalieum'
5/18/2020 1:58:29 AM	Added the faction AIReserves.
5/18/2020 1:58:29 AM	Successfully opened host socket
5/18/2020 1:58:29 AM	OnLoad: Detected 9 player ship(s) that are in the loose fleet (bad).  Was able to correct 9 of those.
5/18/2020 1:58:29 AM	OnLoad: Detected an excess of AI turrets in a savegame older than 1.026, so removed 2044 out of 2524 of them.
5/18/2020 2:02:46 AM	PLAYER DISCONNECTED 0.0.0.0=>0
5/18/2020 2:02:46 AM	Added the faction AIReserves.
5/18/2020 2:02:46 AM	Successfully opened host socket
5/18/2020 2:02:46 AM	OnLoad: Detected 9 player ship(s) that are in the loose fleet (bad).  Was able to correct 9 of those.
5/18/2020 2:02:46 AM	OnLoad: Detected an excess of AI turrets in a savegame older than 1.026, so removed 2044 out of 2524 of them.
5/18/2020 2:03:42 AM	PLAYER DISCONNECTED 0.0.0.0=>0
5/18/2020 2:03:42 AM	Added the faction AIReserves.
5/18/2020 2:03:42 AM	Successfully opened host socket
5/18/2020 2:03:42 AM	OnLoad: Detected 9 player ship(s) that are in the loose fleet (bad).  Was able to correct 9 of those.
5/18/2020 2:03:42 AM	OnLoad: Detected an excess of AI turrets in a savegame older than 1.026, so removed 2044 out of 2524 of them.
5/18/2020 2:53:14 AM	Donating team Fireteam 13 has 11 units with strength 1432. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 7, Fugue: 4 to hunter, path A
5/18/2020 2:53:20 AM	Donating team Fireteam 17 has 2 units with strength 1092. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 1, Fugue: 1 to hunter, path A
5/18/2020 2:53:52 AM	Donating team Fireteam 17 has 1 units with strength 30. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 1 to hunter, path A
5/18/2020 3:00:53 AM	No resolution change was required.
5/18/2020 3:00:53 AM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
5/18/2020 3:00:53 AM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
5/18/2020 3:06:28 AM	Waiting On Server, at frame 0 client mode: False SocketMode: Host
5/18/2020 3:06:30 AM	PLAYER DISCONNECTED 0.0.0.0=>0
5/28/2020 11:17:12 PM	Current directory used: D:/Games/Steam/steamapps/common/AI War 2/
Process Count = 0 so PlayerDataDirectory used: D:/Games/Steam/steamapps/common/AI War 2/PlayerData/
5/28/2020 11:17:12 PM	Boot up FleetOS (0.3560s)
5/28/2020 11:17:14 PM	graphicsDeviceType in use: Direct3D11
graphicsDeviceVersion in use: Direct3D 11.0 [level 11.0]
graphicsMultiThreaded: True
graphicsShaderLevel: 50
operatingSystem: Windows 7  (6.1.0) 64bit
graphicsDeviceName: NVIDIA GeForce GTX 770
graphicsDeviceID: 4484
graphicsDeviceVendor: NVIDIA
graphicsDeviceVendorID: 4318
graphicsDeviceVersion: Direct3D 11.0 [level 11.0]
graphicsMemorySize: 1979
maxTextureSize: 16384
npotSupport: Full
processorType: Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
processorCount: 4
processorFrequency: 3500
systemMemorySize: 16330
supportedRenderTargetCount: 8
supportsComputeShaders: True
supportsShadows: True
usesReversedZBuffer: True
5/28/2020 11:17:14 PM	Check System Logs For Rogue Intelligence (1.8751s)
5/28/2020 11:17:14 PM	Game Version: 2.048
5/28/2020 11:17:14 PM	Eject Trash Into Hyperspace (0.1820s)
5/28/2020 11:17:14 PM	Expansions:  The Spire Rises (Installed!)  Zenith Onslaught (NOT INSTALLED)  
5/28/2020 11:17:14 PM	Check For Extra Modules (0.0440s)
5/28/2020 11:17:14 PM	Warning: skipped mod "_Vanilla" in XMLLoadingOrder.txt because we couldn't find any mod with that name
5/28/2020 11:17:14 PM	Bring Cloaking Systems Online (0.0380s)
5/28/2020 11:17:14 PM	Remembering Alamo (0.1090s)
5/28/2020 11:17:14 PM	Generating Framerates (0.0260s)
5/28/2020 11:17:14 PM	Recalculate Speed Of Light (0.1220s)
5/28/2020 11:17:14 PM	Optimize Comfort On Command Decks (0.0430s)
5/28/2020 11:17:14 PM	Check Nearby Stellar Masses (0.0500s)
5/28/2020 11:17:14 PM	No resolution change was required.
5/28/2020 11:17:14 PM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
5/28/2020 11:17:14 PM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
5/28/2020 11:17:14 PM	Refresh Optical Lensing (0.0050s)
5/28/2020 11:17:15 PM	Revise Fundamental Physical Laws (0.3170s)
5/28/2020 11:17:15 PM	Boot Audio Comms (0.0350s)
5/28/2020 11:17:15 PM	Establish Individual Audio Links (0.0160s)
5/28/2020 11:17:15 PM	Prepare Explosions and Crackles (0.4320s)
5/28/2020 11:17:16 PM	Calculate Odds Of Success (0.7180s)
5/28/2020 11:17:19 PM	Briefly Panic (2.6252s)
5/28/2020 11:17:19 PM	Install Confidence Routines (0.2230s)
5/28/2020 11:17:19 PM	Bring Commander Interface Online (0.2230s)
5/28/2020 11:17:19 PM	Motivate All Crews (0.1150s)
5/28/2020 11:17:19 PM	Externalizing Patterns (0.0720s)
5/28/2020 11:17:19 PM	Hooking Externals (0.0210s)
5/28/2020 11:17:19 PM	Handlizing Hooks (0.0110s)
5/28/2020 11:17:20 PM	Disengaging Constants (0.3840s)
5/28/2020 11:17:20 PM	Late Axionic Computations (0.3600s)
5/28/2020 11:17:20 PM	Connecting to Fleet Command (0.0290s)
5/28/2020 11:17:20 PM	Thinking Of Advice (0.0490s)
5/28/2020 11:17:20 PM	Degaussing Advice (0.2790s)
5/28/2020 11:17:20 PM	Reading Alien Diaries (0.0860s)
5/28/2020 11:17:20 PM	Naming All Known Planets (0.0220s)
5/28/2020 11:17:20 PM	Remembering Speeds (0.0080s)
5/28/2020 11:17:20 PM	Prioritizing Targets (0.0280s)
5/28/2020 11:17:21 PM	Rebooting Sensor Arrays (0.0170s)
5/28/2020 11:17:21 PM	Unloading Prismatic Grid (0.0190s)
5/28/2020 11:17:21 PM	Thinking Of Objectives (0.0070s)
5/28/2020 11:17:21 PM	Re-Aligning Objectives (0.0240s)
5/28/2020 11:17:21 PM	Inhibiting Visual Scans (0.0360s)
5/28/2020 11:17:21 PM	Synthesizing Vocals (0.0080s)
5/28/2020 11:17:21 PM	Ventilating Scenarios (0.0520s)
5/28/2020 11:17:21 PM	Decontaminating Targeting Systems (0.0300s)
5/28/2020 11:17:21 PM	Ejecting Tactical Core (0.0090s)
5/28/2020 11:17:21 PM	Calibrating Formations (0.0070s)
5/28/2020 11:17:21 PM	Intercepting Galactic Maps (0.0110s)
5/28/2020 11:17:21 PM	Sterilizing Test Chamber (0.0380s)
5/28/2020 11:17:21 PM	Faction Diagnostics (0.0870s)
5/28/2020 11:17:21 PM	Buffering Hackers (0.0720s)
5/28/2020 11:17:21 PM	Inverting Death (0.0800s)
5/28/2020 11:17:21 PM	Linear Field Variance (0.0910s)
5/28/2020 11:17:21 PM	Charging Marks (0.0220s)
5/28/2020 11:17:21 PM	Guarding The Posts (0.0410s)
5/28/2020 11:17:21 PM	Range Manifolds (0.0170s)
5/28/2020 11:17:21 PM	Purging ROFs (0.0170s)
5/28/2020 11:17:21 PM	Manipulating Speeds (0.0100s)
5/28/2020 11:17:21 PM	Detecting Projectiles (0.0080s)
5/28/2020 11:17:21 PM	Grouping Flow Fields (0.0310s)
5/28/2020 11:17:21 PM	Modulating Flow Field Groups (0.0750s)
5/28/2020 11:17:22 PM	Designing Fleets (0.2190s)
5/28/2020 11:17:22 PM	Thinking Of Technologies (0.0840s)
5/28/2020 11:17:22 PM	Categorizing Starboard Sensors (0.0590s)
5/28/2020 11:17:22 PM	Injecting Galactic Variables (0.0790s)
5/28/2020 11:17:22 PM	Discharging Colored Ions (0.0880s)
5/28/2020 11:17:22 PM	Replicating Ion Colors (0.0400s)
5/28/2020 11:17:24 PM	Weepinig Over Starfields (1.7331s)
5/28/2020 11:17:30 PM	Resizing Distant Planets (6.0753s)
5/28/2020 11:17:30 PM	Investigating Map Signatures (0.1010s)
5/28/2020 11:17:30 PM	Collating Solar Systems (0.0250s)
5/28/2020 11:17:30 PM	Categorizing All Planets (0.0040s)
5/28/2020 11:17:30 PM	Organizing Commands (0.0480s)
5/28/2020 11:17:30 PM	Calculating Firing Cones (0.0040s)
5/28/2020 11:17:35 PM	Jailbreaking Favorite Ship Parts (4.8123s)
5/28/2020 11:17:59 PM	Weaponizing Cryonics (24.6584s)
5/28/2020 11:17:59 PM	Issuing Orders (0.0080s)
5/28/2020 11:17:59 PM	Augmenting Infusers (0.0290s)
5/28/2020 11:18:00 PM	Infusing (0.1390s)
5/28/2020 11:18:00 PM	Post-Proton Surge (0.0040s)
5/28/2020 11:18:00 PM	Calibrate Weapons Arrays (0.3210s)
5/28/2020 11:18:00 PM	Stimulate Modulation (0.0490s)
5/28/2020 11:18:01 PM	ArcenAssetBundleCache.InstantiatedObjects: 972
5/28/2020 11:18:02 PM	Load Surrogates (2.4781s)
5/28/2020 11:18:02 PM	Load Historical Documents (0.0060s)
5/28/2020 11:18:02 PM	50.8 seconds total load time.
Boot up FleetOS (0.4s)
Check System Logs For Rogue Intelligence (1.9s)
Revise Fundamental Physical Laws (0.3s)
Prepare Explosions and Crackles (0.4s)
Calculate Odds Of Success (0.7s)
Briefly Panic (2.6s)
Disengaging Constants (0.4s)
Late Axionic Computations (0.4s)
Degaussing Advice (0.3s)
Weepinig Over Starfields (1.7s)
Resizing Distant Planets (6.1s)
Jailbreaking Favorite Ship Parts (4.8s)
Weaponizing Cryonics (24.7s)
Calibrate Weapons Arrays (0.3s)
Load Surrogates (2.5s)
5/28/2020 11:18:03 PM	Hello Steam user 'Kalieum'
5/28/2020 11:19:03 PM	Successfully opened host socket
5/28/2020 11:30:54 PM	Donating team Fireteam 23 has 12 units with strength 314. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 12 to hunter, path A
5/28/2020 11:52:47 PM	Donating team Fireteam 37 has 24 units with strength 975. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 24 to hunter, path A
5/29/2020 12:12:39 AM	Donating team Fireteam 43 has 26 units with strength 2466. Status Staging	 No target planet No lurk planet. Ships: Rogue: 26 to hunter, path B
5/29/2020 12:12:55 AM	Donating team Fireteam 25 has 30 units with strength 2619. Status Staging	 No target planet No lurk planet. Ships: Fire Dragon: 23, Giant Leech: 3, Salamander: 4 to hunter, path B
5/29/2020 12:12:55 AM	Donating team Fireteam 40 has 34 units with strength 3452. Status Staging	 No target planet No lurk planet. Ships: Fire Dragon: 25, Salamander: 7, Maxwell: 1, Giant Leech: 1 to hunter, path B
5/29/2020 12:35:21 AM	Donating team Fireteam 49 has 2 units with strength 88. Status Assembling	 No target planet No lurk planet. Ships: Valukar: 2 to hunter, path A
5/29/2020 12:35:40 AM	Donating team Fireteam 46 has 37 units with strength 3083. Status Staging	 No target planet No lurk planet. Ships: Undertaker: 23, Dire Wolf: 5, Ooze: 9 to hunter, path B
5/29/2020 12:36:19 AM	Donating team Fireteam 52 has 4 units with strength 874. Status Assembling	 No target planet No lurk planet. Ships: Rogue: 4 to hunter, path A
5/29/2020 1:01:55 AM	Donating team Fireteam 65 has 10 units with strength 284. Status Assembling	 No target planet No lurk planet. Ships: Dire Wolf: 10 to hunter, path A
5/29/2020 1:01:55 AM	Donating team Fireteam 64 has 13 units with strength 2242. Status Staging	 No target planet No lurk planet. Ships: Ooze: 1, Dire Wolf: 12 to hunter, path B
5/29/2020 1:08:08 AM	No resolution change was required.
5/29/2020 1:08:08 AM	Applied graphics settings: 
AntialiasingMode:x2
UseSoftParticles:False
BillboardsFaceCameraPosition:False
AnisotropicMode:ForceEnable
TextureQuality:Full
5/29/2020 1:08:08 AM	Applied Framerate Type: 144 FPS (vsync: 0 targetFPS:144)
5/29/2020 1:38:37 AM	Donating team Fireteam 78 has 17 units with strength 400. Status Assembling	 No target planet No lurk planet. Ships: Hedgehog: 17 to hunter, path A
5/29/2020 1:42:29 AM	Donating team Fireteam 83 has 8 units with strength 290. Status Assembling	 No target planet No lurk planet. Ships: Hedgehog: 8 to hunter, path A
5/29/2020 1:49:23 AM	Donating team Fireteam 95 has 46 units with strength 3103. Status Staging	 No target planet No lurk planet. Ships: Hedgehog: 43, Ooze: 3 to hunter, path B
5/29/2020 1:49:23 AM	Donating team Fireteam 96 has 55 units with strength 2653. Status Staging	 No target planet No lurk planet. Ships: Hedgehog: 52, Ooze: 3 to hunter, path B
5/29/2020 1:49:23 AM	Donating team Fireteam 93 has 55 units with strength 3659. Status Staging	 No target planet No lurk planet. Ships: Hedgehog: 40, Ooze: 15 to hunter, path B
5/29/2020 2:03:47 AM	Donating team Fireteam 107 has 1 units with strength 39. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 1 to hunter, path A
5/29/2020 2:11:10 AM	Donating team Fireteam 110 has 17 units with strength 2661. Status Assembling	 No target planet No lurk planet. Ships: Ooze: 17 to hunter, path A
5/29/2020 2:11:12 AM	Donating team Fireteam 111 has 3 units with strength 63. Status Assembling	 No target planet No lurk planet. Ships: Ooze: 3 to hunter, path A
5/29/2020 2:12:33 AM	Donating team Fireteam 110 has 24 units with strength 487. Status Assembling	 No target planet No lurk planet. Ships: Green Roper: 24 to hunter, path A
5/29/2020 2:13:55 AM	Donating team Fireteam 115 has 21 units with strength 1760. Status Assembling	 No target planet No lurk planet. Ships: Hedgehog: 15, Ooze: 6 to hunter, path A
5/29/2020 2:13:55 AM	Donating team Fireteam 113 has 39 units with strength 2575. Status Staging	 No target planet No lurk planet. Ships: Hedgehog: 34, Ooze: 5 to hunter, path B
5/29/2020 2:14:01 AM	Donating team Fireteam 115 has 23 units with strength 755. Status Assembling	 No target planet No lurk planet. Ships: Hedgehog: 20, Ooze: 3 to hunter, path A
5/29/2020 2:18:36 AM	Donating team Fireteam 123 has 9 units with strength 311. Status Assembling	 No target planet No lurk planet. Ships: Hedgehog: 9 to hunter, path A
5/29/2020 2:18:36 AM	Donating team Fireteam 120 has 38 units with strength 4216. Status Staging	 No target planet No lurk planet. Ships: Hedgehog: 38 to hunter, path B
5/29/2020 2:18:36 AM	Donating team Fireteam 122 has 36 units with strength 2502. Status Staging	 No target planet No lurk planet. Ships: Hedgehog: 36 to hunter, path B
5/29/2020 2:27:20 AM	Donating team Fireteam 125 has 6 units with strength 126. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 6 to hunter, path A
5/29/2020 2:27:58 AM	Donating team Fireteam 132 has 3 units with strength 190. Status Assembling	 No target planet No lurk planet. Ships: Salamander: 3 to hunter, path A
5/29/2020 2:46:45 AM	Donating team Fireteam 142 has 5 units with strength 1376. Status Assembling	 No target planet No lurk planet. Ships: Fugue: 5 to hunter, path A
5/29/2020 2:50:01 AM	Donating team Fireteam 147 has 17 units with strength 363. Status Assembling	 No target planet No lurk planet. Ships: Fugue: 17 to hunter, path A
5/29/2020 2:50:01 AM	Donating team Fireteam 148 has 2 units with strength 52. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 2 to hunter, path A
5/29/2020 3:02:11 AM
Error in targeting logic System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.Core.LazyLoadSquadWrapper.GetSquad () [0x0005a] in <96495cf12d244b52bdff6e34a8b5c318>:0 
  at Arcen.AIW2.External.TargetListPlanning.FindTopEntriesForSystem (Arcen.AIW2.Core.GameEntity_Squad AttackerEntity, Arcen.AIW2.Core.EntitySystem AttackerSystem, System.Int32 SystemIndex) [0x0012a] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at Arcen.AIW2.External.TargetListPlanning.DoEntityFramePlanningLogic_TargetPrioritizing_SpecificSystem (Arcen.AIW2.Core.GameEntity_Squad AttackerEntity, Arcen.AIW2.Core.EntitySystem AttackerSystem, System.Int32 SystemIndex) [0x00009] in <cd03e35adbf545aa82aec4d4fc519102>:0 

  at System.Environment.get_StackTrace () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <f32e02f53c514759af8a0a555f98192e>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <f32e02f53c514759af8a0a555f98192e>:0 
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <f32e02f53c514759af8a0a555f98192e>:0 
  at Arcen.AIW2.External.TargetListPlanning.DoEntityFramePlanningLogic_TargetPrioritizing_SpecificSystem (Arcen.AIW2.Core.GameEntity_Squad AttackerEntity, Arcen.AIW2.Core.EntitySystem AttackerSystem, System.Int32 SystemIndex) [0x00000] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at Arcen.AIW2.External.TargetListPlanning.DoEntityFramePlanningLogic_TargetPrioritizing (Arcen.AIW2.Core.GameEntity_Squad AttackerEntity) [0x00000] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at Arcen.AIW2.Core.EntityCollection.DoForEntities (Arcen.AIW2.Core.GameEntity_Squad+ProcessorDelegate Processor) [0x00000] in <96495cf12d244b52bdff6e34a8b5c318>:0 
  at Arcen.AIW2.External.TargetListPlanning.<Execute>b__9_0 (Arcen.AIW2.Core.Planet planet) [0x00000] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at Arcen.AIW2.Core.Galaxy.DoForPlanets (System.Boolean IncludeDestroyed, Arcen.AIW2.Core.Planet+ProcessorDelegate Processor) [0x00000] in <96495cf12d244b52bdff6e34a8b5c318>:0 
  at Arcen.AIW2.Core.World_AIW2.DoForPlanets (System.Boolean IncludeDestroyed, Arcen.AIW2.Core.Planet+ProcessorDelegate Processor) [0x00000] in <96495cf12d244b52bdff6e34a8b5c318>:0 
  at Arcen.AIW2.External.TargetListPlanning.Execute () [0x00000] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at Arcen.AIW2.External.ArcenSimPlanningContext.InnerRun () [0x00000] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at Arcen.AIW2.External.ArcenThread.InternalActualThreadFunction () [0x00000] in <cd03e35adbf545aa82aec4d4fc519102>:0 
  at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
  at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
  at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext executionContext, System.Threading.ContextCallback callback, System.Object state) [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 
  at System.Threading.ThreadHelper.ThreadStart () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0 

5/29/2020 3:02:13 AM	Donating team Fireteam 150 has 1 units with strength 1206. Status Assembling	 No target planet No lurk planet. Ships: Energy Stone: 1 to hunter, path A
5/29/2020 3:02:15 AM	Donating team Fireteam 151 has 2 units with strength 66. Status Assembling	 No target planet No lurk planet. Ships: Fugue: 2 to hunter, path A
ArcenDebugLog.txt (37,969 bytes)
20200529030217_1.jpg (322,303 bytes)
Just after bug.save (676,894 bytes)
Autosave.10200.savemet (94 bytes)
Autosave.10200.save (668,959 bytes)

BadgerBadger

May 28, 2020 11:51 pm

manager   ~0057142

Error in targeting logic System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.Core.LazyLoadSquadWrapper.GetSquad () [0x0005a] in <96495cf12d244b52bdff6e34a8b5c318>:0
  at Arcen.AIW2.External.TargetListPlanning.FindTopEntriesForSystem (Arcen.AIW2.Core.GameEntity_Squad AttackerEntity, Arcen.AIW2.Core.EntitySystem AttackerSystem, System.Int32 SystemIndex) [0x0012a] in <cd03e35adbf545aa82aec4d4fc519102>:0
  at Arcen.AIW2.External.TargetListPlanning.DoEntityFramePlanningLogic_TargetPrioritizing_SpecificSystem (Arcen.AIW2.Core.GameEntity_Squad AttackerEntity, Arcen.AIW2.Core.EntitySystem AttackerSystem, System.Int32 SystemIndex) [0x00009] in <cd03e35adbf545aa82aec4d4fc519102>:0

x4000Bughunter

Jun 30, 2020 6:07 pm

administrator   ~0057474

Thanks!

* Fixed a very rare race condition that could happen in LazyLoadSquadWrapper.GetSquad(). Essentially one thread could be marking it as dead and thus the reference goes away, while another thread was still trying to read its info. By using local variables this should now be properly threadsafe, and it actually let us remove a try/catch block, which improves speed of access slightly (actually the part inside that try/catch was getting hit more frequently prior to now, but we were using that to suppress it in a nonideal way).

Issue History

Date Modified Username Field Change
May 28, 2020 10:39 pm Kalieum New Issue
May 28, 2020 10:39 pm Kalieum File Added: 20200529030217_1.jpg
May 28, 2020 10:39 pm Kalieum File Added: Autosave.10200.save
May 28, 2020 10:39 pm Kalieum File Added: Autosave.10200.savemet
May 28, 2020 10:39 pm Kalieum File Added: Just after bug.save
May 28, 2020 10:39 pm Kalieum File Added: Just after bug.savemet
May 28, 2020 10:39 pm Kalieum File Added: ArcenDebugLog.txt
May 28, 2020 11:51 pm BadgerBadger Note Added: 0057142
Jun 27, 2020 11:04 am x4000Bughunter Assigned To => x4000Bughunter
Jun 27, 2020 11:04 am x4000Bughunter Status new => assigned
Jun 30, 2020 6:07 pm x4000Bughunter Status assigned => resolved
Jun 30, 2020 6:07 pm x4000Bughunter Resolution open => fixed
Jun 30, 2020 6:07 pm x4000Bughunter Fixed in Version => Beta 2.088 Banishment of Undead AIs
Jun 30, 2020 6:07 pm x4000Bughunter Note Added: 0057474