View Issue Details

IDProjectCategoryLast Update
0023198AI War 2[All Projects] Bug - OtherMay 21, 2020 9:09 am
ReporterDEMOCRACY_DEMOCRACYAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version2.045 Scientific Emergence 
Fixed in Version2.046 Hotfix 
Summary0023198: Exception in PerFrame_CalculateEffectiveFleetData
Descriptionsome error occured, not sure what it is. let the game run for a couple of seconds and it should pop up.
TagsNo tags attached.

Relationships

related to 0023200 resolvedx4000Bughunter Null Reference Exception upon loading savegame. 

Activities

DEMOCRACY_DEMOCRACY

May 20, 2020 7:40 pm

reporter  

Autosave.1800.save (814,204 bytes)

BadgerBadger

May 21, 2020 12:45 am

manager   ~0057074

Last edited: May 21, 2020 12:48 am

View 2 revisions

5/20/2020 10:44:49 PM Error in PerFrame_CalculateEffectiveFleetData, debugStage 784600
System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.Core.Fleet+Membership.PerFrame_CalculateEffectiveFleetData_P1 (System.Int32 MinMarkLevelFromFleet, Arcen.AIW2.Core.GameEntity_Squad CenterpieceOfFleet, Arcen.AIW2.Core.Faction LocalPlayerFactionForUICalculationsOrNull, Arcen.AIW2.Core.ArcenSimContext Context, System.Int32& debugStage) [0x00b48] in <a4451cb0949e41db952b2ab1d7a0d5c3>:0

                debugStage = 784600;
                this.EffectiveFullMembershipStrength = this.EffectiveSquadCap * this.ForMark.StrengthPerSquad;
                this.LocalPlayerUIFullMembershipStrength = this.LocalPlayerUISquadCap * this.LocalPlayerUIForMark.StrengthPerSquad;

                int squadCapOfRelevance = this.EffectiveSquadCap;
                if ( squadCapOfRelevance < 0 )
                    squadCapOfRelevance = 0;

Can confirm, very easy to reproduce with this save game

Mitsuha

May 21, 2020 1:38 am

reporter   ~0057075

I second this issue. It appeared immediately in an old save game, so I thought it was due to upgrading to a new release. Then it popped up again randomly while I was hacking an ARS. Here's another save game.

Mitsuha

May 21, 2020 1:38 am

reporter  

03error.savemet (76 bytes)
03error.save (734,648 bytes)

x4000Bughunter

May 21, 2020 9:09 am

administrator   ~0057081

Thanks! Sorry about that.

* Fixed a bug where any savegame that you loaded that had drones in a fleet with a dead centerpiece would cause an exception in PerFrame_CalculateEffectiveFleetData, debugStage 784600.

Issue History

Date Modified Username Field Change
May 20, 2020 7:40 pm DEMOCRACY_DEMOCRACY New Issue
May 20, 2020 7:40 pm DEMOCRACY_DEMOCRACY File Added: Autosave.1800.save
May 21, 2020 12:45 am BadgerBadger Note Added: 0057074
May 21, 2020 12:48 am BadgerBadger Note Edited: 0057074 View Revisions
May 21, 2020 12:48 am BadgerBadger Summary unknown error => Exception in PerFrame_CalculateEffectiveFleetData
May 21, 2020 12:48 am BadgerBadger Assigned To => x4000Bughunter
May 21, 2020 12:48 am BadgerBadger Status new => assigned
May 21, 2020 1:38 am Mitsuha Note Added: 0057075
May 21, 2020 1:38 am Mitsuha File Added: 03error.save
May 21, 2020 1:38 am Mitsuha File Added: 03error.savemet
May 21, 2020 6:00 am Lord Of Nothing Relationship added related to 0023000
May 21, 2020 6:00 am Lord Of Nothing Relationship deleted related to 0023000
May 21, 2020 6:01 am Lord Of Nothing Relationship added related to 0023200
May 21, 2020 9:09 am x4000Bughunter Status assigned => resolved
May 21, 2020 9:09 am x4000Bughunter Resolution open => fixed
May 21, 2020 9:09 am x4000Bughunter Fixed in Version => 2.046 Hotfix
May 21, 2020 9:09 am x4000Bughunter Note Added: 0057081