View Issue Details

IDProjectCategoryLast Update
0023197AI War 2[All Projects] Graphical BugMay 20, 2020 5:31 pm
ReporterMitsuhaAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBeta 2.044 Scientific Equality 
Fixed in Version2.045 Scientific Emergence 
Summary0023197: Make un-upgradable ships mark-less // Drones say they can be upgraded but they can't
DescriptionIf a ship cannot be upgraded, it would be nice to make it mark-less, rather than leave it as mark 1. This would demonstrate to the player that it is not possible to obtain a stronger variant.

I'm looking in particular at support fleets with drones. Upgrading a combat factory does not improve its drone. Assuming this is intended, it would be nice if the drone did not have a mark, since there is no way to upgrade it.

Looking at the description of a decoy drone (attached), it says "upgraded when the parent fleet upgrades". I'm assuming this is not intended. If it is intended, perhaps there is a way to upgrade only the drone when the combat factory is upgraded (and not combat engineers, sentry frigates, and whatever other ships you might switch to the support fleet). I would actually prefer the latter; I'd like to see a centerpiece's drones upgrade with it.

I hope that the hive golem's bee drones upgrade with the hive golem, as they are the whole point of the golem. I haven't found a hive golem in the new beta yet, so I don't know how they work.
TagsNo tags attached.

Relationships

related to 0023051 assignedx4000Bughunter Swarmer Guard Posts do not have drones of appropriate level 

Activities

Mitsuha

May 20, 2020 1:19 am

reporter  

DronesDontUpgrade.PNG (135,179 bytes)
DronesDontUpgrade.PNG (135,179 bytes)

x4000Bughunter

May 20, 2020 12:04 pm

administrator   ~0057057

The drones should be upgrading when their centerpiece does, yeah. Do you have a savegame to go with the screenshot, where I can go in an figure out what's up? The wording probably does need to be improved, too. What you're wanting is the intended behavior, but it's not working at present.

Related to 0023051.

BadgerBadger

May 20, 2020 3:14 pm

manager   ~0057067

Chris, Poppy on steam pointed out that combat factories drones aren't upgrading properly, which is likely the same problem.

This might make for a really easy recreate case.

Mitsuha

May 20, 2020 3:20 pm

reporter   ~0057068

To recreate, start any new game, upgrade your support fleet, notice that the drones don't upgrade.

BadgerBadger

May 20, 2020 3:52 pm

manager   ~0057069

Looking at
        public void DeployDroneContents_ONLYCallFromSimBGThread( ArcenSimContext Context )

We create units whose mark is dependent on FleetMembership.EffectiveMark. Presumably when the science upgrade is done we aren't iterating over the Memberships and increasing them as appropriate for drones.

x4000Bughunter

May 20, 2020 5:27 pm

administrator   ~0057071

I think I got it -- I don't think drones were ever set up properly since the change to fleets. We always had relatively few drones, so it wasn't as much an issue. Thanks!

x4000Bughunter

May 20, 2020 5:31 pm

administrator   ~0057073

Thanks!

* Drones of all sorts, be they AI-based or part of a combat factory, or off a hive golem, now all inherit the mark level of their spawner. If their spawner dies (in the case of AI stuff, mainly), then they will stick at the mark level they were.

Issue History

Date Modified Username Field Change
May 20, 2020 1:19 am Mitsuha New Issue
May 20, 2020 1:19 am Mitsuha File Added: DronesDontUpgrade.PNG
May 20, 2020 12:04 pm x4000Bughunter Note Added: 0057057
May 20, 2020 12:04 pm x4000Bughunter Relationship added related to 0023051
May 20, 2020 3:14 pm BadgerBadger Note Added: 0057067
May 20, 2020 3:20 pm Mitsuha Note Added: 0057068
May 20, 2020 3:52 pm BadgerBadger Note Added: 0057069
May 20, 2020 5:27 pm x4000Bughunter Note Added: 0057071
May 20, 2020 5:31 pm x4000Bughunter Assigned To => x4000Bughunter
May 20, 2020 5:31 pm x4000Bughunter Status new => resolved
May 20, 2020 5:31 pm x4000Bughunter Resolution open => fixed
May 20, 2020 5:31 pm x4000Bughunter Fixed in Version => 2.045 Scientific Emergence
May 20, 2020 5:31 pm x4000Bughunter Note Added: 0057073