View Issue Details

IDProjectCategoryLast Update
0023051AI War 2[All Projects] Balance IssueMay 26, 2020 2:34 pm
ReporterNRSirLimboAssigned Tox4000Bughunter 
Severityminor 
Status assignedResolutionreopened 
Product Version2.009 Plenty Of Tuning 
Fixed in Version2.045 Scientific Emergence 
Summary0023051: Swarmer Guard Posts do not have drones of appropriate level
DescriptionEven if guard post is Mk2+ the drones will always stay at Mk1.
TagsNo tags attached.

Relationships

related to 0023197 resolvedx4000Bughunter Make un-upgradable ships mark-less // Drones say they can be upgraded but they can't 

Activities

NRSirLimbo

Mar 22, 2020 11:01 am

reporter  

20200322160032_1.jpg (694,091 bytes)

x4000Bughunter

May 19, 2020 4:50 pm

administrator   ~0057037

Ah, thanks, I missed this. At the time I had just gotten married in the middle of covid and there was quite a bit going on. Is there a repro case where there's a post that has yet to put out the drones but is about to?

NRSirLimbo

May 19, 2020 4:51 pm

reporter   ~0057038

Repo should be very simple. Just put Swarmer AI there, attack a planet and that's all the drone spawning anyone needs from the Swarmer Guard Post variants.

NRSirLimbo

May 19, 2020 4:52 pm

reporter   ~0057039

But the level itself seems to be fixed at spawn. So I think the issue is the units always having a Mk1 drone line of ships in their belly instead of something that's related to spawning units.

x4000Bughunter

May 19, 2020 4:53 pm

administrator   ~0057040

I see. Okay, thanks, that's useful.

x4000Bughunter

May 20, 2020 5:31 pm

administrator   ~0057072

Thanks!

* Drones of all sorts, be they AI-based or part of a combat factory, or off a hive golem, now all inherit the mark level of their spawner. If their spawner dies (in the case of AI stuff, mainly), then they will stick at the mark level they were.

NRSirLimbo

May 21, 2020 6:29 am

reporter   ~0057076

Hate to break it, but it doesn't seem to work...

20200521122909_1.jpg (385,680 bytes)

x4000Bughunter

May 21, 2020 8:51 am

administrator   ~0057078

Savegame, please?

I tested it and it works on player support fleet drones.

NRSirLimbo

May 26, 2020 2:34 pm

reporter   ~0057129

Look at any of the Swarmer Guard Posts (which is everywhere, Swarmer AI) on Mk2+ planets of the map. The drones inside are still Mk1.

s1.savemet (82 bytes)
s1.save (531,876 bytes)

Issue History

Date Modified Username Field Change
Mar 22, 2020 11:01 am NRSirLimbo New Issue
Mar 22, 2020 11:01 am NRSirLimbo File Added: 20200322160032_1.jpg
May 19, 2020 4:50 pm x4000Bughunter Note Added: 0057037
May 19, 2020 4:51 pm NRSirLimbo Note Added: 0057038
May 19, 2020 4:52 pm NRSirLimbo Note Added: 0057039
May 19, 2020 4:53 pm x4000Bughunter Note Added: 0057040
May 20, 2020 12:04 pm x4000Bughunter Relationship added related to 0023197
May 20, 2020 5:31 pm x4000Bughunter Assigned To => x4000Bughunter
May 20, 2020 5:31 pm x4000Bughunter Status new => resolved
May 20, 2020 5:31 pm x4000Bughunter Resolution open => fixed
May 20, 2020 5:31 pm x4000Bughunter Fixed in Version => 2.045 Scientific Emergence
May 20, 2020 5:31 pm x4000Bughunter Note Added: 0057072
May 21, 2020 6:29 am NRSirLimbo File Added: 20200521122909_1.jpg
May 21, 2020 6:29 am NRSirLimbo Note Added: 0057076
May 21, 2020 8:51 am x4000Bughunter Status resolved => feedback
May 21, 2020 8:51 am x4000Bughunter Resolution fixed => reopened
May 21, 2020 8:51 am x4000Bughunter Note Added: 0057078
May 26, 2020 2:34 pm NRSirLimbo File Added: s1.save
May 26, 2020 2:34 pm NRSirLimbo File Added: s1.savemet
May 26, 2020 2:34 pm NRSirLimbo Note Added: 0057129
May 26, 2020 2:34 pm NRSirLimbo Status feedback => assigned