View Issue Details

IDProjectCategoryLast Update
0023185AI War 2[All Projects] Crash/ExceptionMay 18, 2020 5:53 pm
ReporterNRSirLimboAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBeta 2.042 Journals, Cheats, And EXP Retirement 
Fixed in VersionBeta 2.043 The Missing Human King 
Summary0023185: Exception popup: No Human King Found
DescriptionThere's that popup again...
TagsNo tags attached.

Activities

NRSirLimbo

May 17, 2020 6:14 pm

reporter  

20200518001308_1.jpg (351,854 bytes)
ArcenDebugLog.txt (1,490,824 bytes)

BadgerBadger

May 17, 2020 7:14 pm

manager   ~0056997

Just to ask the stupid question.... Was the player dead at this point?

NRSirLimbo

May 17, 2020 7:37 pm

reporter   ~0056999

This was right after launching a new game. There has literally been no 5 seconds of game. It seems as if no player unit (and that includes Home Command) ever spawned.

NRSirLimbo

May 17, 2020 7:41 pm

reporter   ~0057000

Every time I've tested it was Clusters - Small - 40 planets. Not sure if this is a problem here or really just a reliable way to reproduce.

Oh and naturally this is without any mods.

x4000Bughunter

May 18, 2020 12:55 pm

administrator   ~0057006

No actual exceptions, until findKing. Looks like with these two seeds at least:

Start Generate FULL Map with Clusters and seed 487571087 and planet count 40 and 19 factions
Start Generate FULL Map with Clusters and seed 595378181 and planet count 40 and 19 factions

I can't duplicate the issue yet, but it looks like you're not being assigned a homeworld, perhaps? There was someone else reporting getting an instant victory on Steam: https://steamcommunity.com/app/573410/discussions/1/4334097152423048883/

Anything you can do to help us reproduce it is welcome.

x4000Bughunter

May 18, 2020 1:07 pm

administrator   ~0057007

I can reproduce this with Linked Rings and 10 planets. Looking into it!

x4000Bughunter

May 18, 2020 5:53 pm

administrator   ~0057013

Thanks!

* Map planet size ranges changed for the following:
** Concentric from 40-250 to 40-160.
** X, Grid, Maze, Clusters, Wheel, Honeycomb, Encapsulated, Octopus, and Simple from 40-200 to 40-160.
** Realistic from 40-100 to 40-160.
** Linked Rings, Swirl, and Bubbles from 10-300 to 40-160.
** Below about 40 planets, it's rare to be able to fully generate a map properly.

* Fixed several bugs that could happen if you had no planet or were not viewing a planet at the moment.
** Those states should not have been happening in the first place, but if they do we want to not flood the error log with that sort of downstream error.

* Fixed a couple of funky bugs that could lead to the player or an AI not seeding properly on their homeworlds on excessively small maps.

Issue History

Date Modified Username Field Change
May 17, 2020 6:14 pm NRSirLimbo New Issue
May 17, 2020 6:14 pm NRSirLimbo File Added: 20200518001308_1.jpg
May 17, 2020 6:14 pm NRSirLimbo File Added: ArcenDebugLog.txt
May 17, 2020 7:14 pm BadgerBadger Note Added: 0056997
May 17, 2020 7:37 pm NRSirLimbo Note Added: 0056999
May 17, 2020 7:41 pm NRSirLimbo Note Added: 0057000
May 18, 2020 12:55 pm x4000Bughunter Note Added: 0057006
May 18, 2020 1:07 pm x4000Bughunter Note Added: 0057007
May 18, 2020 1:07 pm x4000Bughunter Assigned To => x4000Bughunter
May 18, 2020 1:07 pm x4000Bughunter Status new => assigned
May 18, 2020 5:53 pm x4000Bughunter Status assigned => resolved
May 18, 2020 5:53 pm x4000Bughunter Resolution open => fixed
May 18, 2020 5:53 pm x4000Bughunter Fixed in Version => Beta 2.043 The Missing Human King
May 18, 2020 5:53 pm x4000Bughunter Note Added: 0057013