View Issue Details

IDProjectCategoryLast Update
0023179AI War 2[All Projects] Crash/ExceptionJun 18, 2020 4:03 pm
ReporterStrategic SageAssigned Tox4000Bughunter 
Severitycrash 
Status closedResolutionno change required 
Product Version2.032 Savegame Hotfix 
Fixed in Version 
Summary0023179: Can't Start Program
DescriptionSo I'm sure this is something very obvious. I haven't played in a while and was going to get back into it. Yesterday all was fine, but today AI War 2 won't even boot up. I restarted my computer, tried the OpenGL and DX11 options, and there's nothing in the debug log file (assuming I'm looking in the right place for that, last info there is from over two weeks ago). So … what do I look at/try/report back with there? Steam just cycles for 15-20 seconds and then I get the Play button back again, nothing happens after the Steam 'preparing to launch AI War 2' message.
TagsNo tags attached.

Activities

Strategic Sage

May 10, 2020 8:22 pm

reporter   ~0056969

Should also note that I've checked other software I use. Some other Steam games I use work fine, but some don't. I think I'm going to try reinstalling the Steam client itself. .

BadgerBadger

May 10, 2020 8:27 pm

manager   ~0056970

Are there errors in the unity or arcen logs?

Try running it from the command line instead of through steam

Strategic Sage

May 10, 2020 8:30 pm

reporter   ~0056971

If I'm looking in the right place, there's literally nothing in the logs more recent than April 24th. PlayerData directory, ArcenDebugLog and ErrorsReportedByEngine

Strategic Sage

May 10, 2020 8:32 pm

reporter   ~0056972

It does boot up when starting outside of Steam though, so it appears Steam and I are just having … a moment.

BadgerBadger

May 10, 2020 8:32 pm

manager   ~0056973

Can you try invoking directly? (ie find the binary and execute via clicking on it or the cli)?

Strategic Sage

May 10, 2020 8:50 pm

reporter   ~0056974

If you mean clicking on the AIWar2.exe directly, that works. It just won't start if I try to run it through Steam.

Strategic Sage

May 10, 2020 9:47 pm

reporter   ~0056975

Reinstalled Steam, no change. I can still run the game from the directory, but I'm not sure how updates will work … will have to see I guess. Anyway, feel free to close this if you like, since it's a Valve issue not an Arcen issue from what I can tell. .

x4000Bughunter

May 12, 2020 10:20 am

administrator   ~0056980

So, there are some log files from unity directly, which are located here: https://docs.unity3d.com/2018.1/Documentation/Manual/LogFiles.html

For you, that would be in this location: C:\Users\username\AppData\LocalLow\CompanyName\ProductName\output_log.txt

It sounds like unity is failing long before it actually launches any of Arcen's code, and given that's the case it's likely not actually starting steamworks directly, either (as in, our hooks to it). Before we do anything even remotely risky with our code, we first log some stuff saying "starting now, here's our system specs in a really broad sense." You're not even getting to that point, so it can't be GOG integration or anything else that might get funky.

Steam itself injects a secondary layer of stuff into any program launched through it, to give you the steam overlay. GOG does the same thing with stuff launched via galaxy. Usually this is harmless and works out extremely well even for programs not ever designed to have them in there. It's more of an OS-level function.

My suspicion is that there is indeed a Steam problem that's affecting your system for some reason, whether that's because of an OS update on Microsoft's part, or some sort of hardware driver conflict (steam's overlay does try to connect to gamepads and such for big picture mode, so far as I know), or just a good old fashioned but in the version of Steam you have right now.

Seeing the output.log from unity's stuff would potentially be a bit edifying, although since it's dying before it even reaches Arcen's first line of code, there's probably not much we can directly do.

On the plus side, if you launch AI War 2 from windows explorer or the command line, and steam is running, you won't have the overlay but you will still get signed in and it will log achievements and playtime.

Strategic Sage

May 18, 2020 6:40 am

reporter   ~0057003

Thanks for the suggestion. There is no output file in that folder though. LocalLow/Arcen Games, LLC just contains two files, Player and Player-prev. Most of the other games I have don't have one either, but some of them do. I'm not sure under what conditions that output_log file is generated, but I can't report back here on it when it doesn't exist.

x4000Bughunter

May 18, 2020 11:15 am

administrator   ~0057004

Sorry about that -- Player.log and Player-prev.log are what this version of unity calls them, I think. It varies by OS, and they've changed it repeatedly over the last 10 years. I miss when it used to just go to the equivalent of AIWar2_Data in the local folder. At any rate, those are the two log files. One is from your very most recent run, the other is from your one prior to that.

x4000Bughunter

May 18, 2020 11:17 am

administrator   ~0057005

To be clear -- on OSX and Linux it is always Player.log, but their documentation was probably lagging on this for windows because I can see on my own machine that it's Player.log and has been for years, but I never really think about it much. Sorry about the confusion.

Strategic Sage

May 18, 2020 7:25 pm

reporter   ~0057016

Ok so let's confuse things even more. Trying to run the game through Steam puts nothing there. At all. Tested by deleting those files and tried it again. Nothing. Starting just by navigating to the directory still works fine, and generates the attached file. Seems that, among other things I'm sure I don't understand, several .dll files from the

Strategic Sage

May 18, 2020 7:26 pm

reporter   ~0057017

I'll try this again without cutting off. several .dll files from the AI War 2_Data/Mono directory are failing. Which makes sense, inasmuch as that subdirectory does not exist on my computer. Should it? Anyway, aside from that I hope this is of some use to somebody in some way.

Player.log (9,916 bytes)

BadgerBadger

May 18, 2020 7:54 pm

manager   ~0057019

I suspect if you want to get this fixed you need to take it up with Valve's support

Strategic Sage

May 19, 2020 6:35 am

reporter   ~0057020

Thanks. I have tried to do so but am not optimistic as their approach to this is to just direct me to contact the game developers themselves - which is not particularly useful in this case as has been shown here. Totally agree that this isn't an Arcen issue.

x4000Bughunter

May 20, 2020 12:31 pm

administrator   ~0057062

Blah! Yep, all looks well in your Player.log. There are random dlls that they look for via unity for some reason, which fail but are harmless. I think they wind up checking for some sort of extensions that aren't always there, and just warn if it's missing. Since it seems to be kind of auto-generated dlls, I assume it's some sort of internal thing unity is creating for their own dynamic code.

At any rate, those are things that appear for everyone, and don't harm anything.

Why it's failing to load AT ALL is so strange, when it comes to Steam. I tried googling it, and mostly came up with this ad-laden kinda-shady link which does have a few gems despite also pushing a lot of software you don't need: https://windowsreport.com/steam-games-fail-windows-10/

Good bits:

2. Antivirus software can be problematic. You might want to try turning any you have off temporarily. It COULD be that antivirus software is seeing how Steam is hooking into the game and injecting the overlay, and then killing the whole process. That would be a first since about 2011 for an Arcen title, but it has happened before.

"3. Delete/move GameOverlayRenderer64.dll file
According to users, sometimes certain files can cause issues with Steam games and prevent them from launching. However, you can fix this issue simply by removing a single problematic file. In most cases, the problematic file is GameOverlayRenderer64.dll, and to fix the problem you need to remove it.

Alternatively, you can just move the file to a different location and that will achieve the same results. Keep in mind that this is just a workaround, but it works according to users, so be sure to try it out."

That seems like an interesting possible fix, if the overlay is the problem.

5. Update your graphics card drivers. This is definitely something that can happen, since it sounds like the overlay being injected into the game may be the problem here.

6. Check for problematic applications. If you have some other programs adding in an overlay or some sort of hook into the game, then they might be conflicting with Steam. I doubt that's the case, but it could be. Something like bandicam, for instance, does a hook over the top to draw the FPS counter. At one point various voice chat apps had hooks in.

9. Run the game in Compatibility mode. This one is junk, don't do that one. ;)

Regarding updates to the game, Steam itself will always download updates for you just fine. Restarting Steam (Exit Steam in the right-click menu on the task bar) will trigger updates immediately to any games that have them. It's slower if you don't periodically restart Steam, but not super slow. And you can still try to launch the game and have it get the update before you then launch it from the file system.

Sorry about all the trouble! If you find out what the conflict is, please do post here so that others will know.

Strategic Sage

May 31, 2020 9:33 am

reporter   ~0057158

Thanks again for all the time spent on this. Here's thelong and the short of it:

2) This is always a first step. No dice.

3) Never got to this

5) It was out of date. Updating resulted in Steam taking longer to decide not to run the game. Still nothing in the log files.

6) Had all that stuff turned off, I do use MSI Afterburner for that on occasion but it was off.

However, it is working again now just recently. I think it was a Steam update that fixed it, so more evidence there that it was on their end. There is still one other game that doesn't work for, but yeah - I wish I had better advice for others beyond 'wait for Valve to fix it on their own', but I think that's about the best I can do here.

Strategic Sage

May 31, 2020 9:34 am

reporter   ~0057159

And then just it's stopped running again. *sigh* Whatever.

x4000Bughunter

Jun 11, 2020 9:57 am

administrator   ~0057272

Yikes, I completely missed this. Sorry about that. Is it still busted again?

Strategic Sage

Jun 11, 2020 8:10 pm

reporter   ~0057286

It still works sometimes, and not others. No dice on isolating why.

x4000Bughunter

Jun 16, 2020 8:22 pm

administrator   ~0057325

Dang, that's super frustrating.

Strategic Sage

Jun 17, 2020 2:58 pm

reporter   ~0057347

Ok the latest on this: it's now hit another game by a quality indie developer with the same 'disease'. CW4 Demo in this case. Again I'm the only one, but that one won't even run through the executable. So we tried a few more things. Windows Memory Diagnostic - no errors. Switched around the RAM, ran off one stick at a time, different configurations ... nada. I can be around 98%+ or so confident that's not the problem.

Both AI War 2 and that product run once a blue moon right after reboot. Vast majority of the time they don't. Rest of Steam library still does. The GameOverlayRenderer64.dll file trick or other similar things are a non-starter; can't do anything with them while Steam is running and I can't run anything through Steam without it detecting the file isn't there and reinstalling it.

I did bludgeon my way through the Steam Support system and started an issue there, closest I could get is 'Steam Client crashing'. Which it isn't, but it's the best approximation of the issue. If I get anything useful out of that, I'll report it back here.

BadgerBadger

Jun 17, 2020 3:12 pm

manager   ~0057348

Last edited: Jun 17, 2020 3:12 pm

View 2 revisions

If you try to use the steam cli does the problem repeat?

I'd also suggest replacing the AIW2 executable with a new executable that you create that does some additional logging. Like a bash script that says

echo "I am trying to invoke AI War 2 binary "> /tmp/logfile;
exec AIWar2
echo "return code is $rc" > /tmp/logfile.

If steam is in fact launching the executable then that might let you figure out what's going on.

Strategic Sage

Jun 17, 2020 3:57 pm

reporter   ~0057349

Problem always repeats in steam client - even if I've just run the game via the executable or not. Unsure if that's what you are asking?

Unfortunately I don't know how to use bash scripts. I've done small command line switches in the past and some amateurish C# coding, modding scripts etc. but I think it might be beyond what I know how to do. From what I can see that appears to be a linux thing and I don't run linux, but maybe I just don't really know what it is. *shrug*

BadgerBadger

Jun 17, 2020 5:57 pm

manager   ~0057351

Are you using the GUI client? Or the CLI? There is a steam CLI that can be used.

Well, it doesn't have to be a bash script, that was just an example. Any programming language would do. Powershell? Any scripting language? C#? Brainfuck? The goal is to say "Instead of invoking the AIW2 binary directly, invoke a different program instead so you can get more logging, since the current logging is inadequate".

If windows has an equivalent to strace you could also use that to see exactly how the AIW2 binary is being invoked, whether any signals are being sent to the process, etc...

Strategic Sage

Jun 18, 2020 2:15 am

reporter   ~0057358

Thanks for that. I spent a while working with the command-line option, but I don't think that will get me far. It won't install the expansion (gives a timed-out error when I try), only the base game of AI War 2. Can't run the game in any way I can see through that either, using the executable directly will run it but ... I could already do that. I.e., there aren't any commands to run the game per se, just to update, where to install, etc. I think I've reached the point where there's not a whole lot I can do that doesn't require a lot more time to learn/familiarize myself with things I don't typically use than I have time available.

x4000Bughunter

Jun 18, 2020 8:58 am

administrator   ~0057360

If you'd like a GOG key, in the meantime, that might be one thing. DLC2 is not in beta there yet, and we don't do beta branches in general on GOG, but the main game itself is there and works with their downloader.

Strategic Sage

Jun 18, 2020 1:06 pm

reporter   ~0057362

I appreciate that - it's not that big an inconvenience for me to run AI War 2 through the executable so I don't need a GOG key. I've taken the 'nuclear option' due to not hearing anything back yet, and am reinstalling Windows. I report back on whether that did any good.

Strategic Sage

Jun 18, 2020 1:59 pm

reporter   ~0057363

And all is well now. Apparently somewhere in the mysterious, unfathomable, unknowable depths of Windows where even Flensers fear to tread there was something corrupt or amiss. I guess my lesson is to pull the trigger on that a lot sooner next time when I can't find another solution.

We can close this now. My PC was just being a rebel ... or something.

BadgerBadger

Jun 18, 2020 2:22 pm

manager   ~0057364

This is why everyone should run linux

x4000Bughunter

Jun 18, 2020 4:03 pm

administrator   ~0057365

Oh man! A rogue windows install is kind a nightmare. Our game has next to no dependencies, so I'm guessing it was something wrong with the Steam ones -- probably one of the Visual C++ runtimes was corrupt in some way. Blah!

Issue History

Date Modified Username Field Change
May 10, 2020 8:19 pm Strategic Sage New Issue
May 10, 2020 8:22 pm Strategic Sage Note Added: 0056969
May 10, 2020 8:27 pm BadgerBadger Note Added: 0056970
May 10, 2020 8:30 pm Strategic Sage Note Added: 0056971
May 10, 2020 8:32 pm Strategic Sage Note Added: 0056972
May 10, 2020 8:32 pm BadgerBadger Note Added: 0056973
May 10, 2020 8:50 pm Strategic Sage Note Added: 0056974
May 10, 2020 9:47 pm Strategic Sage Note Added: 0056975
May 12, 2020 10:20 am x4000Bughunter Note Added: 0056980
May 18, 2020 6:40 am Strategic Sage Note Added: 0057003
May 18, 2020 11:15 am x4000Bughunter Note Added: 0057004
May 18, 2020 11:17 am x4000Bughunter Note Added: 0057005
May 18, 2020 7:25 pm Strategic Sage Note Added: 0057016
May 18, 2020 7:26 pm Strategic Sage File Added: Player.log
May 18, 2020 7:26 pm Strategic Sage Note Added: 0057017
May 18, 2020 7:54 pm BadgerBadger Note Added: 0057019
May 19, 2020 6:35 am Strategic Sage Note Added: 0057020
May 20, 2020 12:31 pm x4000Bughunter Note Added: 0057062
May 20, 2020 12:32 pm x4000Bughunter Assigned To => x4000Bughunter
May 20, 2020 12:32 pm x4000Bughunter Status new => feedback
May 31, 2020 9:33 am Strategic Sage Note Added: 0057158
May 31, 2020 9:33 am Strategic Sage Status feedback => assigned
May 31, 2020 9:34 am Strategic Sage Note Added: 0057159
Jun 11, 2020 9:57 am x4000Bughunter Note Added: 0057272
Jun 11, 2020 8:10 pm Strategic Sage Note Added: 0057286
Jun 16, 2020 8:22 pm x4000Bughunter Note Added: 0057325
Jun 17, 2020 2:58 pm Strategic Sage Note Added: 0057347
Jun 17, 2020 3:12 pm BadgerBadger Note Added: 0057348
Jun 17, 2020 3:12 pm BadgerBadger Note Edited: 0057348 View Revisions
Jun 17, 2020 3:57 pm Strategic Sage Note Added: 0057349
Jun 17, 2020 5:57 pm BadgerBadger Note Added: 0057351
Jun 18, 2020 2:15 am Strategic Sage Note Added: 0057358
Jun 18, 2020 8:58 am x4000Bughunter Note Added: 0057360
Jun 18, 2020 1:06 pm Strategic Sage Note Added: 0057362
Jun 18, 2020 1:59 pm Strategic Sage Note Added: 0057363
Jun 18, 2020 2:22 pm BadgerBadger Status assigned => closed
Jun 18, 2020 2:22 pm BadgerBadger Resolution open => no change required
Jun 18, 2020 2:22 pm BadgerBadger Note Added: 0057364
Jun 18, 2020 4:03 pm x4000Bughunter Note Added: 0057365