View Issue Details

IDProjectCategoryLast Update
0023031AI War 2[All Projects] Balance IssueMay 21, 2020 4:37 pm
ReporterHistidineAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version2.009 Plenty Of Tuning 
Fixed in Version2.047 Perks By Another Mother 
Summary0023031: Nanobot centers should not spawn on player planets
Description(i.e. planets with player command stations on them, when player is not friendly to nanocaust)

Otherwise they can spread through player territory uncontrollably once they penetrate the front line, building nanobot centers as they go while circumventing player defenses.
TagsNo tags attached.

Activities

BadgerBadger

May 21, 2020 12:06 pm

manager   ~0057084

int hostileStrength = planet.GetPlanetFactionForFaction( faction ).DataByStance[FactionStance.Hostile].MobileStrength;
            //FInt friendlyTotalStrength = planet.GetPlanetFactionForFaction( faction ).DataByStance[FactionStance.Friendly].TotalStrength;

            PlanetFaction myPlanetFaction = planet.GetPlanetFactionForFaction( faction );
            int myStrength = myPlanetFaction.DataByStance[FactionStance.Self].TotalStrength;

            if ( myStrength == 0 )
                return false;

            if ( hostileStrength < myStrength/10)
            {
                if ( tracing ) tracingBuffer.Add("allowedToCapture: currently allowed to capture " + planet.Name + " Nanocaust Strength " + myStrength + " enemy strength " + hostil\
eStrength).Add("\n");
                return true;
            }

Note that it's only counting mobile ships. It probably should count everything

BadgerBadger

May 21, 2020 4:37 pm

manager   ~0057090

The Nanocaust are definitely allowed to claim planets with player command stations on them. However, I've tweaked the rules to make sure they significantly outnumber your forces.

You also have a grace period where the spawner is warping in. But if the Nanocaust break through your defenses they can and will spread very rapidly through your planets, and that's not a bug.

Issue History

Date Modified Username Field Change
Mar 14, 2020 9:15 am Histidine New Issue
May 21, 2020 12:06 pm BadgerBadger Note Added: 0057084
May 21, 2020 12:06 pm BadgerBadger Assigned To => BadgerBadger
May 21, 2020 12:06 pm BadgerBadger Status new => assigned
May 21, 2020 4:37 pm BadgerBadger Status assigned => resolved
May 21, 2020 4:37 pm BadgerBadger Resolution open => fixed
May 21, 2020 4:37 pm BadgerBadger Fixed in Version => 2.047 Perks By Another Mother
May 21, 2020 4:37 pm BadgerBadger Note Added: 0057090