View Issue Details

IDProjectCategoryLast Update
0023019AI War 2[All Projects] Bug - GameplayApr 27, 2020 4:22 pm
ReporterParadoxSongAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionduplicate 
Product Version2.009 Plenty Of Tuning 
Fixed in Version2.031 Faction Color Choice 
Summary0023019: Distinguishing between duplicate factions is impossible in warnings
DescriptionPretty simple this one, messages like spire debris, if you have multiple factions of the same type, are impossible to distinguish between. Simply printing the allegiances of each faction getting spire ships would solve this for all practical purposes. (Though edge cases with highly varied intensities of the same faction on the same team wouldn't, that's a pretty minor problem)
TagsNo tags attached.

Relationships

duplicate of 0022177 resolvedx4000Bughunter Change Faction Color Ingame 

Activities

BadgerBadger

Mar 13, 2020 6:12 pm

manager   ~0056529

The name of the faction should have the faction colour in it though, right?

Chris is going to make it possible to change faction colours in game, which should resolve this.

ParadoxSong

Mar 20, 2020 4:46 pm

reporter   ~0056593

Yep, that'll resolve this when it's in.

ParadoxSong

Apr 19, 2020 7:37 pm

reporter   ~0056915

Resolved.

x4000Bughunter

Apr 27, 2020 4:22 pm

administrator   ~0056945

As of the next version (2.030), you can now change the colors of any and all factions in a savegame at any time. You just go into the escape / system menu, and hit View / Edit Factions, and choose the faction you want.

Thanks!

Issue History

Date Modified Username Field Change
Mar 13, 2020 3:57 pm ParadoxSong New Issue
Mar 13, 2020 6:12 pm BadgerBadger Note Added: 0056529
Mar 20, 2020 4:46 pm ParadoxSong Note Added: 0056593
Apr 19, 2020 7:37 pm ParadoxSong Fixed in Version => 2.026 The Faction Duality Problem
Apr 19, 2020 7:37 pm ParadoxSong Note Added: 0056915
Apr 21, 2020 3:20 pm BadgerBadger Relationship added duplicate of 0022177
Apr 27, 2020 4:22 pm x4000Bughunter Assigned To => x4000Bughunter
Apr 27, 2020 4:22 pm x4000Bughunter Status new => resolved
Apr 27, 2020 4:22 pm x4000Bughunter Resolution open => duplicate
Apr 27, 2020 4:22 pm x4000Bughunter Fixed in Version 2.026 The Faction Duality Problem => 2.031 Faction Color Choice
Apr 27, 2020 4:22 pm x4000Bughunter Note Added: 0056945