View Issue Details

IDProjectCategoryLast Update
0022765AI War 2[All Projects] Bug - OtherFeb 10, 2020 8:02 pm
Reporter5oundsAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBETA 1.324 Forcefield Beautification 
Fixed in VersionBETA 1.327 Hardened Forcefields 
Summary0022765: Build issue - Window_ModalDualTextboxWindow ?
DescriptionHi there,

Just went to do a build a moment ago and I notice this call:

Window_ModalDualTextboxWindow.Instance.Open( "Save as Quickstart?", "Preset Name:", "Preset Description", false, false, null, 30, 3000, delegate ( string NewPresetName, string NewPresetDescription )
                
is not recognised in class Window_InGameDeveloperToolsMenu .

Is there something missing / not checked-in?

Thanks.
TagsNo tags attached.

Activities

BadgerBadger

Feb 10, 2020 12:00 pm

manager   ~0055945

Just to be clear, this is an error during compilation? What's the actual error? Are you trying to build through visual studio or some other means?

I had this problem and needed to add a file or two to the External csproj.

Do you see the C# that defines that modal text box?

x4000Bughunter

Feb 10, 2020 12:05 pm

administrator   ~0055947

It should be fixed in the next version (thanks to Badger), but if you go in and manually add Window_ModalDualTextboxWindow.cs to your csproj file, then it should start working for you sooner than that. I didn't catch this because my batch compile scripts don't use the csproj files, and I've been only in the art areas, not code. Apologies!

BadgerBadger

Feb 10, 2020 12:06 pm

manager   ~0055948

I think I'm the only person using the csproj's in my compilation these days.

x4000Bughunter

Feb 10, 2020 1:16 pm

administrator   ~0055960

I use them when I compile by hand. Which I frequently do while coding.

5ounds

Feb 10, 2020 5:57 pm

reporter   ~0055961

As I'm not really a Visual Studio expert I didn't even think to check the actual csproj file. As my time outside of office hours is limited for fun coding, it was just a case of seeing a simple build error from a clean check out from steam and wondering how it was missed.

I generally use VIM and eclipse for work (C/C++, Java, Python, R) so a case of being a bit lazy and not hunting down a simple missing file.

Thanks for looking into it

x4000Bughunter

Feb 10, 2020 8:02 pm

administrator   ~0055963

No problem, sorry that made it into the steam build. Usually wouldn't!

Issue History

Date Modified Username Field Change
Feb 10, 2020 1:00 am 5ounds New Issue
Feb 10, 2020 12:00 pm BadgerBadger Note Added: 0055945
Feb 10, 2020 12:05 pm x4000Bughunter Assigned To => x4000Bughunter
Feb 10, 2020 12:05 pm x4000Bughunter Status new => resolved
Feb 10, 2020 12:05 pm x4000Bughunter Resolution open => fixed
Feb 10, 2020 12:05 pm x4000Bughunter Fixed in Version => BETA 1.327 Hardened Forcefields
Feb 10, 2020 12:05 pm x4000Bughunter Note Added: 0055947
Feb 10, 2020 12:06 pm BadgerBadger Note Added: 0055948
Feb 10, 2020 1:16 pm x4000Bughunter Note Added: 0055960
Feb 10, 2020 5:57 pm 5ounds Note Added: 0055961
Feb 10, 2020 8:02 pm x4000Bughunter Note Added: 0055963