View Issue Details

IDProjectCategoryLast Update
0022729AI War 2[All Projects] Bug - GameplayFeb 14, 2020 6:04 pm
ReporterSigma7Assigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionreopened 
Product Version1.320 Intelligence Intensifies 
Fixed in VersionBETA 1.330 Extragalactic War First Steps 
Summary0022729: Spurious Announcement - AI targetting homeworld
DescriptionThe chief of staff advises the player that an AI is readying a wave against the homeworld. The problem is that some of these waves are often spurious, thus feeding incorrect information to the player.

Expected behavior:
* The chief of staff should either give a warning of a regular wave, or said wave should be on the proclaimed target.

Actual behavior
* The chief announces that there's a wave against the home world on a non-homeworld wave.

Attached saved game shows the bug - at ~22m:02s, the AI sends a wave to Veloso from Kennedy. In this case, a direct homeworld strike isn't possible, but the AI focuses on the current planet rather than stretching for a deeper strike.

Autosave.1200 is the control save, taken before I knocked out a warp gate. Here, the direct wave is possible but the spurious announcement still occurs as the wave likewise targets borderworld Veloso.
TagsNo tags attached.

Activities

Sigma7

Jan 31, 2020 1:11 pm

reporter  

Readied Wave.7z (269,756 bytes)

x4000Bughunter

Jan 31, 2020 11:16 pm

administrator   ~0055852

Finally fixed. Thank you!!

Sigma7

Feb 4, 2020 10:08 pm

reporter   ~0055899

Although I no longer have a known setup, I'm still experiencing this bug in v1.321.

This save is a bit farther into the same campaign where I captured a few planets. The announcer states that the AI is planning an attack on the homeworld, but Dean is targeted instead.

Announcer 2h53m20s.7z (243,316 bytes)

Sigma7

Feb 4, 2020 10:08 pm

reporter   ~0055900

Saved game is 20 seconds away from warp event.

Sigma7

Feb 14, 2020 5:20 pm

reporter   ~0056029

Update: Got a new setup. Here's a new save set, where one save has the announcer for the system, and the other does not. Only relevant difference between the two saves is the missing GCA, thus it's confusing home system with critical planet.

bug0022729 - announcer.7z (462,545 bytes)

BadgerBadger

Feb 14, 2020 6:03 pm

manager   ~0056030

After some C# debugging, the code thinks it's trying to play a "Critical Planet" voice line. Looks like there's an XML issue. The XML here maps from what the C# code looks at to the actual unity sound files
  <sfx name="ArkChiefOfStaff_WaveTargetingCriticalPlanet" bus="Alert" bundle_name="aiwar2voice" <================== Critical Planet; this is what the C# looks at
       filename="Assets/Voice/ArkChiefOfStaff/AI Attack/Wave Targeting Home World/000_Voice.prefab" /> <================== Whoops! It's pointing to sound files about the home planet

This is fixed now. Thanks for the diligent reporting! Your save games were critical to figuring this out

Issue History

Date Modified Username Field Change
Jan 31, 2020 1:11 pm Sigma7 New Issue
Jan 31, 2020 1:11 pm Sigma7 File Added: Readied Wave.7z
Jan 31, 2020 11:16 pm x4000Bughunter Assigned To => x4000Bughunter
Jan 31, 2020 11:16 pm x4000Bughunter Status new => resolved
Jan 31, 2020 11:16 pm x4000Bughunter Resolution open => fixed
Jan 31, 2020 11:16 pm x4000Bughunter Fixed in Version => 1.321 Enjoy Your Break, Voice Lady
Jan 31, 2020 11:16 pm x4000Bughunter Note Added: 0055852
Feb 4, 2020 10:08 pm Sigma7 File Added: Announcer 2h53m20s.7z
Feb 4, 2020 10:08 pm Sigma7 Note Added: 0055899
Feb 4, 2020 10:08 pm Sigma7 Status resolved => feedback
Feb 4, 2020 10:08 pm Sigma7 Resolution fixed => reopened
Feb 4, 2020 10:08 pm Sigma7 Note Added: 0055900
Feb 14, 2020 5:20 pm Sigma7 File Added: bug0022729 - announcer.7z
Feb 14, 2020 5:20 pm Sigma7 Note Added: 0056029
Feb 14, 2020 5:20 pm Sigma7 Status feedback => assigned
Feb 14, 2020 6:03 pm BadgerBadger Note Added: 0056030
Feb 14, 2020 6:04 pm BadgerBadger Assigned To x4000Bughunter => BadgerBadger
Feb 14, 2020 6:04 pm BadgerBadger Status assigned => resolved
Feb 14, 2020 6:04 pm BadgerBadger Fixed in Version 1.321 Enjoy Your Break, Voice Lady => BETA 1.330 Extragalactic War First Steps