View Issue Details

IDProjectCategoryLast Update
0022244AI War 2[All Projects] Bug - GameplayJan 11, 2021 5:13 pm
ReporterdeoAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version1.010 Extracting Those Archives 
Fixed in Version 
Summary0022244: Hotkeys inconsistencies
Description1. Flagships selecting hotkey (controls->selection->select mobile flagships)
working case
- press hotkey to select all military ships (i have it on ~)
- then hold ALT and press hotkey to select flagships (Q)
- result - excluding flagships from all military selection, works fine

another case which does not work
press hotkey to select fleet (1,2,etc)
then hold ALT and press hotkey to select flagships (Q)
expected the same - excluding flagships from selection, but it does not work for some reason
visually you see how selection of flagships disappear and reappear again

2. Load/Unload transport hotkeys (controls->ship controls->load/unload transport)
i Have load one on F and unload is alt+F
the case is
- select flagship 1
- press F to load it
- select flagships 1 and 2 (second one is unloaded at the time)
- press alt+f to unload - expected selected flagships to unload ships if any
what i see if first flagship is unloading but second one is loading (and any which is not loaded)
TagsNo tags attached.

Activities

alocritani

Nov 19, 2019 4:48 pm

reporter   ~0054642

for case 1, if you look carefully you can see that selecting every military unit really select units (lower right all ships are listed) but selecting fleet with (1,2,...) doesn't really select ships, just the fleet as a single "entity" (lower right only the fleet is listed). I agree with you that this is not ideal.
by the way I suggest a keybind to select all military EXCEPT flagship, because by default this selection is M (all military) followed by ALT (deselect) + C + V (select flagship) - not so easy

for case 2, I cannot reproduce it with default keybinding (U = unload, L = load) but I can reproduce it if I set (ALT+L = unload, L = load); so I think ALT key is the real difference

deo

Nov 20, 2019 1:39 am

reporter   ~0054646

yea, probably mod-key is not checked

x4000Bughunter

Jan 11, 2021 5:13 pm

administrator   ~0060284

Fixed these a while ago, except for case 1, which is working as intended. You can't select an entire fleet and then deselect part of it. But we do have the new stationary-flagship mode that does allow you to issue orders that the flagship will ignore, which is a useful option.

Issue History

Date Modified Username Field Change
Nov 19, 2019 2:35 pm deo New Issue
Nov 19, 2019 4:48 pm alocritani Note Added: 0054642
Nov 20, 2019 1:39 am deo Note Added: 0054646
Jan 11, 2021 5:13 pm x4000Bughunter Assigned To => x4000Bughunter
Jan 11, 2021 5:13 pm x4000Bughunter Status new => resolved
Jan 11, 2021 5:13 pm x4000Bughunter Resolution open => fixed
Jan 11, 2021 5:13 pm x4000Bughunter Note Added: 0060284