View Issue Details

IDProjectCategoryLast Update
0021783AI War 2[All Projects] GUIOct 15, 2019 1:55 pm
ReporterOzoneGrifAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.900 Custom Fleets With Empty Slots 
Fixed in Version0.950 First Press Build 
Summary0021783: Fleet selection and deselection issues (seems related to galaxy map selection changes)
DescriptionThe selection behavior on distant planets is different than selection on the current planet.

On the current planet, it deselects the ships from the current planet, but not the distant ships.
On the distant planet, it adds the ships to selection.

Wanted behavior:
If the player does not hold shift, the current selection should be cleaned at all times (always deselect distant and current planet ships). If the player holds shift, then the selection is added. Alt to remove.


Another issue: when a fleet traverse a wormhole, it's selection is lost. This issue only occurs if the selection was made in the planet view. If you select the fleet on the galaxy map, it works correctly.
TagsNo tags attached.

Relationships

related to 0021811 assignedx4000Bughunter Selection is lost after traversing wormhole (precise case) 

Activities

OzoneGrif

Oct 12, 2019 12:34 am

reporter   ~0053611

Distant Planet selection (with simple click).
Scorpion is currently selected.
Golem's selection is additive; it shouldn't.

DistantPlanet.jpg (59,515 bytes)
DistantPlanet.jpg (59,515 bytes)

OzoneGrif

Oct 12, 2019 12:37 am

reporter   ~0053612

Current Planet selection (with simple click).
Scorpion is currently selected.
I click on the fleet 1/2/0/4, it deselects the previously selected fleet in Scorpion and we end with 4 selected.
Golem's selection remains; it should be cleaned.

CurrentPlanet.jpg (58,505 bytes)
CurrentPlanet.jpg (58,505 bytes)

OzoneGrif

Oct 12, 2019 12:41 am

reporter   ~0053613

I select a fleet on the planet view with a simple click/or/drag 'n drop (not using shortcuts or galaxy map).
It is selected.
I ctrl+click the wormhole to traverse it.

OzoneGrif

Oct 12, 2019 12:42 am

reporter   ~0053614

The fleet is not selected anymore. I have to reselect it to unload my troops or give another order.

x4000Bughunter

Oct 14, 2019 7:55 pm

administrator   ~0053681

Thanks!

* Fixed a variety of selection issues on the galaxy map with fleets not always deselecting properly and instead sometimes being additive, etc.
** It's actually a number of bugs all in one, because basically there was some older per-planet logic that was still being used here (and on planets) from back when cross-planet selection was only kinda-sorta a thing. Now it all works consistently galaxy-wide, or at least should. But if you see any remaining (or new) bugs, please let us know.

* Previously, hitting the escape key would just clear your selection on the current planet. Now it clears the selection on all the planets, as it should.
** We didn't see the "when a fleet traverse a wormhole, it's selection is lost. This issue only occurs if the selection was made in the planet view. If you select the fleet on the galaxy map, it works correctly." issue, but probably what it really was was the above one. Or something fixed in the batch right before that. If it's still something anyone else sees, please let us know.

OzoneGrif

Oct 15, 2019 12:28 pm

reporter   ~0053697

> We didn't see the "when a fleet traverse a wormhole, it's selection is lost. This issue only occurs if the selection was made in the planet view. If you select the fleet on the galaxy map, it works correctly." issue

Just re-tested to make sure, the issue is still present in the 901 version.
I'll open a new issue bug

x4000Bughunter

Oct 15, 2019 1:55 pm

administrator   ~0053705

Last edited: Oct 15, 2019 1:55 pm

View 2 revisions

Perfect, thanks for opening 0021811. That's a big help!

Issue History

Date Modified Username Field Change
Oct 12, 2019 12:31 am OzoneGrif New Issue
Oct 12, 2019 12:34 am OzoneGrif File Added: DistantPlanet.jpg
Oct 12, 2019 12:34 am OzoneGrif Note Added: 0053611
Oct 12, 2019 12:37 am OzoneGrif File Added: CurrentPlanet.jpg
Oct 12, 2019 12:37 am OzoneGrif Note Added: 0053612
Oct 12, 2019 12:41 am OzoneGrif File Added: Annotation 2019-10-12 064017.jpg
Oct 12, 2019 12:41 am OzoneGrif Note Added: 0053613
Oct 12, 2019 12:42 am OzoneGrif File Added: Annotation 2019-10-12 064045.jpg
Oct 12, 2019 12:42 am OzoneGrif Note Added: 0053614
Oct 14, 2019 7:55 pm x4000Bughunter Assigned To => x4000Bughunter
Oct 14, 2019 7:55 pm x4000Bughunter Status new => resolved
Oct 14, 2019 7:55 pm x4000Bughunter Resolution open => fixed
Oct 14, 2019 7:55 pm x4000Bughunter Fixed in Version => 0.950 First Press Build
Oct 14, 2019 7:55 pm x4000Bughunter Note Added: 0053681
Oct 15, 2019 12:28 pm OzoneGrif Note Added: 0053697
Oct 15, 2019 1:54 pm x4000Bughunter Relationship added related to 0021811
Oct 15, 2019 1:55 pm x4000Bughunter Note Added: 0053705
Oct 15, 2019 1:55 pm x4000Bughunter Note Edited: 0053705 View Revisions