View Issue Details

IDProjectCategoryLast Update
0021641AI War 2[All Projects] Graphical BugOct 4, 2019 7:40 pm
ReporterVaroneAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.888 Astro Examination 
Fixed in Version0.896 Strength and Control 
Summary0021641: Pursuit mode - ship model movement
DescriptionWhen your ships are in pursuit mode and they are attacking an enemy planet many ship models will rapidly rotate left and right. They tend to do this when engaged with an enemy already and so not moving.

Could be they are scanning for other targets and are rotating to point at them but then the next tick rotating back towards the original target they're engaged with?

TagsNo tags attached.

Activities

RocketAssistedPuffin

Sep 13, 2019 3:08 pm

developer   ~0053089

Far as I know units don't...actually look at their targets. They look where they are going though.

I imagine this is kiting, doing a little "go forward, go backwards", and since they look at their destination it causes that?

Asteroid

Sep 13, 2019 3:23 pm

reporter   ~0053091

Good point to bring up. Units look really spastic when they do that - probably the kind of bug you want to have fixed for 1.0.

wm46

Sep 13, 2019 5:41 pm

reporter   ~0053096

I was sure I fixed this a while ago, around when Chris first gave me access to the files sometime near 0.700.

Before, the issue was caused by ships getting an order to move to 0.8x kite range, then being told to move to 0.9x kite range once they moved past 0.9x.

Maybe the issue now is inaccuracies in the GetPointAtAngleAndDistance and GetDistanceToPoint methods. Currently the approach and retreat destinations are both set to 0.8x, the exact start of the retreat distance.

Maybe they should both put the ship at 0.85x kite distance?

x4000Bughunter

Oct 4, 2019 7:40 pm

administrator   ~0053495

Please let us know if you still see this, but I think Badger got it last build:

* Put in a fix to hopefully reduce auto-kite making your ships wobble.

Thanks!

Issue History

Date Modified Username Field Change
Sep 13, 2019 3:02 pm Varone New Issue
Sep 13, 2019 3:08 pm RocketAssistedPuffin Note Added: 0053089
Sep 13, 2019 3:23 pm Asteroid Note Added: 0053091
Sep 13, 2019 5:41 pm wm46 Note Added: 0053096
Oct 4, 2019 7:40 pm x4000Bughunter Assigned To => BadgerBadger
Oct 4, 2019 7:40 pm x4000Bughunter Status new => resolved
Oct 4, 2019 7:40 pm x4000Bughunter Resolution open => fixed
Oct 4, 2019 7:40 pm x4000Bughunter Fixed in Version => 0.896 Strength and Control
Oct 4, 2019 7:40 pm x4000Bughunter Note Added: 0053495