View Issue Details

IDProjectCategoryLast Update
0021632AI War 2[All Projects] GUISep 18, 2019 11:36 am
Reporterwm46Assigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.888 Astro Examination 
Fixed in Version0.890 Lighting and Darkness 
Summary0021632: Cryogenic pods give null ref exception when viewing mark up stats in the C-Menu
Description9/12/2019 8:59:41 PM
Exception in entity tooltip text generation at stage 1010:System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.External.Window_InGameHoverEntityInfo.GetTextForEntity (Arcen.Universal.ArcenDoubleCharacterBuffer buffer, Arcen.AIW2.Core.GameEntity_Base EntityBase, Arcen.AIW2.Core.Fleet+Membership MembershipBase, Arcen.AIW2.Core.GameEntityTypeData TypeDataOrNull, System.Int32 OptionalCountToShow, Arcen.AIW2.Core.Faction ForFactionOrNull, System.Int32 OptionalForMarkLevel, Arcen.AIW2.Core.FromSidebarType IsFromSidebarType, Arcen.AIW2.External.ShipExtraDetailsInfo DetailsType) [0x05f81] in <2fcaf8dc7ad6455698221b1a1e85de7e>:0

  at System.Environment.get_StackTrace () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.AIW2.External.Window_InGameHoverEntityInfo.GetTextForEntity (Arcen.Universal.ArcenDoubleCharacterBuffer buffer, Arcen.AIW2.Core.GameEntity_Base EntityBase, Arcen.AIW2.Core.Fleet+Membership MembershipBase, Arcen.AIW2.Core.GameEntityTypeData TypeDataOrNull, System.Int32 OptionalCountToShow, Arcen.AIW2.Core.Faction ForFactionOrNull, System.Int32 OptionalForMarkLevel, Arcen.AIW2.Core.FromSidebarType IsFromSidebarType, Arcen.AIW2.External.ShipExtraDetailsInfo DetailsType) [0x00000] in <2fcaf8dc7ad6455698221b1a1e85de7e>:0
  at Arcen.AIW2.External.Window_InGameSidebarScience+btnScienceTech.WriteDetailsOfATechContents (Arcen.Universal.ArcenDoubleCharacterBuffer buffer, Arcen.AIW2.Core.TechUpgrade tech, System.Int32 CostToUpgrade, System.Int32 UpgradesSoFar) [0x00000] in <2fcaf8dc7ad6455698221b1a1e85de7e>:0
  at Arcen.AIW2.External.Window_InGameSidebarScience+btnScienceTech+<>c__DisplayClass20_0.<ShowDetailsOfATechUpgradeContents>b__0 (Arcen.Universal.ArcenDoubleCharacterBuffer Buffer) [0x00000] in <2fcaf8dc7ad6455698221b1a1e85de7e>:0
  at Arcen.AIW2.External.Window_ModalSelfUpdatingTextWindow+customParent.OnUpdate () [0x00000] in <2fcaf8dc7ad6455698221b1a1e85de7e>:0
  at Arcen.Universal.ArcenUI_CustomUI.OnUpdate_Subclass (System.Single DeltaTime) [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.Universal.ArcenUI_Element.UpdateFromUI (System.Boolean ShouldDoFullUpdate, System.Single DeltaTime) [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.Universal.ArcenUI_Window.OnUpdateWindow (System.Single AddedDeltaTime) [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.Universal.ArcenUI.OnUpdateFromMainThread () [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at Arcen.Universal.Engine_Universal.OnUpdateFromMainThread () [0x00000] in <eab198e2cfa74fd3b58fcd31444f8343>:0
  at ArcenGameController.Update () [0x00000] in <15a8d73ac96046e1ae913167f0994469>:0

They seem to be trying to get their fleet membership to find out if they mark up from exp, but the fleet is null?
TagsNo tags attached.

Relationships

related to 0021550 resolvedx4000Bughunter null reference: Network.OnClient_SendClientBatchToServer 

Activities

wm46

Sep 12, 2019 9:01 pm

reporter  

Screenshot (25).png (631,560 bytes)

BadgerBadger

Sep 12, 2019 10:05 pm

manager   ~0053050

So you were C-viewing the science menu for Energy Collection?

I can't reproduce this. Is it consistent?

wm46

Sep 12, 2019 10:37 pm

reporter   ~0053051

Reproducing on my machine, both from a saved game and from a new quick start.

Here's the save just in case

Testes.save (650,410 bytes)

BadgerBadger

Sep 16, 2019 11:57 pm

manager   ~0053159

When I load that save game I immediately hit 21550

9/16/2019 9:56:49 PM
Inner Error in Network.OnClient_SendClientBatchToServer, debugStage 16000: System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.Universal.GameSpecificWorld_Networking.OnClient_SendClientBatchToServer () [0x00223] in <a1a624e568f140fe9fef8adbb37081ee>:0

  at System.Environment.get_StackTrace () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <647abaf984a14318970a43d63f422ea9>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <647abaf984a14318970a43d63f422ea9>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <647abaf984a14318970a43d63f422ea9>:0
  at Arcen.Universal.GameSpecificWorld_Networking.OnClient_SendClientBatchToServer () [0x00000] in <a1a624e568f140fe9fef8adbb37081ee>:0
  at Arcen.AIW2.Core.World_AIW2.OnClient_SendClientBatchToServer () [0x00000] in <6352ac173221436eb1ccc95fda3a1169>:0
  at Arcen.AIW2.External.SimPlannerImplementation.DoActualSimStep (System.Boolean& stalledWaitingOnConnections, System.Boolean& mayUpdateVisuals) [0x00000] in <52bbadae5e6044ea8cd68763dea52162>:0
  at Arcen.AIW2.Core.Engine_AIW2.ProcessSimStep (System.Boolean& stalledWaitingOnConnections) [0x00000] in <6352ac173221436eb1ccc95fda3a1169>:0
  at Arcen.Universal.Engine_Universal.OnUpdateFromMainThread () [0x00000] in <647abaf984a14318970a43d63f422ea9>:0
  at ArcenGameController.Update () [0x00000] in <1f99dcdc51d54627b95392fe7a7c50b4>:0

wm46

Sep 17, 2019 1:08 am

reporter   ~0053160

I don't know if I'm reading that right, but the debug log itself is throwing an error?

I've had no errors like that at all from that save.

BadgerBadger

Sep 18, 2019 11:25 am

manager   ~0053173

Last edited: Sep 18, 2019 11:35 am

View 2 revisions

Yeah, the networking problem doesn't reproduce readily; it was a thing I only hit once.

Edit: This problem no longer occurs when checking the C-Click menu for science upgrades that include cryo pods

BadgerBadger

Sep 18, 2019 11:36 am

manager   ~0053174

I'm not sure who fixed this or when it got fixed, but I can't reproduce it anymore

Issue History

Date Modified Username Field Change
Sep 12, 2019 9:01 pm wm46 New Issue
Sep 12, 2019 9:01 pm wm46 File Added: Screenshot (25).png
Sep 12, 2019 10:05 pm BadgerBadger Note Added: 0053050
Sep 12, 2019 10:37 pm wm46 File Added: Testes.save
Sep 12, 2019 10:37 pm wm46 Note Added: 0053051
Sep 16, 2019 11:57 pm BadgerBadger Note Added: 0053159
Sep 16, 2019 11:57 pm BadgerBadger Relationship added related to 0021550
Sep 17, 2019 1:08 am wm46 Note Added: 0053160
Sep 18, 2019 11:25 am BadgerBadger Note Added: 0053173
Sep 18, 2019 11:35 am BadgerBadger Note Edited: 0053173 View Revisions
Sep 18, 2019 11:36 am BadgerBadger Assigned To => BadgerBadger
Sep 18, 2019 11:36 am BadgerBadger Status new => resolved
Sep 18, 2019 11:36 am BadgerBadger Resolution open => fixed
Sep 18, 2019 11:36 am BadgerBadger Fixed in Version => 0.890 Lighting and Darkness
Sep 18, 2019 11:36 am BadgerBadger Note Added: 0053174