View Issue Details

IDProjectCategoryLast Update
0021581AI War 2[All Projects] GUISep 9, 2019 4:52 pm
ReporterAsteroidAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.886 Zombie Homebodies 
Fixed in Version0.888 Astro Examination 
Summary0021581: UI doesn't always register click on build unit button
DescriptionParticularly noticeable when placing turrets - I click a new turret type, only to keep getting the message that I'm hitting the cap, and then I realize it's still trying to place the last type of turret.
TagsNo tags attached.

Relationships

related to 0021230 resolvedx4000Bughunter A tiny section of each button on the sidebar actually selects the option below it 

Activities

x4000Bughunter

Sep 5, 2019 6:22 pm

administrator   ~0052877

Is it possible that part of the button doesn't register the click, or is it just some clicks get discarded?

RocketAssistedPuffin

Sep 5, 2019 6:37 pm

developer   ~0052878

Last edited: Sep 5, 2019 6:45 pm

View 2 revisions

It appears to not be a problem with registering a click.

In-game, hover the mouse over the Turret options. It'll swap the highlighted one correctly, to whatever the tip of the mouse is over.

Click one, place one, then hover the mouse over the options again. It'll highlight whatever the bottom of the mouse is over instead.

I am able to get it sometimes without doing that, but that seems the most consistent. Pretty random to get it, though.

So essentially, if you try to build a Turret above the one already selected, sometimes the mouse point has changed to the bottom, and you end up selecting the same one.

Asteroid

Sep 8, 2019 6:37 pm

reporter   ~0052923

I've paid closer attention, and sometimes when bringing the cursor over the button for a turret, it doesn't get highlighted and the one below it gets highlighted instead - and when you click, it would seem that it's the highlighted one that receives the click.

Wild guess: I play in 1920x1200. Would there be some UI scaling code that assumes a 16:9 aspect ratio rather than 16:10 by any chance? The weird thing though is that this vertical offset error isn't always present, and I haven't identified steps to reproduce it. It does happen rather often, at least once per planet whose defenses I have to setup.

Asteroid

Sep 8, 2019 7:28 pm

reporter   ~0052926

Reproduced fairly easily in a brand new 0.887 campaign by going back and forth between the planet view and the sidebar, clicking randomly in the planet view everytime.

2019-09-08 19_24_33-AIWar2.png (581,236 bytes)

wm46

Sep 8, 2019 11:01 pm

reporter   ~0052935

Added a relation to one of my reports. I've noticed this only occurs in the bottom right corner of any tab that has a metal cost icon below it.

Clicking on the bottom right of a tab will always select the option below it.

x4000Bughunter

Sep 9, 2019 4:52 pm

administrator   ~0052955

Thanks!

* Fixed several super-annoying glitches with any pieces of text we were using that had icons in them, mainly in parts of the sidebars, where the clickable area of buttons would be absurdly large and obscure part of the button below them. This often led to clicks and hovers actually selecting the wrong button, which was rightly infuriating.
** Turns out this was actually a bug/oversight in TextMeshPro itself, and we've fixed it per the notes we left here: https://forum.unity.com/threads/cant-disable-raycasting-on-tmp-submesh.548500/#post-4948295

Issue History

Date Modified Username Field Change
Sep 5, 2019 4:02 am Asteroid New Issue
Sep 5, 2019 6:22 pm x4000Bughunter Note Added: 0052877
Sep 5, 2019 6:37 pm RocketAssistedPuffin Note Added: 0052878
Sep 5, 2019 6:45 pm RocketAssistedPuffin Note Edited: 0052878 View Revisions
Sep 8, 2019 6:37 pm Asteroid Note Added: 0052923
Sep 8, 2019 7:28 pm Asteroid File Added: 2019-09-08 19_24_33-AIWar2.png
Sep 8, 2019 7:28 pm Asteroid Note Added: 0052926
Sep 8, 2019 10:58 pm wm46 Relationship added related to 0021230
Sep 8, 2019 11:01 pm wm46 Note Added: 0052935
Sep 9, 2019 4:52 pm x4000Bughunter Assigned To => x4000Bughunter
Sep 9, 2019 4:52 pm x4000Bughunter Status new => resolved
Sep 9, 2019 4:52 pm x4000Bughunter Resolution open => fixed
Sep 9, 2019 4:52 pm x4000Bughunter Fixed in Version => 0.888 Astro Examination
Sep 9, 2019 4:52 pm x4000Bughunter Note Added: 0052955