View Issue Details

IDProjectCategoryLast Update
0021570AI War 2[All Projects] GUISep 29, 2019 7:47 pm
ReporterAsteroidAssigned ToBadgerBadger 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.886 Zombie Homebodies 
Fixed in Version0.893 Usability and Tutorial Prep 
Summary0021570: Galaxy map UI doesn't reflect multiple queued move commands
DescriptionYou can shift-click to give a path to your units on the galaxy map, which is essential to go around dangerous enemy worlds. The problem is that the path displayed on screen doesn't reflect that, it always starts at the point of origin giving the impression that shift-clicking does nothing, and that clicking again will replace the previous path.
TagsNo tags attached.

Relationships

related to 0020790 resolvedBadgerBadger Waypoint queuing in route preview 

Activities

BadgerBadger

Sep 9, 2019 1:58 pm

manager   ~0052951

The code in question just computes the path to the planet you are hovering, it doesn't actually look at the commands that are queued.

BadgerBadger

Sep 23, 2019 5:54 pm

manager   ~0053256

Last edited: Sep 23, 2019 6:04 pm

View 2 revisions

I've put in a first pass at improving the UI code. I'm not sure how well it's working though.

Note that my changes are only for the UI

BadgerBadger

Sep 29, 2019 7:47 pm

manager   ~0053314

This seems to be working now

Issue History

Date Modified Username Field Change
Sep 4, 2019 1:20 pm Asteroid New Issue
Sep 9, 2019 1:55 pm BadgerBadger Summary Galaxy map UI doesn't reflect shift-click path => Galaxy map UI doesn't reflect multiple queued move commands
Sep 9, 2019 1:58 pm BadgerBadger Note Added: 0052951
Sep 9, 2019 11:55 pm BadgerBadger Relationship added related to 0020790
Sep 23, 2019 5:54 pm BadgerBadger Assigned To => BadgerBadger
Sep 23, 2019 5:54 pm BadgerBadger Status new => feedback
Sep 23, 2019 5:54 pm BadgerBadger Note Added: 0053256
Sep 23, 2019 6:04 pm BadgerBadger Note Edited: 0053256 View Revisions
Sep 29, 2019 7:47 pm BadgerBadger Status feedback => resolved
Sep 29, 2019 7:47 pm BadgerBadger Resolution open => fixed
Sep 29, 2019 7:47 pm BadgerBadger Fixed in Version => 0.893 Usability and Tutorial Prep
Sep 29, 2019 7:47 pm BadgerBadger Note Added: 0053314