View Issue Details

IDProjectCategoryLast Update
0021538AI War 2[All Projects] Bug - GameplaySep 3, 2019 9:05 pm
ReporterNRSirLimboAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.884 The Helping Hat 
Fixed in Version0.885 The Audible Bodyguard 
Summary0021538: Stacks still interfere with stances (FRD, etc)
DescriptionI'm not yet sure what causes it but seemingly when a ship is removed from a stack (i.e. destroyed) it seems that the stance is lost.
Currently trying to figure out what exactly does it.

EDIT:
Yes, I can confirm: It happens when a ship is destroyed from a stack.
TagsNo tags attached.

Relationships

related to 0021536 resolvedBadgerBadger Ships decolliding to odd places when traveling through wormholes 
related to 0021522 assignedx4000Bughunter Decollision problem with queued moves 

Activities

x4000Bughunter

Aug 28, 2019 10:51 am

administrator   ~0052655

This is now in for 0.885, can you test if it works?

* Fixed a potential cause of the bug where orders and stance could be lost on ships when a stack was being split or one ship in a stack died.
** Basically in the OnDeath logic we no longer need to clear orders at all.

* A HUGE amount of rework has been done with how orders are cleared from ships, and also regular move and decollision-move orders have been split out into two types.
** This lets us do things like clear just decollision orders but not other things, and we also no longer have a bunch of things referring to Rally orders, which haven't existed for a while.
** There may well be some bugs relating from this, but hopefully they are now easier to track down because the code is more sensibly-arranged for the current game design. It's possible that some things were previously working sometimes-but-not-always and will now work never, and that's actually preferable since we can then fix it to work always, once it's found.
** This needs lots of testing, relating to queuing orders and issuing orders of various sorts, and seeing that the AI doesn't do strange things with its own orders, etc, etc, etc.
** It's possible that this fixes the strange decollision logic when you queue a lot of move orders (that worked once upon a time, but has been broken since we revamped a bunch of the game code).

* Decollision-move orders are now explicitly dumped when a ship goes through a wormhole from one planet to another.

NRSirLimbo

Aug 31, 2019 5:00 pm

reporter   ~0052721

Seems fixed. So far hadn't seen a single case of FRD being removed without me ordering so.

x4000Bughunter

Sep 3, 2019 9:05 pm

administrator   ~0052795

Sweeeeet! Thanks. :)

Issue History

Date Modified Username Field Change
Aug 28, 2019 7:41 am NRSirLimbo New Issue
Aug 28, 2019 7:49 am NRSirLimbo Description Updated View Revisions
Aug 28, 2019 10:51 am x4000Bughunter Assigned To => x4000Bughunter
Aug 28, 2019 10:51 am x4000Bughunter Status new => feedback
Aug 28, 2019 10:51 am x4000Bughunter Note Added: 0052655
Aug 28, 2019 10:51 am x4000Bughunter Relationship added related to 0021536
Aug 28, 2019 10:51 am x4000Bughunter Relationship added related to 0021522
Aug 31, 2019 5:00 pm NRSirLimbo Note Added: 0052721
Aug 31, 2019 5:00 pm NRSirLimbo Status feedback => assigned
Sep 3, 2019 9:05 pm x4000Bughunter Status assigned => resolved
Sep 3, 2019 9:05 pm x4000Bughunter Resolution open => fixed
Sep 3, 2019 9:05 pm x4000Bughunter Fixed in Version => 0.885 The Audible Bodyguard
Sep 3, 2019 9:05 pm x4000Bughunter Note Added: 0052795