View Issue Details

IDProjectCategoryLast Update
0021373AI War 2[All Projects] Bug - GameplayJul 12, 2019 12:35 pm
ReporterAnnoyingOrangeAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.874 Basic Fleet Management 
Fixed in Version0.875 Counterattacks You Can Taste 
Summary0021373: Fleet centerpieces now push friendly forcefield generators out of the way.
DescriptionThis can be a big problem if the fleet defending your homeworld pushes the home forcefield out of position, or if it displaces the forcefield covering a wormhole.
Test save attached, send Fleet 1 to the homeworld and then back through the wormhole to see the forcefields being displaced: interestingly, displacement doesn't happen on the entry wormhole, only on the destination wormhole.
TagsNo tags attached.

Activities

AnnoyingOrange

Jul 10, 2019 8:41 am

reporter  

displacement test.savemet (64 bytes)
displacement test.save (234,863 bytes)

x4000Bughunter

Jul 10, 2019 11:46 am

administrator   ~0052151

Is it the centerpiece, or the ships coming out of the centerpiece? We probably need a new flag that says they are never pushed out of the way by anything if they generate a forcefield.

AnnoyingOrange

Jul 10, 2019 12:45 pm

reporter   ~0052153

It's certainly the centerpiece in the attached save, as all of its ships are loaded within it, and I have not been able to reproduce using only non-centerpiece ships.

wm46

Jul 10, 2019 12:54 pm

reporter   ~0052154

I've noticed it a lot with ships coming out of wormholes. So if you try blocking the wormhole with a shield generator, ships that spew from the wormhole tend to knock it away.

AnnoyingOrange

Jul 10, 2019 1:09 pm

reporter   ~0052155

You mean enemy or friendly ships?
I tested with player ships mostly, so perhaps there's a difference between the two.

wm46

Jul 10, 2019 1:49 pm

reporter   ~0052158

Well I did a double check and you're right, it's only when flagships go through the wormhole, both coming in and going out of the planet. It works just fine when fleet ships and frigates do it though.


I actually found the reason in the XML:

All Arks and the Transport Flagship have their collision priority set at 10,000 but the shield generators are set at 900. 900 is higher than all golems, frigates, and fleetships, Arks and Transports are the only mobile ships that are higher than shield generators and thus push them around.

x4000Bughunter

Jul 10, 2019 3:29 pm

administrator   ~0052161

Could you try setting the shield generators to 11,000 and see if that fixes it? If so, that's a wonderfully easy fix, heh.

AnnoyingOrange

Jul 11, 2019 6:26 am

reporter   ~0052176

Setting collision_priority to 11000 for entity ForcefieldGenerator in KDL_Ships_NonTurretDefenses.xml fixes the issue for normal forcefields generators, but not for home forcefield generators: and those are supposed to inherit it from the basic forcefield generator as they don't have a collision_priority value declared in the xml.

x4000Bughunter

Jul 11, 2019 9:37 am

administrator   ~0052179

Hmm, I'm not sure why that wouldn't work, but I'd try setting it explicitly and see if that solves it.

x4000Bughunter

Jul 12, 2019 12:35 pm

administrator   ~0052202

Thanks!

* Fixed-position forcefield generators should no longer be pushed around by flagships. This hasn't been fully tested, so if you see it more, or other variants, please let us know!

Issue History

Date Modified Username Field Change
Jul 10, 2019 8:41 am AnnoyingOrange New Issue
Jul 10, 2019 8:41 am AnnoyingOrange File Added: displacement test.save
Jul 10, 2019 8:41 am AnnoyingOrange File Added: displacement test.savemet
Jul 10, 2019 11:46 am x4000Bughunter Note Added: 0052151
Jul 10, 2019 12:45 pm AnnoyingOrange Note Added: 0052153
Jul 10, 2019 12:54 pm wm46 Note Added: 0052154
Jul 10, 2019 1:09 pm AnnoyingOrange Note Added: 0052155
Jul 10, 2019 1:49 pm wm46 Note Added: 0052158
Jul 10, 2019 3:29 pm x4000Bughunter Note Added: 0052161
Jul 11, 2019 6:26 am AnnoyingOrange Note Added: 0052176
Jul 11, 2019 9:37 am x4000Bughunter Note Added: 0052179
Jul 12, 2019 12:35 pm x4000Bughunter Assigned To => x4000Bughunter
Jul 12, 2019 12:35 pm x4000Bughunter Status new => resolved
Jul 12, 2019 12:35 pm x4000Bughunter Resolution open => fixed
Jul 12, 2019 12:35 pm x4000Bughunter Fixed in Version => 0.875 Counterattacks You Can Taste
Jul 12, 2019 12:35 pm x4000Bughunter Note Added: 0052202